aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2008-11-16 23:55:16 +0000
committerWesley Shields <wxs@FreeBSD.org>2008-11-16 23:55:16 +0000
commit7c445d05edcf0ffd18714481a0712fdfb3a9bdc2 (patch)
tree94ac752312177d6b85f937de379ed1f0e0c11a83 /databases
parente7ec142f0aab3b50a0c3d85479f923061ceba465 (diff)
downloadports-7c445d05edcf0ffd18714481a0712fdfb3a9bdc2.tar.gz
ports-7c445d05edcf0ffd18714481a0712fdfb3a9bdc2.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/couchdb/Makefile24
-rw-r--r--databases/couchdb/distinfo6
-rw-r--r--databases/couchdb/pkg-plist194
3 files changed, 94 insertions, 130 deletions
diff --git a/databases/couchdb/Makefile b/databases/couchdb/Makefile
index b405ead16a50..47fb055c0ec8 100644
--- a/databases/couchdb/Makefile
+++ b/databases/couchdb/Makefile
@@ -6,15 +6,17 @@
#
PORTNAME= couchdb
-PORTVERSION= 0.7.0
+PORTVERSION= 0.9.0a
CATEGORIES= databases
-MASTER_SITES= http://couchdb.googlecode.com/files/
+MASTER_SITES= http://people.apache.org/~nslater/build/latest/
+DISTNAME= apache-couchdb-0.9.0a-incubating
-MAINTAINER= ditesh@gathani.org
+MAINTAINER= jan@apache.org
COMMENT= A document database server, accessible via a RESTful JSON API
-LIB_DEPENDS= icudata:${PORTSDIR}/devel/icu
-BUILD_DEPENDS= ${LOCALBASE}/lib/erlang/usr/include/erl_driver.h:${PORTSDIR}/lang/erlang
+LIB_DEPENDS= icudata:${PORTSDIR}/devel/icu \
+ js:${PORTSDIR}/lang/spidermonkey
+BUILD_DEPENDS= ${LOCALBASE}/lib/erlang/usr/include/erl_driver.h:${PORTSDIR}/lang/erlang-lite
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_GMAKE= yes
@@ -23,15 +25,13 @@ USE_LDCONFIG= yes
CONFIGURE_ARGS= --with-erlang=${LOCALBASE}/lib/erlang/usr/include \
--localstatedir=/var \
-post-patch:
- @${REINPLACE_CMD} -e "s|),Linux|),FreeBSD|g" ${WRKSRC}/src/js/config.mk
-
MAN1= couchdb.1 couchjs.1
-.include <bsd.port.pre.mk>
+PLIST_SUB= COUCHVERSION=couch-${PORTVERSION}-incubating
-.if ${ARCH} != "i386"
-BROKEN= does not compile
+post-patch:
+.if defined(NOPORTDOCS)
+ ${REINPLACE_CMD} -e 's/install-data-am$$//' ${WRKSRC}/Makefile.in
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/couchdb/distinfo b/databases/couchdb/distinfo
index e492cbfb8577..cae8166daed9 100644
--- a/databases/couchdb/distinfo
+++ b/databases/couchdb/distinfo
@@ -1,3 +1,3 @@
-MD5 (couchdb-0.7.0.tar.gz) = 2e214874e9063cc178bde7ab0f703b89
-SHA256 (couchdb-0.7.0.tar.gz) = 34311f849512e557e565417fd97a87a8db8cf704956373a83613606e9a545ecd
-SIZE (couchdb-0.7.0.tar.gz) = 1602625
+MD5 (apache-couchdb-0.9.0a-incubating.tar.gz) = a4bee75260a7e89de600841f392b846c
+SHA256 (apache-couchdb-0.9.0a-incubating.tar.gz) = 790dd3f12051ff1e92f4f7cfd840cdfd4d4efd241e2ee56a706f195dd3e914d3
+SIZE (apache-couchdb-0.9.0a-incubating.tar.gz) = 567412
diff --git a/databases/couchdb/pkg-plist b/databases/couchdb/pkg-plist
index 2de358dd8caa..f482e88afd46 100644
--- a/databases/couchdb/pkg-plist
+++ b/databases/couchdb/pkg-plist
@@ -1,110 +1,65 @@
bin/couchdb
bin/couchjs
-%%ETCDIR%%/conf/mime.types
%%ETCDIR%%/couch.ini
-%%ETCDIR%%/couch_httpd.conf
+etc/logrotate.d/couchdb
etc/default/couchdb
etc/rc.d/couchdb
-lib/couchdb/bin/_couchjs
-lib/couchdb/erlang/bin/couch.boot
-lib/couchdb/erlang/lib/couch-0.7.0/ebin/cjson.beam
-lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch.app
-lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_btree.beam
-lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_db.beam
-lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_db_sup.beam
-lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_db_update_notifier.beam
-lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_doc.beam
-lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_event_sup.beam
-lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_file.beam
-lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_ft_query.beam
-lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_log.beam
-lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_query_servers.beam
-lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_rep.beam
-lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_server.beam
-lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_server_sup.beam
-lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_stream.beam
-lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_util.beam
-lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_view_group.beam
-lib/couchdb/erlang/lib/couch-0.7.0/ebin/mod_couch.beam
-lib/couchdb/erlang/lib/couch-0.7.0/include/couch_db.hrl
-lib/couchdb/erlang/lib/couch-0.7.0/priv/lib/couch_erl_driver.a
-lib/couchdb/erlang/lib/couch-0.7.0/priv/lib/couch_erl_driver.la
-lib/couchdb/erlang/lib/couch-0.7.0/priv/lib/couch_erl_driver.so
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/couch_inets.app
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/ftp.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/ftp_progress.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/ftp_response.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/ftp_sup.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/http.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/http_base_64.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/http_chunk.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/http_cookie.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/http_request.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/http_response.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/http_transport.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/http_uri.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/http_util.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpc_handler.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpc_manager.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpc_request.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpc_response.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpc_sup.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_acceptor.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_acceptor_sup.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_cgi.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_conf.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_esi.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_example.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_instance_sup.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_manager.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_misc_sup.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_request.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_request_handler.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_response.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_script_env.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_socket.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_sup.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_util.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/inets.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/inets_app.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/inets_sup.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_actions.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_alias.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_auth.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_auth_dets.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_auth_mnesia.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_auth_plain.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_auth_server.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_browser.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_cgi.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_dir.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_disk_log.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_esi.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_get.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_head.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_htaccess.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_include.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_log.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_range.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_responsecontrol.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_security.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_security_server.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_trace.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/tftp.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/tftp_binary.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/tftp_engine.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/tftp_file.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/tftp_lib.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/tftp_sup.beam
-lib/couchdb/erlang/lib/couch_inets-4.7.5/include/ftp_internal.hrl
-lib/couchdb/erlang/lib/couch_inets-4.7.5/include/http_internal.hrl
-lib/couchdb/erlang/lib/couch_inets-4.7.5/include/httpc_internal.hrl
-lib/couchdb/erlang/lib/couch_inets-4.7.5/include/httpd.hrl
-lib/couchdb/erlang/lib/couch_inets-4.7.5/include/inets_internal.hrl
-lib/couchdb/erlang/lib/couch_inets-4.7.5/include/mod_auth.hrl
-lib/couchdb/erlang/lib/couch_inets-4.7.5/include/tftp.hrl
+lib/couchdb/bin/couchjs
+lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/cjson.beam
+lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch.app
+lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_btree.beam
+lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_db.beam
+lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_db_update_notifier.beam
+lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_db_updater.beam
+lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_doc.beam
+lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_event_sup.beam
+lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_file.beam
+lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_ft_query.beam
+lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_httpd.beam
+lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_key_tree.beam
+lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_log.beam
+lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_query_servers.beam
+lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_rep.beam
+lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_server.beam
+lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_server_sup.beam
+lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_stream.beam
+lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_util.beam
+lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_view.beam
+lib/couchdb/erlang/lib/%%COUCHVERSION%%/include/couch_db.hrl
+lib/couchdb/erlang/lib/%%COUCHVERSION%%/priv/lib/couch_erl_driver.a
+lib/couchdb/erlang/lib/%%COUCHVERSION%%/priv/lib/couch_erl_driver.la
+lib/couchdb/erlang/lib/%%COUCHVERSION%%/priv/lib/couch_erl_driver.so
+lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb.app
+lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb_request.beam
+lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb_response.beam
+lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb_util.beam
+lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb_charref.beam
+lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb_app.beam
+lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochifmt_std.beam
+lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb_skel.beam
+lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb_sup.beam
+lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochinum.beam
+lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb_http.beam
+lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb_multipart.beam
+lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb_socket_server.beam
+lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb.beam
+lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochijson2.beam
+lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochifmt_records.beam
+lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb_headers.beam
+lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochihex.beam
+lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb_echo.beam
+lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb_cookies.beam
+lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb_html.beam
+lib/couchdb/erlang/lib/mochiweb-r82/ebin/reloader.beam
+lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochifmt.beam
+lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochijson.beam
%%DATADIR%%/server/main.js
+%%DATADIR%%/www/browse/_create_document.html
+%%DATADIR%%/www/browse/_create_database.html
+%%DATADIR%%/www/browse/_delete_database.html
+%%DATADIR%%/www/browse/_compact_database.html
+%%DATADIR%%/www/browse/_delete_document.html
+%%DATADIR%%/www/browse/_save_view_as.html
%%DATADIR%%/www/browse/database.html
%%DATADIR%%/www/browse/document.html
%%DATADIR%%/www/browse/index.html
@@ -114,38 +69,49 @@ lib/couchdb/erlang/lib/couch_inets-4.7.5/include/tftp.hrl
%%DATADIR%%/www/image/apply.gif
%%DATADIR%%/www/image/bg.png
%%DATADIR%%/www/image/cancel.gif
+%%DATADIR%%/www/image/compact.gif
%%DATADIR%%/www/image/delete-mini.gif
%%DATADIR%%/www/image/delete.gif
+%%DATADIR%%/www/image/grippie.gif
%%DATADIR%%/www/image/hgrad.gif
%%DATADIR%%/www/image/load.gif
%%DATADIR%%/www/image/logo.png
+%%DATADIR%%/www/image/order-asc.gif
+%%DATADIR%%/www/image/order-desc.gif
%%DATADIR%%/www/image/path.gif
+%%DATADIR%%/www/image/progress.gif
%%DATADIR%%/www/image/run-mini.gif
%%DATADIR%%/www/image/run.gif
%%DATADIR%%/www/image/running.gif
%%DATADIR%%/www/image/save.gif
+%%DATADIR%%/www/image/spinner.gif
%%DATADIR%%/www/image/test_failure.gif
%%DATADIR%%/www/image/test_success.gif
+%%DATADIR%%/www/image/thead-key.gif
%%DATADIR%%/www/image/thead.gif
%%DATADIR%%/www/image/toggle-collapse.gif
%%DATADIR%%/www/image/toggle-expand.gif
+%%DATADIR%%/www/image/twisty.gif
%%DATADIR%%/www/index.html
%%DATADIR%%/www/replicator.html
%%DATADIR%%/www/script/browse.js
%%DATADIR%%/www/script/couch.js
%%DATADIR%%/www/script/couch_tests.js
+%%DATADIR%%/www/script/jquery.dialog.js
+%%DATADIR%%/www/script/jquery.suggest.js
+%%DATADIR%%/www/script/jquery.couch.js
+%%DATADIR%%/www/script/jquery.cookies.js
+%%DATADIR%%/www/script/jquery.resizer.js
%%DATADIR%%/www/script/jquery.js
-%%DATADIR%%/www/script/json.js
+%%DATADIR%%/www/script/json2.js
%%DATADIR%%/www/script/pprint.js
-%%DATADIR%%/www/script/shell.js
-%%DATADIR%%/www/shell.html
%%DATADIR%%/www/style/layout.css
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS.gz
%%PORTDOCS%%%%DOCSDIR%%/BUGS.gz
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES.gz
%%PORTDOCS%%%%DOCSDIR%%/NEWS.gz
%%PORTDOCS%%%%DOCSDIR%%/README.gz
%%PORTDOCS%%%%DOCSDIR%%/THANKS.gz
-%%PORTDOCS%%%%DOCSDIR%%/changelog.gz
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%/www/style
@dirrm %%DATADIR%%/www/script
@@ -154,19 +120,17 @@ lib/couchdb/erlang/lib/couch_inets-4.7.5/include/tftp.hrl
@dirrm %%DATADIR%%/www
@dirrm %%DATADIR%%/server
@dirrm %%DATADIR%%
-@dirrm lib/couchdb/erlang/lib/couch_inets-4.7.5/include
-@dirrm lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin
-@dirrm lib/couchdb/erlang/lib/couch_inets-4.7.5
-@dirrm lib/couchdb/erlang/lib/couch-0.7.0/priv/lib
-@dirrm lib/couchdb/erlang/lib/couch-0.7.0/priv
-@dirrm lib/couchdb/erlang/lib/couch-0.7.0/include
-@dirrm lib/couchdb/erlang/lib/couch-0.7.0/ebin
-@dirrm lib/couchdb/erlang/lib/couch-0.7.0
+@dirrm lib/couchdb/erlang/lib/%%COUCHVERSION%%/priv/lib
+@dirrm lib/couchdb/erlang/lib/%%COUCHVERSION%%/priv
+@dirrm lib/couchdb/erlang/lib/%%COUCHVERSION%%/include
+@dirrm lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin
+@dirrm lib/couchdb/erlang/lib/mochiweb-r82/ebin
+@dirrm lib/couchdb/erlang/lib/mochiweb-r82
+@dirrm lib/couchdb/erlang/lib/%%COUCHVERSION%%
@dirrm lib/couchdb/erlang/lib
-@dirrm lib/couchdb/erlang/bin
@dirrm lib/couchdb/erlang
@dirrm lib/couchdb/bin
@dirrm lib/couchdb
@dirrm etc/default
-@dirrm %%ETCDIR%%/conf
+@dirrm etc/logrotate.d
@dirrm %%ETCDIR%%