aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-23 16:20:31 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-23 16:20:31 +0000
commit7d007bcd73c29ea05a0c4334d65c604ef91a71fc (patch)
treea5aeb5730e3132c29c90c2c1e76a7d1466d52c47 /databases
parent6bb3f7b978589cc2a3525cf9b827a3fcf24c4c07 (diff)
downloadports-7d007bcd73c29ea05a0c4334d65c604ef91a71fc.tar.gz
ports-7d007bcd73c29ea05a0c4334d65c604ef91a71fc.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pear-Structures_DataGrid_DataSource_DB/Makefile25
-rw-r--r--databases/pear-Structures_DataGrid_DataSource_DB/distinfo3
-rw-r--r--databases/pear-Structures_DataGrid_DataSource_DB/pkg-descr5
4 files changed, 34 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 023bec576235..71b25ba80764 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -386,6 +386,7 @@
SUBDIR += pear-MDB_QueryTool
SUBDIR += pear-Structures_DataGrid_DataSource_Array
SUBDIR += pear-Structures_DataGrid_DataSource_CSV
+ SUBDIR += pear-Structures_DataGrid_DataSource_DB
SUBDIR += pear-Structures_DataGrid_DataSource_DBQuery
SUBDIR += pear-Structures_DataGrid_DataSource_DBTable
SUBDIR += pear-Structures_DataGrid_DataSource_DataObject
diff --git a/databases/pear-Structures_DataGrid_DataSource_DB/Makefile b/databases/pear-Structures_DataGrid_DataSource_DB/Makefile
new file mode 100644
index 000000000000..1575f93c98f0
--- /dev/null
+++ b/databases/pear-Structures_DataGrid_DataSource_DB/Makefile
@@ -0,0 +1,25 @@
+# Ports collection makefile for: pear-Structures_DataGrid_DataSource_DB
+# Date created: 26 Jun 2008
+# Whom: Nick Hilliard <nick@foobar.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Structures_DataGrid_DataSource_DB
+PORTVERSION= 0.1.1
+CATEGORIES= databases www pear
+
+MAINTAINER= nick@foobar.org
+COMMENT= DB datasource driver for pear-Structures_DataGrid
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:${PORTSDIR}/devel/pear-Structures_DataGrid \
+ ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB \
+ ${PEARDIR}/Structures/DataGrid/DataSource/Array.php:${PORTSDIR}/databases/pear-Structures_DataGrid_DataSource_Array
+
+CATEGORY= Structures
+FILES= DataGrid/DataSource/DB.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/databases/pear-Structures_DataGrid_DataSource_DB/distinfo b/databases/pear-Structures_DataGrid_DataSource_DB/distinfo
new file mode 100644
index 000000000000..a5421c498867
--- /dev/null
+++ b/databases/pear-Structures_DataGrid_DataSource_DB/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Structures_DataGrid_DataSource_DB-0.1.1.tgz) = c0d2c0b1dd4a027adffd98aa82747890
+SHA256 (PEAR/Structures_DataGrid_DataSource_DB-0.1.1.tgz) = 070040b0a713790c0cc18e2e0e5ccdeb34ec06d721bd1fb1e5f2e28789e795f9
+SIZE (PEAR/Structures_DataGrid_DataSource_DB-0.1.1.tgz) = 2433
diff --git a/databases/pear-Structures_DataGrid_DataSource_DB/pkg-descr b/databases/pear-Structures_DataGrid_DataSource_DB/pkg-descr
new file mode 100644
index 000000000000..fbfcad91f547
--- /dev/null
+++ b/databases/pear-Structures_DataGrid_DataSource_DB/pkg-descr
@@ -0,0 +1,5 @@
+This is DataSource driver for Structures_DataGrid which uses PEAR::DB.
+Please note that this driver is deprecated. Consider using DBQuery or MDB2
+DataSource drivers instead.
+
+WWW: http://pear.php.net/package/Structures_DataGrid_DataSource_DB/