aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-05-16 06:27:56 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-05-16 06:27:56 +0000
commitabf5b5ffc09b367c1d6e4537c8f5e2473c14e670 (patch)
tree2e22cb4768c6b41b24fe161ae7a3c7a4536ed6c0 /databases
parent184f8b1f5a5dce5332d9b8f4bb170da1df68af6a (diff)
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/gnatsweb4/Makefile2
-rw-r--r--databases/p5-ApacheDBILogConfig/Makefile2
-rw-r--r--databases/p5-ApacheDBILogger/Makefile2
-rw-r--r--databases/p5-DBIx-Browse/Makefile2
-rw-r--r--databases/p5-DBIx-Tree/Makefile2
-rw-r--r--databases/p5-GDBM/Makefile2
-rw-r--r--databases/tokyocabinet/Makefile2
7 files changed, 14 insertions, 0 deletions
diff --git a/databases/gnatsweb4/Makefile b/databases/gnatsweb4/Makefile
index 0ad66357d96b..92996dcc7e8c 100644
--- a/databases/gnatsweb4/Makefile
+++ b/databases/gnatsweb4/Makefile
@@ -16,6 +16,8 @@ COMMENT= Gnatsweb, a GNATS web interface
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 2.0+
USE_PERL5_RUN= yes
diff --git a/databases/p5-ApacheDBILogConfig/Makefile b/databases/p5-ApacheDBILogConfig/Makefile
index edeef1e63de1..1d28ed336991 100644
--- a/databases/p5-ApacheDBILogConfig/Makefile
+++ b/databases/p5-ApacheDBILogConfig/Makefile
@@ -19,6 +19,8 @@ BUILD_DEPENDS= ${SITE_PERL}/Apache/DBI.pm:${PORTSDIR}/www/p5-Apache-DBI \
${LOCALBASE}/libexec/apache/libperl.so:${PORTSDIR}/www/mod_perl
RUN_DEPENDS= ${BUILD_DEPENDS}
+MAKE_JOBS_SAFE= yes
+
PERL_CONFIGURE= yes
MAN3= Apache::DBILogConfig.3
diff --git a/databases/p5-ApacheDBILogger/Makefile b/databases/p5-ApacheDBILogger/Makefile
index 79185d996c89..77f2a70f80db 100644
--- a/databases/p5-ApacheDBILogger/Makefile
+++ b/databases/p5-ApacheDBILogger/Makefile
@@ -17,6 +17,8 @@ COMMENT= A module that tracks what's being transferred in a DBI database
BUILD_DEPENDS= ${SITE_PERL}/Apache/DBI.pm:${PORTSDIR}/www/p5-Apache-DBI \
${LOCALBASE}/libexec/apache/libperl.so:${PORTSDIR}/www/mod_perl
+MAKE_JOBS_SAFE= yes
+
PERL_CONFIGURE= yes
MAN3= Apache::DBILogger.3
diff --git a/databases/p5-DBIx-Browse/Makefile b/databases/p5-DBIx-Browse/Makefile
index d02a0aa2d1e9..1dd4b9ad9d33 100644
--- a/databases/p5-DBIx-Browse/Makefile
+++ b/databases/p5-DBIx-Browse/Makefile
@@ -17,6 +17,8 @@ COMMENT= DBIx::Browse - Perl extension to browse tables
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+MAKE_JOBS_SAFE= yes
+
PERL_CONFIGURE= yes
MAN3= DBIx::Browse::CGI.3 \
diff --git a/databases/p5-DBIx-Tree/Makefile b/databases/p5-DBIx-Tree/Makefile
index 802ee8d44833..809fa89ec2f2 100644
--- a/databases/p5-DBIx-Tree/Makefile
+++ b/databases/p5-DBIx-Tree/Makefile
@@ -17,6 +17,8 @@ COMMENT= Perl module for generating a tree from a self-referential table
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+MAKE_JOBS_SAFE= yes
+
PERL_CONFIGURE= yes
MAN3= DBIx::Tree.3
diff --git a/databases/p5-GDBM/Makefile b/databases/p5-GDBM/Makefile
index 47370d3010c3..928e5c736d04 100644
--- a/databases/p5-GDBM/Makefile
+++ b/databases/p5-GDBM/Makefile
@@ -20,6 +20,8 @@ COMMENT= GNU Data Base Manager (gdbm) interface
LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
+MAKE_JOBS_SAFE= yes
+
USE_BZIP2= yes
PERL_CONFIGURE= 5.8.0+
EXTRACT_AFTER_ARGS= | ${TAR} -xf - ${DISTNAME}/ext/GDBM_File
diff --git a/databases/tokyocabinet/Makefile b/databases/tokyocabinet/Makefile
index 0b2571cffffb..e396fee71e12 100644
--- a/databases/tokyocabinet/Makefile
+++ b/databases/tokyocabinet/Makefile
@@ -13,6 +13,8 @@ MASTER_SITES= SF
MAINTAINER= pgollucci@FreeBSD.org
COMMENT= A modern implementation of DBM
+MAKE_JOBS_SAFE= yes
+
CONFIGURE_ARGS= --enable-off64
GNU_CONFIGURE= yes
USE_GMAKE= yes