aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-10-03 22:44:56 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-10-03 22:44:56 +0000
commitbf149172eb4bde1861d3e54d83615ff8c27b0925 (patch)
treee2342fc23e82c34a9f490d4aa8930d00cbc7698b /databases
parentd7c299a53514e4303577efe3421c9ceead9f9e30 (diff)
downloadports-bf149172eb4bde1861d3e54d83615ff8c27b0925.tar.gz
ports-bf149172eb4bde1861d3e54d83615ff8c27b0925.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/libudbc/Makefile14
-rw-r--r--databases/mysql41-server/Makefile16
2 files changed, 3 insertions, 27 deletions
diff --git a/databases/libudbc/Makefile b/databases/libudbc/Makefile
index c76148c7fced..b704011f2958 100644
--- a/databases/libudbc/Makefile
+++ b/databases/libudbc/Makefile
@@ -14,6 +14,8 @@ MASTER_SITES= ftp://ftp.openlinksw.co.uk/open41/ \
DISTNAME= f6kuzzzz
EXTRACT_SUFX= .taz
+LIB_DEPENDS= c.4:${PORTSDIR}/misc/compat4x
+
MAINTAINER= eugen@grosbein.pp.ru
COMMENT= Openlink UDBC SDK
@@ -51,14 +53,4 @@ post-install:
@${SED} "s'PREFIX'${PREFIX}'" <pkg-message
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500000
-LIB_DEPENDS+= c.4:${PORTSDIR}/misc/compat4x
-.endif
-
-.if ${OSVERSION} < 400000
-IGNORE= "Systems prior to 4.x are not supported"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/mysql41-server/Makefile b/databases/mysql41-server/Makefile
index 161ad2656bd2..40c1a31ce619 100644
--- a/databases/mysql41-server/Makefile
+++ b/databases/mysql41-server/Makefile
@@ -70,35 +70,19 @@ CONFIGURE_ARGS+=--with-named-thread-libs='-DHAVE_GLIBC2_STYLE_GETHOSTBYNAME_R
CONFIGURE_ARGS+=-D_THREAD_SAFE -I${LOCALBASE}/include/pthread/linuxthreads
CFLAGS+= -D__USE_UNIX98 -D_REENTRANT -D_THREAD_SAFE
CFLAGS+= -I${LOCALBASE}/include/pthread/linuxthreads
-.if ${OSVERSION} > 500000
LIB_DEPENDS+= lthread.[35]:${PORTSDIR}/devel/linuxthreads
CONFIGURE_ARGS+=-L${LOCALBASE}/lib -llthread -llgcc_r -llstdc++ -llsupc++'
.else
-LIB_DEPENDS+= lthread.[24]:${PORTSDIR}/devel/linuxthreads
-CONFIGURE_ARGS+=-L${LOCALBASE}/lib -llthread -llgcc_r'
-.endif
-.else
CONFIGURE_ARGS+=--with-named-thread-libs=${PTHREAD_LIBS}
CFLAGS+= ${PTHREAD_CFLAGS}
.endif
-.if ${OSVERSION} < 500000
-LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CXX= ${CC}
-.endif
.if defined(BUILD_OPTIMIZED)
CFLAGS+= -O3 -fno-omit-frame-pointer
-.if ${OSVERSION} > 500000 || (defined(USE_GCC) && (${USE_GCC} == 3.0 || ${USE_GCC} == 3.1 || ${USE_GCC} == 3.2 || ${USE_GCC} == 3.3))
CFLAGS+= -fno-gcse
.endif
-.endif
CXXFLAGS+= ${CFLAGS} -felide-constructors -fno-rtti
-.if ${OSVERSION} >= 400002
CXXFLAGS+= -fno-exceptions
-.endif
# MySQL-Server part
.if !defined(CLIENT_ONLY) && !defined(SCRIPTS_ONLY)