aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-02-03 20:10:37 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-02-03 20:10:37 +0000
commitcb8b1428c6bb9ed135f61a9cecbe8397defbf329 (patch)
tree0a68a09c88303888985b47f7045bed36788aefc2 /databases
parent563bcaab10c891e4bee07c4ec1fbf46515c5a0b4 (diff)
downloadports-cb8b1428c6bb9ed135f61a9cecbe8397defbf329.tar.gz
ports-cb8b1428c6bb9ed135f61a9cecbe8397defbf329.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/akonadi/Makefile15
-rw-r--r--databases/akonadi/distinfo4
-rw-r--r--databases/akonadi/files/patch-server__src__nepomuk__queryserviceclient.h28
-rw-r--r--databases/akonadi/pkg-plist2
4 files changed, 10 insertions, 39 deletions
diff --git a/databases/akonadi/Makefile b/databases/akonadi/Makefile
index 660e6b8ac09f..521d318b104c 100644
--- a/databases/akonadi/Makefile
+++ b/databases/akonadi/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= akonadi
-PORTVERSION= 1.7.2
-PORTREVISION= 4
+PORTVERSION= 1.9.0
CATEGORIES= databases kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTNAME}/src/
@@ -13,11 +12,10 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Storage server for KDE-Pim
LICENSE= LGPL21
-LICENSE_FILE= ${WRKSRC}/lgpl-license
LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs
# Let process generate meaningful backtrace on core dump.
-LIB_DEPENDS+= execinfo.1:${PORTSDIR}/devel/libexecinfo
+LIB_DEPENDS+= execinfo:${PORTSDIR}/devel/libexecinfo
BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
USE_KDE4= kdehier kdeprefix sharedmime automoc4 soprano
@@ -32,12 +30,12 @@ MAKE_JOBS_UNSAFE= yes
PLIST_SUB+= QT_PREFIX=${QT_PREFIX}
-OPTIONS_MULTI= BACKEND
-OPTIONS_MULTI_BACKEND= MYSQL PGSQL SQLITE
+OPTIONS_MULTI= DB
+OPTIONS_MULTI_DB= MYSQL PGSQL SQLITE
MYSQL_DESC= Install MySQL Qt plugin and server
PGSQL_DESC= Install PostgreSQL Qt plugin
-SQLITE_DESC= Enable SQLite backend (unused)
+SQLITE_DESC= Enable SQLite backend
OPTIONS_DEFAULT= MYSQL
@@ -80,7 +78,8 @@ post-patch:
${REINPLACE_CMD} -e '/wait_timeout/ s|31536000|1073741|' \
${PATCH_WRKSRC}/server/src/storage/*.conf
# Prevent updating MIME during build.
- ${REINPLACE_CMD} -e '/^update_xdg_mimetypes/ d; /SharedMimeInfo/ d' \
+ ${REINPLACE_CMD} -e '/^update_xdg_mimetypes/ d' \
+ -e '/find_package(SharedMimeInfo/ d' \
${PATCH_WRKSRC}/CMakeLists.txt
post-install:
diff --git a/databases/akonadi/distinfo b/databases/akonadi/distinfo
index 3689167b4b6e..21ecb293346b 100644
--- a/databases/akonadi/distinfo
+++ b/databases/akonadi/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/akonadi-1.7.2.tar.bz2) = 4b7217a847c6859a529f07bf456127dab4aac69694982ca449a80da510832b1f
-SIZE (KDE/akonadi-1.7.2.tar.bz2) = 210944
+SHA256 (KDE/akonadi-1.9.0.tar.bz2) = 6ff5c23e426efc02784d4ab1a6e6dff24c8efe81fd34ec78bb52bb4d7733e013
+SIZE (KDE/akonadi-1.9.0.tar.bz2) = 220255
diff --git a/databases/akonadi/files/patch-server__src__nepomuk__queryserviceclient.h b/databases/akonadi/files/patch-server__src__nepomuk__queryserviceclient.h
deleted file mode 100644
index 6340f9ae2192..000000000000
--- a/databases/akonadi/files/patch-server__src__nepomuk__queryserviceclient.h
+++ /dev/null
@@ -1,28 +0,0 @@
-commit 1ce93440f9dbfcd01a3f4c11119f120e82a7dfb2
-Author: Christophe Giboudeaux <cgiboudeaux@gmx.com>
-Date: Sat Jan 21 18:29:43 2012 +0100
-
- Build with Clang.
-
-diff --git a/server/src/nepomuk/queryserviceclient.h b/server/src/nepomuk/queryserviceclient.h
-index a0e7517..3c551a0 100644
---- ./server/src/nepomuk/queryserviceclient.h
-+++ ./server/src/nepomuk/queryserviceclient.h
-@@ -78,7 +78,7 @@ namespace Nepomuk {
- *
- * \sa QueryParser
- */
-- bool query( const QString& query, const QHash<QString, QString> &encodedRps = QHash<QString, QString>() );
-+ bool query(const QString& query, const QHash<QString, QString> &encodedRps = ( QHash<QString, QString>() ) );
-
- /**
- * Start a query using the Nepomuk user query language.
-@@ -96,7 +96,7 @@ namespace Nepomuk {
- *
- * \sa query(const QString&), close()
- */
-- bool blockingQuery( const QString& query, const QHash<QString, QString> &encodedRps = QHash<QString, QString>() );
-+ bool blockingQuery( const QString& query, const QHash<QString, QString> &encodedRps = ( QHash<QString, QString>() ) );
-
- /**
- * Close the client, thus stop to monitor the query
diff --git a/databases/akonadi/pkg-plist b/databases/akonadi/pkg-plist
index 31176ca4dc37..7336930b5711 100644
--- a/databases/akonadi/pkg-plist
+++ b/databases/akonadi/pkg-plist
@@ -17,7 +17,7 @@ lib/cmake/Akonadi/AkonadiTargetsWithPrefix-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/Akonadi/AkonadiTargetsWithPrefix.cmake
lib/libakonadiprotocolinternals.so
lib/libakonadiprotocolinternals.so.1
-lib/libakonadiprotocolinternals.so.1.7.2
+lib/libakonadiprotocolinternals.so.1.9.0
libdata/pkgconfig/akonadi.pc
share/config/akonadi/mysql-global-mobile.conf
share/config/akonadi/mysql-global.conf