aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-06-17 02:37:15 +0000
committerWill Andrews <will@FreeBSD.org>2000-06-17 02:37:15 +0000
commit1e60866cc19e399726a715fe8f90de75614755d9 (patch)
tree919603a1bf324ecbe31827d6a9441e11e58f98a0 /databases
parent30563b53998852429b379c5698be8bc307cc56ca (diff)
downloadports-1e60866cc19e399726a715fe8f90de75614755d9.tar.gz
ports-1e60866cc19e399726a715fe8f90de75614755d9.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/p5-DBD-CSV/Makefile4
-rw-r--r--databases/p5-DBD-Pg-13/Makefile11
-rw-r--r--databases/p5-DBD-Pg/Makefile11
-rw-r--r--databases/p5-DBD-mysql/Makefile8
-rw-r--r--databases/p5-DBI-137/Makefile10
-rw-r--r--databases/p5-DBI/Makefile10
-rw-r--r--databases/p5-GDBM/Makefile9
-rw-r--r--databases/p5-MLDBM/Makefile6
-rw-r--r--databases/p5-Mysql/Makefile8
-rw-r--r--databases/p5-Pg/Makefile8
-rw-r--r--databases/p5-SQL-Statement/Makefile9
-rw-r--r--databases/p5-hp200lx-db/Makefile8
12 files changed, 55 insertions, 47 deletions
diff --git a/databases/p5-DBD-CSV/Makefile b/databases/p5-DBD-CSV/Makefile
index d6126849aaf8..1a94a16cf932 100644
--- a/databases/p5-DBD-CSV/Makefile
+++ b/databases/p5-DBD-CSV/Makefile
@@ -5,12 +5,12 @@
# $FreeBSD$
#
-PORTNAME= p5-DBD-CSV
+PORTNAME= DBD-CSV
PORTVERSION= 0.1022
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= DBD
-DISTNAME= DBD-CSV-${PORTVERSION}
+PKGNAMEPREFIX= p5-
MAINTAINER= dirk.meyer@dinoex.sub.org
diff --git a/databases/p5-DBD-Pg-13/Makefile b/databases/p5-DBD-Pg-13/Makefile
index c5e3167831a5..cbe362cf3ff7 100644
--- a/databases/p5-DBD-Pg-13/Makefile
+++ b/databases/p5-DBD-Pg-13/Makefile
@@ -5,25 +5,26 @@
# $FreeBSD$
#
-PORTNAME= p5-DBD-Pg
+PORTNAME= DBD-Pg
PORTVERSION= 0.93
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= DBD
-DISTNAME= DBD-Pg-${PORTVERSION}
+PKGNAMEPREFIX= p5-
MAINTAINER= jfitz@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql
-USE_PERL5= YES
-CONFIGURE_ENV= POSTGRES_INCLUDE=${PREFIX}/pgsql/include POSTGRES_LIB=${PREFIX}/pgsql/lib
+USE_PERL5= yes
+MAKE_ENV= POSTGRES_INCLUDE=${PREFIX}/pgsql/include POSTGRES_LIB=${PREFIX}/pgsql/lib
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= DBD::Pg.3 DBD::dbd-pg.3
do-configure:
- @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ CC="${CC}" CCFLAGS="${CFLAGS}"
.include <bsd.port.mk>
diff --git a/databases/p5-DBD-Pg/Makefile b/databases/p5-DBD-Pg/Makefile
index c5e3167831a5..cbe362cf3ff7 100644
--- a/databases/p5-DBD-Pg/Makefile
+++ b/databases/p5-DBD-Pg/Makefile
@@ -5,25 +5,26 @@
# $FreeBSD$
#
-PORTNAME= p5-DBD-Pg
+PORTNAME= DBD-Pg
PORTVERSION= 0.93
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= DBD
-DISTNAME= DBD-Pg-${PORTVERSION}
+PKGNAMEPREFIX= p5-
MAINTAINER= jfitz@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql
-USE_PERL5= YES
-CONFIGURE_ENV= POSTGRES_INCLUDE=${PREFIX}/pgsql/include POSTGRES_LIB=${PREFIX}/pgsql/lib
+USE_PERL5= yes
+MAKE_ENV= POSTGRES_INCLUDE=${PREFIX}/pgsql/include POSTGRES_LIB=${PREFIX}/pgsql/lib
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= DBD::Pg.3 DBD::dbd-pg.3
do-configure:
- @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ CC="${CC}" CCFLAGS="${CFLAGS}"
.include <bsd.port.mk>
diff --git a/databases/p5-DBD-mysql/Makefile b/databases/p5-DBD-mysql/Makefile
index 1e0f354d24b9..c3f0ea7135e0 100644
--- a/databases/p5-DBD-mysql/Makefile
+++ b/databases/p5-DBD-mysql/Makefile
@@ -5,12 +5,13 @@
# $FreeBSD$
#
-PORTNAME= p5-Mysql-modules
+PORTNAME= Mysql-modules
PORTVERSION= 1.2213
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= DBD
DISTNAME= Msql-Mysql-modules-${PORTVERSION}
+PKGNAMEPREFIX= p5-
MAINTAINER= jedgar@FreeBSD.org
@@ -21,9 +22,10 @@ LIB_DEPENDS= mysqlclient.6:${PORTSDIR}/databases/mysql322-client
Y2K= http://forteviot.symbolstone.org/technology/perl/DBI/doc/faq.html
-CONFIGURE_ARGS= PREFIX=${PREFIX} --noprompt --mysql-install --nomsql-install
+CONFIGURE_ARGS= PREFIX=${PREFIX} CC="${CC}" CCFLAGS="${CFLAGS}" \
+ --noprompt --mysql-install --nomsql-install
CONFIGURE_ENV= MYSQL_HOME=${PREFIX} IN_MYSQL_DISTRIBUTION=1
-USE_PERL5= YES
+USE_PERL5= yes
MAN1= dbimon.1
MAN3= Bundle::DBD::mysql.3 \
diff --git a/databases/p5-DBI-137/Makefile b/databases/p5-DBI-137/Makefile
index c599b36f97a1..c687ab6ceb7d 100644
--- a/databases/p5-DBI-137/Makefile
+++ b/databases/p5-DBI-137/Makefile
@@ -5,19 +5,18 @@
# $FreeBSD$
#
-PORTNAME= p5-DBI
+PORTNAME= DBI
PORTVERSION= 1.13
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= DBI
-DISTNAME= DBI-${PORTVERSION}
+PKGNAMEPREFIX= p5-
MAINTAINER= vanilla@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/RPC/PlServer.pm:${PORTSDIR}/net/p5-PlRPC
-USE_PERL5= YES
-CONFIGURE_ARGS= PREFIX=${PREFIX}
+USE_PERL5= yes
MAN1= dbiproxy.1 \
dbish.1
@@ -35,6 +34,7 @@ MAN3= Bundle::DBI.3 \
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL ${CONFIGURE_ARGS}
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ PREFIX="${PREFIX}" CC="${CC}" CCFLAGS="${CFLAGS}"
.include <bsd.port.mk>
diff --git a/databases/p5-DBI/Makefile b/databases/p5-DBI/Makefile
index c599b36f97a1..c687ab6ceb7d 100644
--- a/databases/p5-DBI/Makefile
+++ b/databases/p5-DBI/Makefile
@@ -5,19 +5,18 @@
# $FreeBSD$
#
-PORTNAME= p5-DBI
+PORTNAME= DBI
PORTVERSION= 1.13
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= DBI
-DISTNAME= DBI-${PORTVERSION}
+PKGNAMEPREFIX= p5-
MAINTAINER= vanilla@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/RPC/PlServer.pm:${PORTSDIR}/net/p5-PlRPC
-USE_PERL5= YES
-CONFIGURE_ARGS= PREFIX=${PREFIX}
+USE_PERL5= yes
MAN1= dbiproxy.1 \
dbish.1
@@ -35,6 +34,7 @@ MAN3= Bundle::DBI.3 \
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL ${CONFIGURE_ARGS}
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ PREFIX="${PREFIX}" CC="${CC}" CCFLAGS="${CFLAGS}"
.include <bsd.port.mk>
diff --git a/databases/p5-GDBM/Makefile b/databases/p5-GDBM/Makefile
index 374a709ac26d..4debb759aba4 100644
--- a/databases/p5-GDBM/Makefile
+++ b/databases/p5-GDBM/Makefile
@@ -18,16 +18,15 @@ MAINTAINER= nsayer@FreeBSD.ORG
LIB_DEPENDS= gdbm.2:${PORTSDIR}/databases/gdbm
-USE_PERL5= YES
+USE_PERL5= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/ext/GDBM_File
MAN3= GDBM_File.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-.include <bsd.port.pre.mk>
-
do-configure:
- @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ CC="${CC}" CCFLAGS="${CFLAGS}"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/p5-MLDBM/Makefile b/databases/p5-MLDBM/Makefile
index fc211ee1c165..7546ede16e75 100644
--- a/databases/p5-MLDBM/Makefile
+++ b/databases/p5-MLDBM/Makefile
@@ -5,19 +5,19 @@
# $FreeBSD$
#
-PORTNAME= p5-MLDBM
+PORTNAME= MLDBM
PORTVERSION= 2.00
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= MLDBM
-DISTNAME= MLDBM-${PORTVERSION}
+PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/FreezeThaw.pm:${PORTSDIR}/devel/p5-FreezeThaw \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
-USE_PERL5= YES
+USE_PERL5= yes
MAN3= MLDBM.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
diff --git a/databases/p5-Mysql/Makefile b/databases/p5-Mysql/Makefile
index 1e0f354d24b9..c3f0ea7135e0 100644
--- a/databases/p5-Mysql/Makefile
+++ b/databases/p5-Mysql/Makefile
@@ -5,12 +5,13 @@
# $FreeBSD$
#
-PORTNAME= p5-Mysql-modules
+PORTNAME= Mysql-modules
PORTVERSION= 1.2213
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= DBD
DISTNAME= Msql-Mysql-modules-${PORTVERSION}
+PKGNAMEPREFIX= p5-
MAINTAINER= jedgar@FreeBSD.org
@@ -21,9 +22,10 @@ LIB_DEPENDS= mysqlclient.6:${PORTSDIR}/databases/mysql322-client
Y2K= http://forteviot.symbolstone.org/technology/perl/DBI/doc/faq.html
-CONFIGURE_ARGS= PREFIX=${PREFIX} --noprompt --mysql-install --nomsql-install
+CONFIGURE_ARGS= PREFIX=${PREFIX} CC="${CC}" CCFLAGS="${CFLAGS}" \
+ --noprompt --mysql-install --nomsql-install
CONFIGURE_ENV= MYSQL_HOME=${PREFIX} IN_MYSQL_DISTRIBUTION=1
-USE_PERL5= YES
+USE_PERL5= yes
MAN1= dbimon.1
MAN3= Bundle::DBD::mysql.3 \
diff --git a/databases/p5-Pg/Makefile b/databases/p5-Pg/Makefile
index 1740e4087799..4b2af7241ec7 100644
--- a/databases/p5-Pg/Makefile
+++ b/databases/p5-Pg/Makefile
@@ -5,18 +5,19 @@
# $FreeBSD$
#
-PORTNAME= p5-Pg
+PORTNAME= Pg
PORTVERSION= 1.8.1
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Pg
DISTNAME= pgsql_perl5-${PORTVERSION}
+PKGNAMEPREFIX= p5-
MAINTAINER= jfitz@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/pgsql/lib/libpq.a:${PORTSDIR}/databases/postgresql
-USE_PERL5= YES
+USE_PERL5= yes
POSTGRES_HOME?= ${PREFIX}/pgsql
MAKE_ENV+= POSTGRES_HOME=${POSTGRES_HOME}
@@ -25,6 +26,7 @@ MAN3= Pg.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ CC="${CC}" CCFLAGS="${CFLAGS}"
.include <bsd.port.mk>
diff --git a/databases/p5-SQL-Statement/Makefile b/databases/p5-SQL-Statement/Makefile
index 3d5aeed60745..129c0f42fcae 100644
--- a/databases/p5-SQL-Statement/Makefile
+++ b/databases/p5-SQL-Statement/Makefile
@@ -5,21 +5,22 @@
# $FreeBSD$
#
-PORTNAME= p5-SQL-Statement
+PORTNAME= SQL-Statement
PORTVERSION= 0.1016
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= SQL
-DISTNAME= SQL-Statement-${PORTVERSION}
+PKGNAMEPREFIX= p5-
MAINTAINER= wolman@cs.washington.edu
-USE_PERL5= YES
+USE_PERL5= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= SQL::Eval.3 SQL::Statement.3
do-configure:
- @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ CC="${CC}" CCFLAGS="${CFLAGS}"
.include <bsd.port.mk>
diff --git a/databases/p5-hp200lx-db/Makefile b/databases/p5-hp200lx-db/Makefile
index da135db2af07..c2ecdc1520d5 100644
--- a/databases/p5-hp200lx-db/Makefile
+++ b/databases/p5-hp200lx-db/Makefile
@@ -5,21 +5,21 @@
# $FreeBSD$
#
-PORTNAME= p5-hp200lx-db
+PORTNAME= hp200lx-db
PORTVERSION= 0.07
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= HP200LX
-DISTNAME= hp200lx-db-${PORTVERSION}
+PKGNAMEPREFIX= p5-
MAINTAINER= g.gonter@ieee.org
-USE_PERL5= YES
+USE_PERL5= yes
# MAN3= HP200LX::DB.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
do-configure:
- @( cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL )
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
.include <bsd.port.mk>