aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2011-01-06 08:41:03 +0000
committerDima Panov <fluffy@FreeBSD.org>2011-01-06 08:41:03 +0000
commit98b32369728f679f67dac3212826291d00d2731d (patch)
treef802f008fdb5b6162f690f8fb99366b93ed695c3 /databases
parent02959738d18798e4c3e8dff4b1081846f71378bd (diff)
downloadports-98b32369728f679f67dac3212826291d00d2731d.tar.gz
ports-98b32369728f679f67dac3212826291d00d2731d.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/qt4-pgsql-plugin/Makefile1
-rw-r--r--databases/qt4-pgsql-plugin/files/patch-qsql_psql.cpp46
-rw-r--r--databases/qt4-pgsql-plugin/files/patch-qsql_psql.h12
3 files changed, 59 insertions, 0 deletions
diff --git a/databases/qt4-pgsql-plugin/Makefile b/databases/qt4-pgsql-plugin/Makefile
index ae8b81659e3d..933d7e1087c4 100644
--- a/databases/qt4-pgsql-plugin/Makefile
+++ b/databases/qt4-pgsql-plugin/Makefile
@@ -7,6 +7,7 @@
#
PORTNAME= qt4-${DB}-plugin
+PORTVERSION= 1
DISTVERSION= ${QT4_VERSION}
CATEGORIES= databases
diff --git a/databases/qt4-pgsql-plugin/files/patch-qsql_psql.cpp b/databases/qt4-pgsql-plugin/files/patch-qsql_psql.cpp
new file mode 100644
index 000000000000..c674ae702ca0
--- /dev/null
+++ b/databases/qt4-pgsql-plugin/files/patch-qsql_psql.cpp
@@ -0,0 +1,46 @@
+--- ./src/sql/drivers/psql/qsql_psql.cpp 2010-09-10 11:05:25.000000000 +0200
++++ ./src/sql/drivers/psql/qsql_psql.cpp 2010-11-03 12:37:55.966977333 +0100
+@@ -661,6 +661,17 @@
+ break;
+ }
+ break;
++ case 9:
++ switch (vMin) {
++ case 0:
++ serverVersion = QPSQLDriver::Version9;
++ break;
++ default:
++ serverVersion = QPSQLDriver::Version9;
++ break;
++ }
++ break;
++
+ default:
+ break;
+ }
+@@ -852,7 +863,8 @@
+ // This hack can dissapear once there is an API to query this sort of information.
+ if (d->pro == QPSQLDriver::Version8 ||
+ d->pro == QPSQLDriver::Version81 ||
+- d->pro == QPSQLDriver::Version82) {
++ d->pro == QPSQLDriver::Version82 ||
++ d->pro == QPSQLDriver::Version9) {
+ transaction_failed = qstrcmp(PQcmdStatus(res), "ROLLBACK") == 0;
+ }
+
+@@ -963,6 +975,7 @@
+ case QPSQLDriver::Version8:
+ case QPSQLDriver::Version81:
+ case QPSQLDriver::Version82:
++ case QPSQLDriver::Version9:
+ stmt = QLatin1String("SELECT pg_attribute.attname, pg_attribute.atttypid::int, "
+ "pg_class.relname "
+ "FROM pg_attribute, pg_class "
+@@ -1046,6 +1059,7 @@
+ case QPSQLDriver::Version8:
+ case QPSQLDriver::Version81:
+ case QPSQLDriver::Version82:
++ case QPSQLDriver::Version9:
+ stmt = QLatin1String("select pg_attribute.attname, pg_attribute.atttypid::int, "
+ "pg_attribute.attnotnull, pg_attribute.attlen, pg_attribute.atttypmod, "
+ "pg_attrdef.adsrc "
diff --git a/databases/qt4-pgsql-plugin/files/patch-qsql_psql.h b/databases/qt4-pgsql-plugin/files/patch-qsql_psql.h
new file mode 100644
index 000000000000..28b3f53c7450
--- /dev/null
+++ b/databases/qt4-pgsql-plugin/files/patch-qsql_psql.h
@@ -0,0 +1,12 @@
+--- ./src/sql/drivers/psql/qsql_psql.h 2010-09-10 11:05:25.000000000 +0200
++++ ./src/sql/drivers/psql/qsql_psql.h 2010-11-03 12:36:16.380310668 +0100
+@@ -104,7 +104,8 @@
+ Version74 = 10,
+ Version8 = 11,
+ Version81 = 12,
+- Version82 = 13
++ Version82 = 13,
++ Version9 = 14
+ };
+
+ explicit QPSQLDriver(QObject *parent=0);