aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2014-05-31 08:31:00 +0000
committerMarcus von Appen <mva@FreeBSD.org>2014-05-31 08:31:00 +0000
commit9f90cca55fb200fe8ffbccce436026de2828f0ca (patch)
tree47fc039f1985db31848448cd3d079faf6855c470 /databases
parent3c79f3a6abfa184be7b3a7ca306b20ea80b0e654 (diff)
downloadports-9f90cca55fb200fe8ffbccce436026de2828f0ca.tar.gz
ports-9f90cca55fb200fe8ffbccce436026de2828f0ca.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/py-peewee/Makefile26
-rw-r--r--databases/py-peewee/distinfo2
-rw-r--r--databases/py-peewee/pkg-descr4
4 files changed, 33 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index e30d28fc422d..47196b2f0d0b 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -734,6 +734,7 @@
SUBDIR += py-mysql2pgsql
SUBDIR += py-odbc
SUBDIR += py-oops
+ SUBDIR += py-peewee
SUBDIR += py-pg8000
SUBDIR += py-pg_pqueue
SUBDIR += py-pgxnclient
diff --git a/databases/py-peewee/Makefile b/databases/py-peewee/Makefile
new file mode 100644
index 000000000000..38497dfb24e6
--- /dev/null
+++ b/databases/py-peewee/Makefile
@@ -0,0 +1,26 @@
+# Created by: Matthias Petermann <matthias@petermann-it.de>
+# $FreeBSD$
+
+PORTNAME= peewee
+PORTVERSION= 2.2.2
+CATEGORIES= databases python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= matthias@petermann-it.de
+COMMENT= Small, expressive Python ORM
+
+LICENSE= MIT
+
+OPTIONS_DEFINE= DOCS SQLITE MYSQL PGSQL
+OPTIONS_DEFAULT= SQLITE
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+
+SQLITE_BUILD_DEPENDS= ${PYTHON_LIBDIR}/lib-dynload/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
+MYSQL_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.3:${PORTSDIR}/databases/py-MySQLdb
+PGSQL_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psycopg2>=2.5.1:${PORTSDIR}/databases/py-psycopg2
+
+.include <bsd.port.mk>
diff --git a/databases/py-peewee/distinfo b/databases/py-peewee/distinfo
new file mode 100644
index 000000000000..f1e480a5d34f
--- /dev/null
+++ b/databases/py-peewee/distinfo
@@ -0,0 +1,2 @@
+SHA256 (peewee-2.2.2.tar.gz) = 1aeeb2ece13bee36bc8ea69fbb76a4f1abda0deea0797d56c9d3f9f271690371
+SIZE (peewee-2.2.2.tar.gz) = 980043
diff --git a/databases/py-peewee/pkg-descr b/databases/py-peewee/pkg-descr
new file mode 100644
index 000000000000..da4ae733e7d5
--- /dev/null
+++ b/databases/py-peewee/pkg-descr
@@ -0,0 +1,4 @@
+Peewee is a small, expressive ORM written in Python. It supports
+PostgreSQL, MySQL and SQLite.
+
+WWW: http://peewee.readthedocs.org