aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-25 13:32:05 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-25 13:38:05 +0000
commit08ef1e8374bbb05e9b599b2c949455a61e77350c (patch)
tree5bbd29aa355c2e058df8b003441af508566afe6d /databases
parentf41aeac54f93961058a65aa9e3b043fcc82b600e (diff)
downloadports-08ef1e8374bbb05e9b599b2c949455a61e77350c.tar.gz
ports-08ef1e8374bbb05e9b599b2c949455a61e77350c.zip
databases/py-dbf: Fix build with setuptools 58.0.0+
With hat: python
Diffstat (limited to 'databases')
-rw-r--r--databases/py-dbf/Makefile2
-rw-r--r--databases/py-dbf/files/patch-2to313
2 files changed, 14 insertions, 1 deletions
diff --git a/databases/py-dbf/Makefile b/databases/py-dbf/Makefile
index 787ab8e1fd9c..fa696d6effc7 100644
--- a/databases/py-dbf/Makefile
+++ b/databases/py-dbf/Makefile
@@ -11,7 +11,7 @@ COMMENT= Pure python package for reading/writing dbf files
LICENSE= BSD3CLAUSE
-USES= python:3.6+
+USES= dos2unix python:3.6+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/databases/py-dbf/files/patch-2to3 b/databases/py-dbf/files/patch-2to3
new file mode 100644
index 000000000000..f9ad71a6c72a
--- /dev/null
+++ b/databases/py-dbf/files/patch-2to3
@@ -0,0 +1,13 @@
+--- dbf/_index.py.orig 2022-03-15 19:06:56 UTC
++++ dbf/_index.py
+@@ -9,8 +9,8 @@ class IndexFile(object):
+ filename += '.pdx'
+ if not os.path.exists(filename):
+ self.index_file = open(filename, 'r+b')
+- self.index_file.write('\xea\xaf\x37\xbf' # signature
+- '\x00'*8 # two non-existant lists
++ self.index_file.write('\xea\xaf\x37\xbf', # signature
++ '\x00'*8, # two non-existant lists
+ '\x00'*500) # and no indices
+ return
+ index_file = self.index_file = open(filename, 'r+b')