aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:35:50 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:35:50 +0000
commitf1bb12de8e50bf76ae21f37debda60994ec7fd99 (patch)
tree1671d4beef381f12d939e34b344eb385a3af4f19 /databases
parent29adee7bb42244f34736c5c24ed18a9b269d0925 (diff)
downloadports-f1bb12de8e50bf76ae21f37debda60994ec7fd99.tar.gz
ports-f1bb12de8e50bf76ae21f37debda60994ec7fd99.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/evolution-data-server/Makefile29
-rw-r--r--databases/evolution-data-server/distinfo6
-rw-r--r--databases/evolution-data-server/files/patch-camel_camel-object.c22
-rw-r--r--databases/evolution-data-server/files/patch-offical-sleepycat480
-rw-r--r--databases/evolution-data-server/pkg-plist90
-rw-r--r--databases/libgda2/Makefile7
-rw-r--r--databases/libgda2/pkg-plist30
7 files changed, 129 insertions, 535 deletions
diff --git a/databases/evolution-data-server/Makefile b/databases/evolution-data-server/Makefile
index c289f423b1ef..f58505bc9690 100644
--- a/databases/evolution-data-server/Makefile
+++ b/databases/evolution-data-server/Makefile
@@ -3,11 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/databases/evolution-data-server/Makefile,v 1.83 2006/04/13 07:52:30 bland Exp $
+# $MCom: ports/databases/evolution-data-server/Makefile,v 1.99 2006/10/03 00:13:42 ahze Exp $
#
PORTNAME= evolution-data-server
-PORTVERSION= 1.6.3
+PORTVERSION= 1.8.1
CATEGORIES= databases gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -24,12 +24,13 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_BISON= yes
USE_GETTEXT= yes
-USE_X_PREFIX= yes
+USE_XLIB= yes
USE_GNOME= gnomeprefix gnomehack intlhack gnometarget libgnomeui \
ltverhack
USE_OPENLDAP= yes
USE_AUTOTOOLS= libtool:15
-INSTALLS_SHLIB= yes
+USE_BDB= 41
+USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-static \
--enable-nss=yes \
--with-openldap=yes \
@@ -37,11 +38,14 @@ CONFIGURE_ARGS= --enable-static \
--with-nss-libs=${LOCALBASE}/lib \
--with-nspr-includes=${LOCALBASE}/include/nspr \
--with-nspr-libs=${LOCALBASE}/lib \
- --with-krb5=/usr
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ --with-krb5=/usr \
+ --with-libdb=${LOCALBASE}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${BDB_INCLUDE_DIR} ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-PLIST_SUB= VERSION="1.6" EVO_VERSION="1.2"
+PLIST_SUB= VERSION="1.8" EVO_VERSION="1.2"
+
+OPTIONS= IMAP4 "Enable experimental IMAP4 backend" off
.include <bsd.port.pre.mk>
@@ -61,4 +65,15 @@ CONFIGURE_ARGS+= --with-krb5=${LOCALBASE}
.endif
.endif
+.if defined(WITH_IMAP4) || defined(PACKAGE_BUILDING)
+CONFIGURE_ARGS+= --enable-imap4=yes
+PLIST_SUB+= IMAP4=""
+.else
+PLIST_SUB+= IMAP4="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-ldb|-l${BDB_LIB_NAME}|g' \
+ ${WRKSRC}/configure
+
.include <bsd.port.post.mk>
diff --git a/databases/evolution-data-server/distinfo b/databases/evolution-data-server/distinfo
index 5c3d6605569f..10f365ce130e 100644
--- a/databases/evolution-data-server/distinfo
+++ b/databases/evolution-data-server/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/evolution-data-server-1.6.3.tar.bz2) = e40343fa6a80916da3f4d1ba5d118c89
-SHA256 (gnome2/evolution-data-server-1.6.3.tar.bz2) = c31a11fd745195b15a4399ec3e83ccf7bafb5d25852c89a7c6a24af49df25922
-SIZE (gnome2/evolution-data-server-1.6.3.tar.bz2) = 7047514
+MD5 (gnome2/evolution-data-server-1.8.1.tar.bz2) = 8c2fe35bcdc457e09728ed213e915d01
+SHA256 (gnome2/evolution-data-server-1.8.1.tar.bz2) = 5fb63ea67899ba3d6f1866594a2f237609b36eb985e9621ee3cb494e15e71956
+SIZE (gnome2/evolution-data-server-1.8.1.tar.bz2) = 7119647
diff --git a/databases/evolution-data-server/files/patch-camel_camel-object.c b/databases/evolution-data-server/files/patch-camel_camel-object.c
deleted file mode 100644
index 03e01116584a..000000000000
--- a/databases/evolution-data-server/files/patch-camel_camel-object.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- camel/camel-object.c.orig Sun Feb 19 17:04:42 2006
-+++ camel/camel-object.c Sun Feb 19 17:06:06 2006
-@@ -454,7 +454,7 @@ cobject_state_read(CamelObject *obj, FIL
- }
-
- /* we batch up the properties and set them in one go */
-- if (!(argv = g_try_malloc (sizeof (*argv) + (count - CAMEL_ARGV_MAX) * sizeof (argv->argv[0]))))
-+ if (!(argv = g_try_malloc ((guint32) (sizeof (*argv) + (count - CAMEL_ARGV_MAX) * sizeof (argv->argv[0])))))
- return -1;
-
- argv->argc = 0;
-@@ -534,8 +534,8 @@ cobject_state_write(CamelObject *obj, FI
-
- count = g_slist_length(props);
-
-- arggetv = g_malloc0(sizeof(*arggetv) + (count - CAMEL_ARGV_MAX) * sizeof(arggetv->argv[0]));
-- argv = g_malloc0(sizeof(*argv) + (count - CAMEL_ARGV_MAX) * sizeof(argv->argv[0]));
-+ arggetv = g_malloc0((guint32) (sizeof(*arggetv) + (count - CAMEL_ARGV_MAX) * sizeof(arggetv->argv[0])));
-+ argv = g_malloc0((guint32) (sizeof(*argv) + (count - CAMEL_ARGV_MAX) * sizeof(argv->argv[0])));
- l = props;
- i = 0;
- while (l) {
diff --git a/databases/evolution-data-server/files/patch-offical-sleepycat b/databases/evolution-data-server/files/patch-offical-sleepycat
deleted file mode 100644
index 0cd4d7909728..000000000000
--- a/databases/evolution-data-server/files/patch-offical-sleepycat
+++ /dev/null
@@ -1,480 +0,0 @@
---- libdb/fileops/fop_util.c.orig Thu Nov 20 23:13:30 2003
-+++ libdb/fileops/fop_util.c Fri Mar 18 20:31:10 2005
-@@ -40,7 +40,7 @@
- u_int32_t __lockval; \
- \
- if (LOCKING_ON((ENV))) { \
-- __lockval = 0; \
-+ __lockval = 1; \
- __dbt.data = &__lockval; \
- __dbt.size = sizeof(__lockval); \
- if ((ret = (ENV)->lock_get((ENV), (ID), \
---- libdb/dbinc/mp.h.orig Thu Nov 20 23:13:17 2003
-+++ libdb/dbinc/mp.h Fri Mar 18 20:31:14 2005
-@@ -149,6 +149,13 @@
- * region lock).
- */
- DB_MPOOL_STAT stat; /* Per-cache mpool statistics. */
-+
-+ /*
-+ * We track page puts so that we can decide when allocation is never
-+ * going to succeed. We don't lock the field, all we care about is
-+ * if it changes.
-+ */
-+ u_int32_t put_counter; /* Count of page put calls. */
- };
-
- struct __db_mpool_hash {
---- libdb/mp/mp_fput.c.orig Thu Nov 20 23:13:36 2003
-+++ libdb/mp/mp_fput.c Fri Mar 18 20:31:14 2005
-@@ -19,6 +19,8 @@
- #include "dbinc/db_shash.h"
- #include "dbinc/mp.h"
-
-+static void __memp_reset_lru __P((DB_ENV *, REGINFO *));
-+
- /*
- * __memp_fput --
- * Mpool file put function.
-@@ -198,5 +200,56 @@
-
- MUTEX_UNLOCK(dbenv, &hp->hash_mutex);
-
-+ /*
-+ * On every buffer put we update the buffer generation number and check
-+ * for wraparound.
-+ */
-+ if (++c_mp->lru_count == UINT32_T_MAX)
-+ __memp_reset_lru(dbenv, dbmp->reginfo);
-+
- return (0);
-+}
-+
-+/*
-+ * __memp_reset_lru --
-+ * Reset the cache LRU counter.
-+ */
-+static void
-+__memp_reset_lru(dbenv, memreg)
-+ DB_ENV *dbenv;
-+ REGINFO *memreg;
-+{
-+ BH *bhp;
-+ DB_MPOOL_HASH *hp;
-+ MPOOL *c_mp;
-+ int bucket;
-+
-+ c_mp = memreg->primary;
-+
-+ /*
-+ * Update the counter so all future allocations will start at the
-+ * bottom.
-+ */
-+ c_mp->lru_count -= MPOOL_BASE_DECREMENT;
-+
-+ /* Adjust the priority of every buffer in the system. */
-+ for (hp = R_ADDR(memreg, c_mp->htab),
-+ bucket = 0; bucket < c_mp->htab_buckets; ++hp, ++bucket) {
-+ /*
-+ * Skip empty buckets.
-+ *
-+ * We can check for empty buckets before locking as we
-+ * only care if the pointer is zero or non-zero.
-+ */
-+ if (SH_TAILQ_FIRST(&hp->hash_bucket, __bh) == NULL)
-+ continue;
-+
-+ MUTEX_LOCK(dbenv, &hp->hash_mutex);
-+ for (bhp = SH_TAILQ_FIRST(&hp->hash_bucket, __bh);
-+ bhp != NULL; bhp = SH_TAILQ_NEXT(bhp, hq, __bh))
-+ if (bhp->priority != UINT32_T_MAX &&
-+ bhp->priority > MPOOL_BASE_DECREMENT)
-+ bhp->priority -= MPOOL_BASE_DECREMENT;
-+ MUTEX_UNLOCK(dbenv, &hp->hash_mutex);
-+ }
- }
---- libdb/mp/mp_alloc.c.orig Thu Nov 20 23:13:36 2003
-+++ libdb/mp/mp_alloc.c Fri Mar 18 20:31:14 2005
-@@ -25,7 +25,6 @@
- } HS;
-
- static void __memp_bad_buffer __P((DB_MPOOL_HASH *));
--static void __memp_reset_lru __P((DB_ENV *, REGINFO *, MPOOL *));
-
- /*
- * __memp_alloc --
-@@ -50,8 +49,9 @@
- MPOOL *c_mp;
- MPOOLFILE *bh_mfp;
- size_t freed_space;
-- u_int32_t buckets, buffers, high_priority, max_na, priority;
-- int aggressive, ret;
-+ u_int32_t buckets, buffers, high_priority, priority, put_counter;
-+ u_int32_t total_buckets;
-+ int aggressive, giveup, ret;
- void *p;
-
- dbenv = dbmp->dbenv;
-@@ -59,18 +59,13 @@
- dbht = R_ADDR(memreg, c_mp->htab);
- hp_end = &dbht[c_mp->htab_buckets];
-
-- buckets = buffers = 0;
-- aggressive = 0;
-+ buckets = buffers = put_counter = total_buckets = 0;
-+ aggressive = giveup = 0;
-+ hp_tmp = NULL;
-
- c_mp->stat.st_alloc++;
-
- /*
-- * Get aggressive if we've tried to flush the number of pages as are
-- * in the system without finding space.
-- */
-- max_na = 5 * c_mp->htab_buckets;
--
-- /*
- * If we're allocating a buffer, and the one we're discarding is the
- * same size, we don't want to waste the time to re-integrate it into
- * the shared memory free list. If the DB_MPOOLFILE argument isn't
-@@ -81,19 +76,10 @@
- len = (sizeof(BH) - sizeof(u_int8_t)) + mfp->stat.st_pagesize;
-
- R_LOCK(dbenv, memreg);
--
-- /*
-- * On every buffer allocation we update the buffer generation number
-- * and check for wraparound.
-- */
-- if (++c_mp->lru_count == UINT32_T_MAX)
-- __memp_reset_lru(dbenv, memreg, c_mp);
--
- /*
- * Anything newer than 1/10th of the buffer pool is ignored during
- * allocation (unless allocation starts failing).
- */
-- DB_ASSERT(c_mp->lru_count > c_mp->stat.st_pages / 10);
- high_priority = c_mp->lru_count - c_mp->stat.st_pages / 10;
-
- /*
-@@ -120,10 +106,11 @@
- * We're not holding the region locked here, these statistics
- * can't be trusted.
- */
-- if (buckets != 0) {
-- if (buckets > c_mp->stat.st_alloc_max_buckets)
-- c_mp->stat.st_alloc_max_buckets = buckets;
-- c_mp->stat.st_alloc_buckets += buckets;
-+ total_buckets += buckets;
-+ if (total_buckets != 0) {
-+ if (total_buckets > c_mp->stat.st_alloc_max_buckets)
-+ c_mp->stat.st_alloc_max_buckets = total_buckets;
-+ c_mp->stat.st_alloc_buckets += total_buckets;
- }
- if (buffers != 0) {
- if (buffers > c_mp->stat.st_alloc_max_pages)
-@@ -131,6 +118,12 @@
- c_mp->stat.st_alloc_pages += buffers;
- }
- return (0);
-+ } else if (giveup || c_mp->stat.st_pages == 0) {
-+ R_UNLOCK(dbenv, memreg);
-+
-+ __db_err(dbenv,
-+ "unable to allocate space from the buffer cache");
-+ return (ret);
- }
-
- /*
-@@ -138,26 +131,24 @@
- * we need. Reset our free-space counter.
- */
- freed_space = 0;
-+ total_buckets += buckets;
-+ buckets = 0;
-
- /*
- * Walk the hash buckets and find the next two with potentially useful
- * buffers. Free the buffer with the lowest priority from the buckets'
- * chains.
- */
-- for (hp_tmp = NULL;;) {
-+ for (;;) {
-+ /* All pages have been freed, make one last try */
-+ if (c_mp->stat.st_pages == 0)
-+ goto alloc;
-+
- /* Check for wrap around. */
- hp = &dbht[c_mp->last_checked++];
- if (hp >= hp_end) {
- c_mp->last_checked = 0;
--
-- /*
-- * If we've gone through all of the hash buckets, try
-- * an allocation. If the cache is small, the old page
-- * size is small, and the new page size is large, we
-- * might have freed enough memory (but not 3 times the
-- * memory).
-- */
-- goto alloc;
-+ hp = &dbht[c_mp->last_checked++];
- }
-
- /*
-@@ -172,39 +163,59 @@
- /*
- * The failure mode is when there are too many buffers we can't
- * write or there's not enough memory in the system. We don't
-- * have a metric for deciding if allocation has no possible way
-- * to succeed, so we don't ever fail, we assume memory will be
-- * available if we wait long enough.
-+ * have a way to know that allocation has no way to succeed.
-+ * We fail if there were no pages returned to the cache after
-+ * we've been trying for a relatively long time.
- *
-- * Get aggressive if we've tried to flush 5 times the number of
-- * hash buckets as are in the system -- it's possible we have
-- * been repeatedly trying to flush the same buffers, although
-- * it's unlikely. Aggressive means:
-+ * Get aggressive if we've tried to flush the number of hash
-+ * buckets as are in the system and have not found any more
-+ * space. Aggressive means:
- *
- * a: set a flag to attempt to flush high priority buffers as
- * well as other buffers.
- * b: sync the mpool to force out queue extent pages. While we
- * might not have enough space for what we want and flushing
- * is expensive, why not?
-- * c: sleep for a second -- hopefully someone else will run and
-- * free up some memory. Try to allocate memory too, in case
-- * the other thread returns its memory to the region.
-- * d: look at a buffer in every hash bucket rather than choose
-+ * c: look at a buffer in every hash bucket rather than choose
- * the more preferable of two.
-+ * d: start to think about giving up.
-+ *
-+ * If we get here twice, sleep for a second, hopefully someone
-+ * else will run and free up some memory.
-+ *
-+ * Always try to allocate memory too, in case some other thread
-+ * returns its memory to the region.
- *
- * !!!
- * This test ignores pathological cases like no buffers in the
- * system -- that shouldn't be possible.
- */
-- if ((++buckets % max_na) == 0) {
-- aggressive = 1;
--
-+ if ((++buckets % c_mp->htab_buckets) == 0) {
-+ if (freed_space > 0)
-+ goto alloc;
- R_UNLOCK(dbenv, memreg);
-
-- (void)__memp_sync_int(
-- dbenv, NULL, 0, DB_SYNC_ALLOC, NULL);
--
-- (void)__os_sleep(dbenv, 1, 0);
-+ switch (++aggressive) {
-+ case 1:
-+ break;
-+ case 2:
-+ put_counter = c_mp->put_counter;
-+ /* FALLTHROUGH */
-+ case 3:
-+ case 4:
-+ case 5:
-+ case 6:
-+ (void)__memp_sync_int(
-+ dbenv, NULL, 0, DB_SYNC_ALLOC, NULL);
-+
-+ (void)__os_sleep(dbenv, 1, 0);
-+ break;
-+ default:
-+ aggressive = 1;
-+ if (put_counter == c_mp->put_counter)
-+ giveup = 1;
-+ break;
-+ }
-
- R_LOCK(dbenv, memreg);
- goto alloc;
-@@ -277,7 +288,8 @@
- * thread may have acquired this buffer and incremented the ref
- * count after we wrote it, in which case we can't have it.
- *
-- * If there's a write error, avoid selecting this buffer again
-+ * If there's a write error and we're having problems finding
-+ * something to allocate, avoid selecting this buffer again
- * by making it the bucket's least-desirable buffer.
- */
- if (ret != 0 || bhp->ref != 0) {
-@@ -301,6 +313,8 @@
-
- freed_space += __db_shsizeof(bhp);
- __memp_bhfree(dbmp, hp, bhp, 1);
-+ if (aggressive > 1)
-+ aggressive = 1;
-
- /*
- * Unlock this hash bucket and re-acquire the region lock. If
-@@ -360,54 +374,6 @@
-
- /* Reset the hash bucket's priority. */
- hp->hash_priority = SH_TAILQ_FIRST(&hp->hash_bucket, __bh)->priority;
--}
--
--/*
-- * __memp_reset_lru --
-- * Reset the cache LRU counter.
-- */
--static void
--__memp_reset_lru(dbenv, memreg, c_mp)
-- DB_ENV *dbenv;
-- REGINFO *memreg;
-- MPOOL *c_mp;
--{
-- BH *bhp;
-- DB_MPOOL_HASH *hp;
-- int bucket;
--
-- /*
-- * Update the counter so all future allocations will start at the
-- * bottom.
-- */
-- c_mp->lru_count -= MPOOL_BASE_DECREMENT;
--
-- /* Release the region lock. */
-- R_UNLOCK(dbenv, memreg);
--
-- /* Adjust the priority of every buffer in the system. */
-- for (hp = R_ADDR(memreg, c_mp->htab),
-- bucket = 0; bucket < c_mp->htab_buckets; ++hp, ++bucket) {
-- /*
-- * Skip empty buckets.
-- *
-- * We can check for empty buckets before locking as we
-- * only care if the pointer is zero or non-zero.
-- */
-- if (SH_TAILQ_FIRST(&hp->hash_bucket, __bh) == NULL)
-- continue;
--
-- MUTEX_LOCK(dbenv, &hp->hash_mutex);
-- for (bhp = SH_TAILQ_FIRST(&hp->hash_bucket, __bh);
-- bhp != NULL; bhp = SH_TAILQ_NEXT(bhp, hq, __bh))
-- if (bhp->priority != UINT32_T_MAX &&
-- bhp->priority > MPOOL_BASE_DECREMENT)
-- bhp->priority -= MPOOL_BASE_DECREMENT;
-- MUTEX_UNLOCK(dbenv, &hp->hash_mutex);
-- }
--
-- /* Reacquire the region lock. */
-- R_LOCK(dbenv, memreg);
- }
-
- #ifdef DIAGNOSTIC
---- libdb/dbreg/dbreg_rec.c.orig Thu Nov 20 23:13:19 2003
-+++ libdb/dbreg/dbreg_rec.c Fri Mar 18 20:31:14 2005
-@@ -174,19 +174,20 @@
- * Typically, closes should match an open which means
- * that if this is a close, there should be a valid
- * entry in the dbentry table when we get here,
-- * however there is an exception. If this is an
-+ * however there are exceptions. 1. If this is an
- * OPENFILES pass, then we may have started from
- * a log file other than the first, and the
- * corresponding open appears in an earlier file.
-- * We can ignore that case, but all others are errors.
-+ * 2. If we are undoing an open on an abort or
-+ * recovery, it's possible that we failed after
-+ * the log record, but before we actually entered
-+ * a handle here.
- */
- dbe = &dblp->dbentry[argp->fileid];
- if (dbe->dbp == NULL && !dbe->deleted) {
- /* No valid entry here. */
-- if ((argp->opcode != LOG_CLOSE &&
-- argp->opcode != LOG_RCLOSE) ||
-- (op != DB_TXN_OPENFILES &&
-- op !=DB_TXN_POPENFILES)) {
-+ if (DB_REDO(op) ||
-+ argp->opcode == LOG_CHECKPOINT) {
- __db_err(dbenv,
- "Improper file close at %lu/%lu",
- (u_long)lsnp->file,
---- libdb/env/env_recover.c.orig Thu Nov 20 23:13:20 2003
-+++ libdb/env/env_recover.c Fri Mar 18 20:31:14 2005
-@@ -232,12 +232,9 @@
- * we'll still need to do a vtruncate based on information we haven't
- * yet collected.
- */
-- if (ret == DB_NOTFOUND) {
-+ if (ret == DB_NOTFOUND)
- ret = 0;
-- if (max_lsn == NULL)
-- goto done;
-- }
-- if (ret != 0)
-+ else if (ret != 0)
- goto err;
-
- hi_txn = txnid;
-@@ -331,7 +328,7 @@
-
- /* Find a low txnid. */
- ret = 0;
-- do {
-+ if (hi_txn != 0) do {
- /* txnid is after rectype, which is a u_int32. */
- memcpy(&txnid,
- (u_int8_t *)data.data + sizeof(u_int32_t), sizeof(txnid));
-@@ -344,11 +341,8 @@
- * There are no transactions and we're not recovering to an LSN (see
- * above), so there is nothing to do.
- */
-- if (ret == DB_NOTFOUND) {
-+ if (ret == DB_NOTFOUND)
- ret = 0;
-- if (max_lsn == NULL)
-- goto done;
-- }
-
- /* Reset to the first lsn. */
- if (ret != 0 || (ret = logc->get(logc, &first_lsn, &data, DB_SET)) != 0)
-@@ -367,6 +361,10 @@
- txninfo, &data, &first_lsn, &last_lsn, nfiles, 1)) != 0)
- goto err;
-
-+ /* If there were no transactions, then we can bail out early. */
-+ if (hi_txn == 0 && max_lsn == NULL)
-+ goto done;
-+
- /*
- * Pass #2.
- *
-@@ -483,6 +481,7 @@
- if ((ret = __dbreg_close_files(dbenv)) != 0)
- goto err;
-
-+done:
- if (max_lsn != NULL) {
- region->last_ckp = ((DB_TXNHEAD *)txninfo)->ckplsn;
-
-@@ -538,7 +537,8 @@
- __db_err(dbenv, "Recovery complete at %.24s", ctime(&now));
- __db_err(dbenv, "%s %lx %s [%lu][%lu]",
- "Maximum transaction ID",
-- ((DB_TXNHEAD *)txninfo)->maxid,
-+ txninfo == NULL ? TXN_MINIMUM :
-+ ((DB_TXNHEAD *)txninfo)->maxid,
- "Recovery checkpoint",
- (u_long)region->last_ckp.file,
- (u_long)region->last_ckp.offset);
-@@ -550,7 +550,6 @@
- (u_long)lsn.file, (u_long)lsn.offset, pass);
- }
-
--done:
- err: if (lockid != DB_LOCK_INVALIDID) {
- if ((t_ret = __rep_unlockpages(dbenv, lockid)) != 0 && ret == 0)
- ret = t_ret;
diff --git a/databases/evolution-data-server/pkg-plist b/databases/evolution-data-server/pkg-plist
index eee832eb15bd..f603e10dea56 100644
--- a/databases/evolution-data-server/pkg-plist
+++ b/databases/evolution-data-server/pkg-plist
@@ -92,6 +92,7 @@ include/evolution-data-server-%%VERSION%%/camel/camel-stream-fs.h
include/evolution-data-server-%%VERSION%%/camel/camel-stream-mem.h
include/evolution-data-server-%%VERSION%%/camel/camel-stream-null.h
include/evolution-data-server-%%VERSION%%/camel/camel-stream-process.h
+include/evolution-data-server-%%VERSION%%/camel/camel-stream-vfs.h
include/evolution-data-server-%%VERSION%%/camel/camel-stream.h
include/evolution-data-server-%%VERSION%%/camel/camel-string-utils.h
include/evolution-data-server-%%VERSION%%/camel/camel-tcp-stream-raw.h
@@ -134,6 +135,7 @@ include/evolution-data-server-%%VERSION%%/exchange/e2k-validate.h
include/evolution-data-server-%%VERSION%%/exchange/e2k-xml-utils.h
include/evolution-data-server-%%VERSION%%/exchange/exchange-account.h
include/evolution-data-server-%%VERSION%%/exchange/exchange-constants.h
+include/evolution-data-server-%%VERSION%%/exchange/exchange-esource.h
include/evolution-data-server-%%VERSION%%/exchange/exchange-folder-size.h
include/evolution-data-server-%%VERSION%%/exchange/exchange-hierarchy-foreign.h
include/evolution-data-server-%%VERSION%%/exchange/exchange-hierarchy-somedav.h
@@ -174,6 +176,7 @@ include/evolution-data-server-%%VERSION%%/libecal/e-cal-view-listener.h
include/evolution-data-server-%%VERSION%%/libecal/e-cal-view.h
include/evolution-data-server-%%VERSION%%/libecal/e-cal.h
include/evolution-data-server-%%VERSION%%/libedata-book/Evolution-DataServer-Addressbook.h
+include/evolution-data-server-%%VERSION%%/libedata-book/e-book-backend-db-cache.h
include/evolution-data-server-%%VERSION%%/libedata-book/e-book-backend-cache.h
include/evolution-data-server-%%VERSION%%/libedata-book/e-book-backend-factory.h
include/evolution-data-server-%%VERSION%%/libedata-book/e-book-backend-sexp.h
@@ -291,10 +294,10 @@ lib/evolution-data-server-%%EVO_VERSION%%/camel-providers/libcamelimap.a
lib/evolution-data-server-%%EVO_VERSION%%/camel-providers/libcamelimap.la
lib/evolution-data-server-%%EVO_VERSION%%/camel-providers/libcamelimap.so
lib/evolution-data-server-%%EVO_VERSION%%/camel-providers/libcamelimap.urls
-lib/evolution-data-server-%%EVO_VERSION%%/camel-providers/libcamelimap4.a
-lib/evolution-data-server-%%EVO_VERSION%%/camel-providers/libcamelimap4.la
-lib/evolution-data-server-%%EVO_VERSION%%/camel-providers/libcamelimap4.so
-lib/evolution-data-server-%%EVO_VERSION%%/camel-providers/libcamelimap4.urls
+%%IMAP4%%lib/evolution-data-server-%%EVO_VERSION%%/camel-providers/libcamelimap4.a
+%%IMAP4%%lib/evolution-data-server-%%EVO_VERSION%%/camel-providers/libcamelimap4.la
+%%IMAP4%%lib/evolution-data-server-%%EVO_VERSION%%/camel-providers/libcamelimap4.so
+%%IMAP4%%lib/evolution-data-server-%%EVO_VERSION%%/camel-providers/libcamelimap4.urls
lib/evolution-data-server-%%EVO_VERSION%%/camel-providers/libcamellocal.a
lib/evolution-data-server-%%EVO_VERSION%%/camel-providers/libcamellocal.la
lib/evolution-data-server-%%EVO_VERSION%%/camel-providers/libcamellocal.so
@@ -356,11 +359,11 @@ lib/libcamel-provider-%%EVO_VERSION%%.so.8
lib/libebook-%%EVO_VERSION%%.a
lib/libebook-%%EVO_VERSION%%.la
lib/libebook-%%EVO_VERSION%%.so
-lib/libebook-%%EVO_VERSION%%.so.5
+lib/libebook-%%EVO_VERSION%%.so.9
lib/libecal-%%EVO_VERSION%%.a
lib/libecal-%%EVO_VERSION%%.la
lib/libecal-%%EVO_VERSION%%.so
-lib/libecal-%%EVO_VERSION%%.so.6
+lib/libecal-%%EVO_VERSION%%.so.7
lib/libedata-book-%%EVO_VERSION%%.a
lib/libedata-book-%%EVO_VERSION%%.la
lib/libedata-book-%%EVO_VERSION%%.so
@@ -368,7 +371,7 @@ lib/libedata-book-%%EVO_VERSION%%.so.2
lib/libedata-cal-%%EVO_VERSION%%.a
lib/libedata-cal-%%EVO_VERSION%%.la
lib/libedata-cal-%%EVO_VERSION%%.so
-lib/libedata-cal-%%EVO_VERSION%%.so.5
+lib/libedata-cal-%%EVO_VERSION%%.so.6
lib/libedataserver-%%EVO_VERSION%%.a
lib/libedataserver-%%EVO_VERSION%%.la
lib/libedataserver-%%EVO_VERSION%%.so
@@ -376,15 +379,15 @@ lib/libedataserver-%%EVO_VERSION%%.so.7
lib/libedataserverui-%%EVO_VERSION%%.a
lib/libedataserverui-%%EVO_VERSION%%.la
lib/libedataserverui-%%EVO_VERSION%%.so
-lib/libedataserverui-%%EVO_VERSION%%.so.6
+lib/libedataserverui-%%EVO_VERSION%%.so.8
lib/libegroupwise-%%EVO_VERSION%%.a
lib/libegroupwise-%%EVO_VERSION%%.la
lib/libegroupwise-%%EVO_VERSION%%.so
-lib/libegroupwise-%%EVO_VERSION%%.so.10
+lib/libegroupwise-%%EVO_VERSION%%.so.12
lib/libexchange-storage-%%EVO_VERSION%%.a
lib/libexchange-storage-%%EVO_VERSION%%.la
lib/libexchange-storage-%%EVO_VERSION%%.so
-lib/libexchange-storage-%%EVO_VERSION%%.so.1
+lib/libexchange-storage-%%EVO_VERSION%%.so.2
libdata/bonobo/servers/GNOME_Evolution_DataServer_%%EVO_VERSION%%.server
libdata/pkgconfig/camel-%%EVO_VERSION%%.pc
libdata/pkgconfig/camel-provider-%%EVO_VERSION%%.pc
@@ -413,7 +416,7 @@ share/doc/libebook/index.sgml
share/doc/libebook/left.png
share/doc/libebook/libebook-EAddressWestern.html
share/doc/libebook/libebook-ENameWestern.html
-share/doc/libebook/libebook-e-book-async.html
+share/doc/libebook/EDestination.html
share/doc/libebook/libebook-e-book-query.html
share/doc/libebook/libebook-e-book-types.html
share/doc/libebook/libebook.devhelp
@@ -904,6 +907,7 @@ share/locale/az/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/be/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/bg/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/bn/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
+share/locale/bn_IN/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/bs/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/ca/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/cs/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
@@ -940,12 +944,13 @@ share/locale/lv/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/mk/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/ml/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/mn/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
+share/locale/mr/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/ms/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/nb/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/ne/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/nl/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/nn/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
-share/locale/no/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
+share/locale/or/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/pa/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/pl/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/pt/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
@@ -959,6 +964,7 @@ share/locale/sq/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/sr/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/sr@Latn/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/sv/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
+share/locale/ta/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/th/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/tr/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/uk/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
@@ -968,14 +974,6 @@ share/locale/xh/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/zh_CN/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/zh_HK/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/zh_TW/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
-@dirrmtry share/locale/xh/LC_MESSAGES
-@dirrmtry share/locale/xh
-@dirrmtry share/locale/rw/LC_MESSAGES
-@dirrmtry share/locale/rw
-@dirrmtry share/locale/ku/LC_MESSAGES
-@dirrmtry share/locale/ku
-@dirrmtry share/locale/dz/LC_MESSAGES
-@dirrmtry share/locale/dz
@dirrm share/gnome/pixmaps/evolution-data-server-%%VERSION%%
@dirrm share/gnome/idl/evolution-data-server-%%EVO_VERSION%%
@dirrm share/gnome/evolution-data-server-%%VERSION%%/zoneinfo/Pacific
@@ -1013,3 +1011,55 @@ share/locale/zh_TW/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
@dirrm include/evolution-data-server-%%VERSION%%/exchange
@dirrm include/evolution-data-server-%%VERSION%%/camel
@dirrm include/evolution-data-server-%%VERSION%%
+@dirrmtry share/locale/zh_TW/LC_MESSAGES
+@dirrmtry share/locale/zh_TW
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/zh_CN/LC_MESSAGES
+@dirrmtry share/locale/zh_CN
+@dirrmtry share/locale/xh/LC_MESSAGES
+@dirrmtry share/locale/xh
+@dirrmtry share/locale/uk/LC_MESSAGES
+@dirrmtry share/locale/uk
+@dirrmtry share/locale/sr/LC_MESSAGES
+@dirrmtry share/locale/sr
+@dirrmtry share/locale/sl/LC_MESSAGES
+@dirrmtry share/locale/sl
+@dirrmtry share/locale/sk/LC_MESSAGES
+@dirrmtry share/locale/sk
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
+@dirrmtry share/locale/ro/LC_MESSAGES
+@dirrmtry share/locale/ro
+@dirrmtry share/locale/pt/LC_MESSAGES
+@dirrmtry share/locale/pt
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl
+@dirrmtry share/locale/nn/LC_MESSAGES
+@dirrmtry share/locale/nn
+@dirrmtry share/locale/ne/LC_MESSAGES
+@dirrmtry share/locale/ne
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
+@dirrmtry share/locale/ko/LC_MESSAGES
+@dirrmtry share/locale/ko
+@dirrmtry share/locale/gl/LC_MESSAGES
+@dirrmtry share/locale/gl
+@dirrmtry share/locale/fi/LC_MESSAGES
+@dirrmtry share/locale/fi
+@dirrmtry share/locale/en_AU/LC_MESSAGES
+@dirrmtry share/locale/en_AU
+@dirrmtry share/locale/el/LC_MESSAGES
+@dirrmtry share/locale/el
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
+@dirrmtry share/locale/cs/LC_MESSAGES
+@dirrmtry share/locale/cs
+@dirrmtry share/locale/ca/LC_MESSAGES
+@dirrmtry share/locale/ca
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/be/LC_MESSAGES
+@dirrmtry share/locale/be
diff --git a/databases/libgda2/Makefile b/databases/libgda2/Makefile
index 757e15f510f8..6be5a9c183be 100644
--- a/databases/libgda2/Makefile
+++ b/databases/libgda2/Makefile
@@ -3,11 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/databases/libgda2/Makefile,v 1.35 2006/09/10 00:51:06 mezz Exp $
#
PORTNAME= libgda2
PORTVERSION= 1.2.3
-PORTREVISION?= 1
+PORTREVISION?= 2
PORTEPOCH?= 1
CATEGORIES= databases gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
@@ -29,9 +30,9 @@ RUN_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack glib20 libxslt referencehack
USE_GETTEXT= yes
-USE_X_PREFIX= yes
+USE_XLIB= yes
INSTALLS_OMF= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-bdb
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/databases/libgda2/pkg-plist b/databases/libgda2/pkg-plist
index 11899b4e4441..ba1df008fdb0 100644
--- a/databases/libgda2/pkg-plist
+++ b/databases/libgda2/pkg-plist
@@ -163,3 +163,33 @@ share/locale/zh_TW/LC_MESSAGES/libgda-2.mo
@dirrm include/libgda-%%VERSION%%/libgda
@dirrm include/libgda-%%VERSION%%
@dirrm etc/libgda
+@dirrmtry share/locale/zh_TW/LC_MESSAGES
+@dirrmtry share/locale/zh_TW
+@dirrmtry share/locale/zh_CN/LC_MESSAGES
+@dirrmtry share/locale/zh_CN
+@dirrmtry share/locale/uk/LC_MESSAGES
+@dirrmtry share/locale/uk
+@dirrmtry share/locale/sr/LC_MESSAGES
+@dirrmtry share/locale/sr
+@dirrmtry share/locale/sl/LC_MESSAGES
+@dirrmtry share/locale/sl
+@dirrmtry share/locale/sk/LC_MESSAGES
+@dirrmtry share/locale/sk
+@dirrmtry share/locale/pt/LC_MESSAGES
+@dirrmtry share/locale/pt
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl
+@dirrmtry share/locale/no/LC_MESSAGES
+@dirrmtry share/locale/no
+@dirrmtry share/locale/ko/LC_MESSAGES
+@dirrmtry share/locale/ko
+@dirrmtry share/locale/gl/LC_MESSAGES
+@dirrmtry share/locale/gl
+@dirrmtry share/locale/fi/LC_MESSAGES
+@dirrmtry share/locale/fi
+@dirrmtry share/locale/el/LC_MESSAGES
+@dirrmtry share/locale/el
+@dirrmtry share/locale/cs/LC_MESSAGES
+@dirrmtry share/locale/cs
+@dirrmtry share/locale/ca/LC_MESSAGES
+@dirrmtry share/locale/ca