aboutsummaryrefslogtreecommitdiff
path: root/deskutils/alacarte
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2005-04-03 07:32:47 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2005-04-03 07:32:47 +0000
commitba4856b168aecf313e3ba3024b42c3dda4e86287 (patch)
tree5d939e848b8fca73a37842c358ac3e5007e77c0e /deskutils/alacarte
parent17694d95cd93b34c7805b40c82dc3c1db601e6fb (diff)
downloadports-ba4856b168aecf313e3ba3024b42c3dda4e86287.tar.gz
ports-ba4856b168aecf313e3ba3024b42c3dda4e86287.zip
Notes
Diffstat (limited to 'deskutils/alacarte')
-rw-r--r--deskutils/alacarte/Makefile41
-rw-r--r--deskutils/alacarte/distinfo2
-rw-r--r--deskutils/alacarte/pkg-descr4
-rw-r--r--deskutils/alacarte/pkg-plist8
4 files changed, 55 insertions, 0 deletions
diff --git a/deskutils/alacarte/Makefile b/deskutils/alacarte/Makefile
new file mode 100644
index 000000000000..16e058a46012
--- /dev/null
+++ b/deskutils/alacarte/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: menueditor
+# Date created: 22 March 2005
+# Whom: FreeBSD GNOME Team
+#
+# $FreeBSD$
+#
+
+PORTNAME= menueditor
+PORTVERSION= 0.4.3
+CATEGORIES= deskutils gnome
+MASTER_SITES= http://dev.realistanew.com/menu-editor/ \
+ http://dev.realistanew.com/menu-editor/old/
+DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A simple menu editor for GNOME 2.10
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/xdg/__init__.py:${PORTSDIR}/devel/py-xdg
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_GMAKE= yes
+USE_GNOME= pygtk2
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|\[(libdir,|\[('share/gnome/menu-editor',|g ; \
+ s|, 'lib/|, 'share/gnome/|g ; \
+ s|'share/pixmaps|'share/gnome/pixmaps|g ; \
+ s|'share/applications|'share/gnome/applications|g ; \
+ s|/usr/share|${X11BASE}/share/gnome|g ; \
+ s|/etc|${X11BASE}/etc|g" \
+ ${WRKSRC}/setup.py ${WRKSRC}/bin/menu-editor \
+ ${WRKSRC}/lib/menu-editor/menu_handler.py
+
+post-install:
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/share/gnome/menu-editor
+
+.include <bsd.port.mk>
diff --git a/deskutils/alacarte/distinfo b/deskutils/alacarte/distinfo
new file mode 100644
index 000000000000..70d900868633
--- /dev/null
+++ b/deskutils/alacarte/distinfo
@@ -0,0 +1,2 @@
+MD5 (menueditor_0.4.3.orig.tar.gz) = a25e6749a76e806f6eb19ece02b90281
+SIZE (menueditor_0.4.3.orig.tar.gz) = 12221
diff --git a/deskutils/alacarte/pkg-descr b/deskutils/alacarte/pkg-descr
new file mode 100644
index 000000000000..72cd553d8a92
--- /dev/null
+++ b/deskutils/alacarte/pkg-descr
@@ -0,0 +1,4 @@
+A simple menu editor for GNOME 2.10 that can edit and add new entries. It
+implements the fd.o menu spec but may or may not work with other DEs.
+
+WWW: http://www.realistanew.com/2005/03/18/gnome-menu-editor/
diff --git a/deskutils/alacarte/pkg-plist b/deskutils/alacarte/pkg-plist
new file mode 100644
index 000000000000..a27895907cbc
--- /dev/null
+++ b/deskutils/alacarte/pkg-plist
@@ -0,0 +1,8 @@
+bin/menu-editor
+share/doc/menu-editor/AUTHORS
+share/gnome/applications/menueditor.desktop
+share/gnome/menu-editor/menu_handler.py
+share/gnome/menu-editor/menu_handler.pyc
+share/gnome/pixmaps/menu-editor.png
+@dirrm share/gnome/menu-editor
+@dirrm share/doc/menu-editor