aboutsummaryrefslogtreecommitdiff
path: root/deskutils/alacarte
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2005-06-05 19:51:24 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2005-06-05 19:51:24 +0000
commit435998af62ad723aceebc6c83ac633bcdb1c527a (patch)
treecfa9d3bcfe6bc8693e5a89eb36a67ca84020df53 /deskutils/alacarte
parentf61113f5961ca9b8464305ffd3c7df5865708dba (diff)
downloadports-435998af62ad723aceebc6c83ac633bcdb1c527a.tar.gz
ports-435998af62ad723aceebc6c83ac633bcdb1c527a.zip
Notes
Diffstat (limited to 'deskutils/alacarte')
-rw-r--r--deskutils/alacarte/Makefile32
-rw-r--r--deskutils/alacarte/distinfo4
-rw-r--r--deskutils/alacarte/pkg-descr5
-rw-r--r--deskutils/alacarte/pkg-plist20
4 files changed, 29 insertions, 32 deletions
diff --git a/deskutils/alacarte/Makefile b/deskutils/alacarte/Makefile
index 33cb944100d5..969f663e2de8 100644
--- a/deskutils/alacarte/Makefile
+++ b/deskutils/alacarte/Makefile
@@ -5,37 +5,31 @@
# $FreeBSD$
#
-PORTNAME= menueditor
-PORTVERSION= 0.4.3
-CATEGORIES= deskutils gnome
-MASTER_SITES= http://dev.realistanew.com/menu-editor/ \
- http://dev.realistanew.com/menu-editor/old/
-DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
+PORTNAME= smeg
+PORTVERSION= 0.7.4
+CATEGORIES= deskutils
+MASTER_SITES= http://dev.realistanew.com/${PORTNAME}/${PORTVERSION}/
MAINTAINER= gnome@FreeBSD.org
-COMMENT= A simple menu editor for GNOME 2.10
+COMMENT= An editor for the freedesktop.org menu specification
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/xdg/__init__.py:${PORTSDIR}/devel/py-xdg
-WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_GMAKE= yes
-USE_GNOME= pygtk2 gnomehier
+USE_GNOME= pygtk2
USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
post-patch:
- @${REINPLACE_CMD} -e "s|\[(libdir,|\[('share/gnome/menu-editor',|g ; \
- s|, 'lib/|, 'share/gnome/|g ; \
- s|'share/pixmaps|'share/gnome/pixmaps|g ; \
- s|'share/applications|'share/gnome/applications|g ; \
- s|/usr/share|${X11BASE}/share/gnome|g ; \
- s|/etc|${X11BASE}/etc|g" \
- ${WRKSRC}/setup.py ${WRKSRC}/bin/menu-editor \
- ${WRKSRC}/lib/menu-editor/menu_handler.py
+ @${REINPLACE_CMD} -e "s|libdir, glob|'share/${PORTNAME}', glob|g ; \
+ s|, 'lib/|, 'share/|g ; s|/usr/share|${X11BASE}/share|g" \
+ ${WRKSRC}/setup.py ${WRKSRC}/bin/${PORTNAME} \
+ ${WRKSRC}/lib/${PORTNAME}/MenuHandler.py \
+ ${WRKSRC}/lib/${PORTNAME}/DialogHandler.py
post-install:
- @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/share/gnome/menu-editor
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py \
+ ${PREFIX}/share/${PORTNAME}
.include <bsd.port.mk>
diff --git a/deskutils/alacarte/distinfo b/deskutils/alacarte/distinfo
index 70d900868633..d9bb7b993055 100644
--- a/deskutils/alacarte/distinfo
+++ b/deskutils/alacarte/distinfo
@@ -1,2 +1,2 @@
-MD5 (menueditor_0.4.3.orig.tar.gz) = a25e6749a76e806f6eb19ece02b90281
-SIZE (menueditor_0.4.3.orig.tar.gz) = 12221
+MD5 (smeg-0.7.4.tar.gz) = 3611bebd337ce4d4799a1d6887240399
+SIZE (smeg-0.7.4.tar.gz) = 21899
diff --git a/deskutils/alacarte/pkg-descr b/deskutils/alacarte/pkg-descr
index 72cd553d8a92..fdb5e2aafcf2 100644
--- a/deskutils/alacarte/pkg-descr
+++ b/deskutils/alacarte/pkg-descr
@@ -1,4 +1,3 @@
-A simple menu editor for GNOME 2.10 that can edit and add new entries. It
-implements the fd.o menu spec but may or may not work with other DEs.
+Smeg is an editor for the freedesktop.org menu specification.
-WWW: http://www.realistanew.com/2005/03/18/gnome-menu-editor/
+WWW: http://www.realistanew.com/projects/smeg/
diff --git a/deskutils/alacarte/pkg-plist b/deskutils/alacarte/pkg-plist
index a27895907cbc..a725979f7a3d 100644
--- a/deskutils/alacarte/pkg-plist
+++ b/deskutils/alacarte/pkg-plist
@@ -1,8 +1,12 @@
-bin/menu-editor
-share/doc/menu-editor/AUTHORS
-share/gnome/applications/menueditor.desktop
-share/gnome/menu-editor/menu_handler.py
-share/gnome/menu-editor/menu_handler.pyc
-share/gnome/pixmaps/menu-editor.png
-@dirrm share/gnome/menu-editor
-@dirrm share/doc/menu-editor
+bin/smeg
+share/applications/smeg-kde.desktop
+share/applications/smeg.desktop
+%%DATADIR%%/DialogHandler.py
+%%DATADIR%%/DialogHandler.pyc
+%%DATADIR%%/MenuHandler.py
+%%DATADIR%%/MenuHandler.pyc
+%%DATADIR%%/config.py
+%%DATADIR%%/config.pyc
+%%DATADIR%%/smeg.glade
+@dirrm %%DATADIR%%
+@unexec rmdir %D/share/applications 2> /dev/null || true