aboutsummaryrefslogtreecommitdiff
path: root/deskutils/aspostit
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-02-07 14:38:10 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-02-07 14:38:10 +0000
commit249c351b016e3236c42883eb7dc5e4041a506ecf (patch)
tree48e5fc545bcb5d104fceb42af4ee2e64e9f47cbb /deskutils/aspostit
parent09b95bf7744d724c704b715831f838a17010505b (diff)
downloadports-249c351b016e3236c42883eb7dc5e4041a506ecf.tar.gz
ports-249c351b016e3236c42883eb7dc5e4041a506ecf.zip
Notes
Diffstat (limited to 'deskutils/aspostit')
-rw-r--r--deskutils/aspostit/Makefile24
-rw-r--r--deskutils/aspostit/files/patch-xpostit.c19
2 files changed, 31 insertions, 12 deletions
diff --git a/deskutils/aspostit/Makefile b/deskutils/aspostit/Makefile
index 5e350fa971c6..4a4c0ec5592f 100644
--- a/deskutils/aspostit/Makefile
+++ b/deskutils/aspostit/Makefile
@@ -1,32 +1,32 @@
-# New ports collection makefile for: ASPostIt
-# Date created: 2 January 1999
-# Whom: Kris Kennaway <kris@FreeBSD.org>
-#
+# Created by: Kris Kennaway <kris@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= aspostit
PORTVERSION= 1.3
PORTREVISION= 6
CATEGORIES= deskutils
-MASTER_SITES= ${MASTER_SITE_AFTERSTEP}
-MASTER_SITE_SUBDIR= apps/aspostit
+MASTER_SITES= AFTERSTEP/apps/aspostit
MAINTAINER= ports@FreeBSD.org
-COMMENT= An AfterStep dockable version of XPostIt
+COMMENT= AfterStep dockable version of XPostIt
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg
+LICENSE= GPLv2 # (or later)
+
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg
USE_XORG= xpm xaw xext x11
USE_GMAKE= yes
-
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
MAN1= aspostit.1
PLIST_FILES= bin/aspostit
+post-extract:
+ @${LN} -sf aspostit.man ${WRKSRC}/aspostit.1
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/aspostit ${PREFIX}/bin/
- ${INSTALL_MAN} ${WRKSRC}/aspostit.man ${PREFIX}/man/man1/aspostit.1
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} aspostit ${PREFIX}/bin)
+ (cd ${WRKSRC} && ${INSTALL_MAN} aspostit.1 ${MANPREFIX}/man/man1)
.include <bsd.port.mk>
diff --git a/deskutils/aspostit/files/patch-xpostit.c b/deskutils/aspostit/files/patch-xpostit.c
new file mode 100644
index 000000000000..943e94175240
--- /dev/null
+++ b/deskutils/aspostit/files/patch-xpostit.c
@@ -0,0 +1,19 @@
+--- xpostit.c.orig 1999-01-08 06:10:27.000000000 +0900
++++ xpostit.c 2012-10-24 01:06:04.000000000 +0900
+@@ -32,6 +32,7 @@
+ #include <X11/Xaw/SimpleMenu.h>
+ #include <signal.h>
+ #include <stdio.h>
++#include <stdlib.h>
+
+ #include "xpostit.h"
+ #include "version.h"
+@@ -130,7 +131,7 @@
+ unsigned long timer_interval; /* auto-save interval */
+ unsigned long alarm_interval; /* alarm check interval */
+
+-void main(argc, argv)
++int main(argc, argv)
+ char **argv;
+ int argc;
+ {