aboutsummaryrefslogtreecommitdiff
path: root/deskutils/ausweisapp2
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2020-03-12 12:56:26 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2020-03-12 12:56:26 +0000
commit92dedd25ab529e1720898948ab0518c293939e1d (patch)
treeaf52e95477631879b6efe2aa1fc3a41561630a99 /deskutils/ausweisapp2
parent7dc8dc5fbf283c3682600af200e787cb4d05b915 (diff)
downloadports-92dedd25ab529e1720898948ab0518c293939e1d.tar.gz
ports-92dedd25ab529e1720898948ab0518c293939e1d.zip
Notes
Diffstat (limited to 'deskutils/ausweisapp2')
-rw-r--r--deskutils/ausweisapp2/Makefile31
-rw-r--r--deskutils/ausweisapp2/distinfo3
-rw-r--r--deskutils/ausweisapp2/files/patch-cmake_Install.cmake28
-rw-r--r--deskutils/ausweisapp2/pkg-descr9
-rw-r--r--deskutils/ausweisapp2/pkg-plist7
5 files changed, 78 insertions, 0 deletions
diff --git a/deskutils/ausweisapp2/Makefile b/deskutils/ausweisapp2/Makefile
new file mode 100644
index 000000000000..b17b32295adb
--- /dev/null
+++ b/deskutils/ausweisapp2/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= ausweisapp2
+DISTVERSION= 1.20.0
+CATEGORIES= deskutils security
+
+MAINTAINER= freebsd@sysctl.cz
+COMMENT= Official authentication app for German ID cards and residence permits
+
+LICENSE= EUPLv1.2
+LICENSE_NAME= European Union Public Licence V. 1.2
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+BUILD_DEPENDS= pcsc-lite>0:devel/pcsc-lite
+LIB_DEPENDS= libpcsclite.so:devel/pcsc-lite
+
+USES= cmake pkgconfig qmake qt:5 ssl
+USE_GITHUB= yes
+GH_ACCOUNT= Governikus
+GH_PROJECT= ${_PROGRAM_NAME}
+USE_QT= buildtools concurrent core declarative gui linguisttools \
+ network quickcontrols2 svg websockets widgets
+
+# The VENDOR variable controls the name of the directory in ${PREFIX}/share.
+CMAKE_ARGS= -DVENDOR=${PORTNAME}
+MAKE_ENV= DESTDIR=${STAGEDIR}
+
+_PROGRAM_NAME= AusweisApp2
+
+.include <bsd.port.mk>
diff --git a/deskutils/ausweisapp2/distinfo b/deskutils/ausweisapp2/distinfo
new file mode 100644
index 000000000000..02104bc65a8f
--- /dev/null
+++ b/deskutils/ausweisapp2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1580634267
+SHA256 (Governikus-AusweisApp2-1.20.0_GH0.tar.gz) = 8590b8370fd7a27f639f7678171aeef0898e891fefafc54bd1d58dfc020e373b
+SIZE (Governikus-AusweisApp2-1.20.0_GH0.tar.gz) = 9727544
diff --git a/deskutils/ausweisapp2/files/patch-cmake_Install.cmake b/deskutils/ausweisapp2/files/patch-cmake_Install.cmake
new file mode 100644
index 000000000000..c394634b86b8
--- /dev/null
+++ b/deskutils/ausweisapp2/files/patch-cmake_Install.cmake
@@ -0,0 +1,28 @@
+--- cmake/Install.cmake.orig 2020-03-12 12:06:51 UTC
++++ cmake/Install.cmake
+@@ -273,12 +273,12 @@ ELSEIF(UNIX)
+
+ SET(DEFAULT_FILE_DESTINATION ${CMAKE_INSTALL_DATADIR}/${VENDOR}/AusweisApp2)
+ SET(TRANSLATION_DESTINATION ${DEFAULT_FILE_DESTINATION}/${TRANSLATION_DESTINATION})
+- INSTALL(TARGETS AusweisApp DESTINATION ${CMAKE_INSTALL_BINDIR} COMPONENT Application)
++ INSTALL(TARGETS AusweisApp DESTINATION ${DESTDIR}${CMAKE_INSTALL_BINDIR} COMPONENT Application)
+ CONFIGURE_FILE(${PACKAGING_DIR}/linux/${BUNDLE_IDENTIFIER}.metainfo.xml.in ${CMAKE_CURRENT_BINARY_DIR}/${BUNDLE_IDENTIFIER}.metainfo.xml @ONLY)
+ CONFIGURE_FILE(${PACKAGING_DIR}/linux/${BUNDLE_IDENTIFIER}.desktop.in ${CMAKE_CURRENT_BINARY_DIR}/${BUNDLE_IDENTIFIER}.desktop @ONLY)
+- INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/${BUNDLE_IDENTIFIER}.metainfo.xml DESTINATION ${CMAKE_INSTALL_DATADIR}/metainfo COMPONENT Application)
+- INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/${BUNDLE_IDENTIFIER}.desktop DESTINATION ${CMAKE_INSTALL_DATADIR}/applications COMPONENT Application)
+- INSTALL(FILES ${RESOURCES_DIR}/images/npa.svg DESTINATION ${DEFAULT_FILE_DESTINATION} COMPONENT Application)
++ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/${BUNDLE_IDENTIFIER}.metainfo.xml DESTINATION ${DESTDIR}${CMAKE_INSTALL_DATADIR}/metainfo COMPONENT Application)
++ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/${BUNDLE_IDENTIFIER}.desktop DESTINATION ${DESTDIR}${CMAKE_INSTALL_DATADIR}/applications COMPONENT Application)
++ INSTALL(FILES ${RESOURCES_DIR}/images/npa.svg DESTINATION ${DESTDIR}${DEFAULT_FILE_DESTINATION} COMPONENT Application)
+ ENDIF()
+
+
+@@ -303,7 +303,7 @@ IF(LINUX OR WIN32 OR MAC)
+ ENDIF()
+
+
+-IF(LINUX)
++IF(LINUX OR BSD)
+ INSTALL(FILES ${QM_FILES} DESTINATION ${TRANSLATION_DESTINATION} COMPONENT Translations)
+ ELSEIF(NOT INTEGRATED_SDK)
+ INSTALL(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/translations/ DESTINATION ${TRANSLATION_DESTINATION} COMPONENT Translations)
diff --git a/deskutils/ausweisapp2/pkg-descr b/deskutils/ausweisapp2/pkg-descr
new file mode 100644
index 000000000000..569cedadd916
--- /dev/null
+++ b/deskutils/ausweisapp2/pkg-descr
@@ -0,0 +1,9 @@
+The AusweisApp2 is a software, that you can use to identify yourself online
+with your ID card or your electronic residence permit.
+
+The AusweisApp2 offers you an integrated self-assessment where you are able to
+view your data that is stored on the online ID.
+
+It is being developed on behalf of the German Federal Ministry of the Interior.
+
+WWW: https://www.ausweisapp.bund.de/ausweisapp2/
diff --git a/deskutils/ausweisapp2/pkg-plist b/deskutils/ausweisapp2/pkg-plist
new file mode 100644
index 000000000000..1950ec67e270
--- /dev/null
+++ b/deskutils/ausweisapp2/pkg-plist
@@ -0,0 +1,7 @@
+bin/AusweisApp2
+share/ausweisapp2/AusweisApp2/AusweisApp2.rcc
+share/ausweisapp2/AusweisApp2/config.json
+share/ausweisapp2/AusweisApp2/npa.svg
+share/ausweisapp2/AusweisApp2/translations/ausweisapp2_de.qm
+share/applications/com.governikus.ausweisapp2.desktop
+share/metainfo/com.governikus.ausweisapp2.metainfo.xml