aboutsummaryrefslogtreecommitdiff
path: root/deskutils/buoh
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2005-12-10 19:15:09 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2005-12-10 19:15:09 +0000
commit55705f0b58d0ac57553829af5fdc8d56b0f87b28 (patch)
tree276cea3c780fe0bcdda7947cf28b680e64778547 /deskutils/buoh
parent81507302c51c1c8823a34aa74221e7a0ec7a56c2 (diff)
downloadports-55705f0b58d0ac57553829af5fdc8d56b0f87b28.tar.gz
ports-55705f0b58d0ac57553829af5fdc8d56b0f87b28.zip
Notes
Diffstat (limited to 'deskutils/buoh')
-rw-r--r--deskutils/buoh/Makefile41
-rw-r--r--deskutils/buoh/distinfo3
-rw-r--r--deskutils/buoh/pkg-descr12
-rw-r--r--deskutils/buoh/pkg-plist19
4 files changed, 75 insertions, 0 deletions
diff --git a/deskutils/buoh/Makefile b/deskutils/buoh/Makefile
new file mode 100644
index 000000000000..56eaa654b4a0
--- /dev/null
+++ b/deskutils/buoh/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: buoh
+# Date created: 10 November 2005
+# Whom: Mezz <mezz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= buoh
+PORTVERSION= 0.8.1
+CATEGORIES= deskutils www gnome
+MASTER_SITES= http://buoh.steve-o.org/downloads/
+
+MAINTAINER= mezz@FreeBSD.org
+COMMENT= A reader for online strips comics
+
+USE_GMAKE= yes
+USE_GNOME= gnomehack gnomeprefix intlhack libgnomeui
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+USE_AUTOTOOLS= libtool:15
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+DOCS= AUTHORS COPYING ChangeLog NEWS README TODO
+GCONF_SCHEMAS= buoh.schemas
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|[$$][(]datadir[)]/applications|${X11BASE}/share/applications|g' \
+ ${WRKSRC}/data/Makefile.in
+
+post-install:
+.ifndef (NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+ @${LN} -sf ${DATADIR}/pixmaps/buoh64x64.png \
+ ${X11BASE}/share/pixmaps/buoh64x64.png
+
+.include <bsd.port.mk>
diff --git a/deskutils/buoh/distinfo b/deskutils/buoh/distinfo
new file mode 100644
index 000000000000..92de48946296
--- /dev/null
+++ b/deskutils/buoh/distinfo
@@ -0,0 +1,3 @@
+MD5 (buoh-0.8.1.tar.gz) = 5d05a51d7c6616d93e93df3465b49fe7
+SHA256 (buoh-0.8.1.tar.gz) = 5284ac85b53d65f6653bbf6bb50f15628618595244247cafbf426a5f6761e4c9
+SIZE (buoh-0.8.1.tar.gz) = 411656
diff --git a/deskutils/buoh/pkg-descr b/deskutils/buoh/pkg-descr
new file mode 100644
index 000000000000..66728719c807
--- /dev/null
+++ b/deskutils/buoh/pkg-descr
@@ -0,0 +1,12 @@
+Buoh is a reader for online strips comics. It is free software, designed to
+work well under the GNOME Desktop.
+
+Buoh has a number of features, including:
+
+ - Select your favorites comic through a list of more than 130 comics
+ - Easy, simple an eye-candy view of an online comic
+ - Browsing over the comic strip archives
+ - Saving a comic to disk
+ - Integration with GNOME (respecting the lockdowns and HIG compliance)
+
+WWW: http://buoh.steve-o.org/
diff --git a/deskutils/buoh/pkg-plist b/deskutils/buoh/pkg-plist
new file mode 100644
index 000000000000..3b14bc9818e8
--- /dev/null
+++ b/deskutils/buoh/pkg-plist
@@ -0,0 +1,19 @@
+bin/buoh
+share/applications/buoh.desktop
+%%DATADIR%%/comics/comics.xml
+%%DATADIR%%/pixmaps/buoh16x16.png
+%%DATADIR%%/pixmaps/buoh64x64.png
+%%DATADIR%%/ui/buoh-ui.xml
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+share/pixmaps/buoh64x64.png
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/ui
+@dirrm %%DATADIR%%/pixmaps
+@dirrm %%DATADIR%%/comics
+@dirrm %%DATADIR%%
+@unexec rmdir %D/share/applications 2> /dev/null || true