aboutsummaryrefslogtreecommitdiff
path: root/deskutils/cairo-dock-plugins/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2013-12-24 09:30:23 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2013-12-24 09:30:23 +0000
commitd94d1af223db4e74b95b5c2243e3c1e532df9e3a (patch)
treeb2770551cec34b67ba79d8639a9f081e41655181 /deskutils/cairo-dock-plugins/Makefile
parent7073c9751cebca76fdda41dc891ba1e05f61604d (diff)
Notes
Diffstat (limited to 'deskutils/cairo-dock-plugins/Makefile')
-rw-r--r--deskutils/cairo-dock-plugins/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/deskutils/cairo-dock-plugins/Makefile b/deskutils/cairo-dock-plugins/Makefile
index 779773295d03..1c7da7046bcf 100644
--- a/deskutils/cairo-dock-plugins/Makefile
+++ b/deskutils/cairo-dock-plugins/Makefile
@@ -18,16 +18,14 @@ DATADIR= ${PREFIX}/share/cairo-dock
ICONS_PACKAGE= cairo-dock-plugins-png-icons
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_GNOME= gnomehack glib20 gtk20 librsvg2 libxml2
+USE_GNOME= glib20 gtk20 librsvg2 libxml2
USE_LDCONFIG= yes
USE_PYTHON= yes
USE_XORG= xrender
-USE_DOS2UNIX= YES
USES= cmake gettext pkgconfig
LDFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB+= PYVER="${PYTHON_VERSION:S/thon//}"
-CMAKE_ARGS+= -Dinstall-pc-path:STRING="${LOCALBASE}/libdata/pkgconfig"
+CMAKE_ARGS+= -DROOT_PREFIX:PATH=${STAGEDIR}
OPTIONS_DEFINE= XFCE_INTEGRATION ALSA_MIXER GMENU \
KEYBOARD_INDICATOR IMPULSE \
@@ -44,14 +42,15 @@ WEBLETS_DESC= Weblets applet
OPTIONS_SUB= yes
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@${CP} -R ${WRKDIR}/${ICONS_PACKAGE}/* ${WRKSRC}
- @${FIND} ${WRKSRC} -type f -name "*" | ${XARGS} ${REINPLACE_CMD} -i.orig -e \
+ @${FIND} ${WRKSRC} -type f \( -name "*.c" -o -name "*.conf" \
+ -o -name netspeed -o -name nvidia-config -o -name "*.sh" \
+ -o -name "*.rb" \) | ${XARGS} ${REINPLACE_CMD} -i.orig -e \
's|/bin/bash|${LOCALBASE}/bin/bash|g; \
- s|/usr/bin/python|${LOCALBASE}/bin/python|g; \
+ s|/usr/bin/python|${PYTHON_CMD}|g; \
s|/usr/bin/ruby|${LOCALBASE}/bin/ruby|g; \
s|/usr/share/applications|${LOCALBASE}/share/applications|g; \
s|/usr/share/cairo-dock|${LOCALBASE}/share/cairo-dock|g'