aboutsummaryrefslogtreecommitdiff
path: root/deskutils/calcurse/Makefile
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2011-05-31 13:12:16 +0000
committerFrederic Culot <culot@FreeBSD.org>2011-05-31 13:12:16 +0000
commit264f057b8771c2c4223879f32b9fb6aef0a39e62 (patch)
treeb424b9eb2e6a40d354a504bd3c5dcea598873b66 /deskutils/calcurse/Makefile
parenta7ff5a621186915517da248eb53cbc46b5f9974d (diff)
downloadports-264f057b8771c2c4223879f32b9fb6aef0a39e62.tar.gz
ports-264f057b8771c2c4223879f32b9fb6aef0a39e62.zip
Notes
Diffstat (limited to 'deskutils/calcurse/Makefile')
-rw-r--r--deskutils/calcurse/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/deskutils/calcurse/Makefile b/deskutils/calcurse/Makefile
index 18430f584134..9f902247f953 100644
--- a/deskutils/calcurse/Makefile
+++ b/deskutils/calcurse/Makefile
@@ -5,9 +5,10 @@
# $FreeBSD$
PORTNAME= calcurse
-PORTVERSION= 2.8
+PORTVERSION= 2.9.0
CATEGORIES= deskutils
-MASTER_SITES= ftp://ftp2.culot.org/culot/
+MASTER_SITES= http://calcurse.org/files/ \
+ ftp://ftp2.culot.org/culot/
MAINTAINER= culot@FreeBSD.org
COMMENT= A text-based calendar and scheduling application
@@ -25,4 +26,15 @@ USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
+post-patch:
+.if !defined(NOPORTDOCS)
+ ${REINPLACE_CMD} -e \
+ 's|^docdir = .*|docdir = ${DOCSDIR}|' \
+ ${WRKSRC}/doc/Makefile.in
+.else
+ ${REINPLACE_CMD} -e \
+ '/install-data-am/ s|install-dist_docDATA||' \
+ ${WRKSRC}/doc/Makefile.in
+.endif
+
.include <bsd.port.mk>