aboutsummaryrefslogtreecommitdiff
path: root/deskutils/calibre/Makefile
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2015-02-01 15:46:04 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2015-02-01 15:46:04 +0000
commit425d2781744de349dff968ec6ca374617c0e7a36 (patch)
treefc71137acb6483ffa35e8fc0cc4eee46071236a9 /deskutils/calibre/Makefile
parent997e0966fdd889f1126f216e0381c01f99ad9687 (diff)
downloadports-425d2781744de349dff968ec6ca374617c0e7a36.tar.gz
ports-425d2781744de349dff968ec6ca374617c0e7a36.zip
Notes
Diffstat (limited to 'deskutils/calibre/Makefile')
-rw-r--r--deskutils/calibre/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/deskutils/calibre/Makefile b/deskutils/calibre/Makefile
index c8a9c9dfa6fd..9b67a36743b2 100644
--- a/deskutils/calibre/Makefile
+++ b/deskutils/calibre/Makefile
@@ -3,7 +3,7 @@
PORTNAME= calibre
PORTVERSION= 1.48.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= deskutils python
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}/
@@ -25,7 +25,8 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sip>=0:${PORTSDIR}/devel/py-sip \
${PYTHON_PKGNAMEPREFIX}qt4-webkit>=0:${PORTSDIR}/www/py-qt4-webkit \
${PYTHON_PKGNAMEPREFIX}dateutil>=0:${PORTSDIR}/devel/py-dateutil \
${PYTHON_PKGNAMEPREFIX}pillow>=0:${PORTSDIR}/graphics/py-pillow \
- ${PYTHON_PKGNAMEPREFIX}lxml>=0:${PORTSDIR}/devel/py-lxml
+ ${PYTHON_PKGNAMEPREFIX}lxml>=0:${PORTSDIR}/devel/py-lxml \
+ ${NONEXISTENT}:${PORTSDIR}/x11-toolkits/qt4-gui:patch
RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils \
${PYTHON_PKGNAMEPREFIX}cssutils>=0.9.9:${PORTSDIR}/www/py-cssutils \
${PYTHON_PKGNAMEPREFIX}dnspython>=0:${PORTSDIR}/dns/py-dnspython \
@@ -70,8 +71,14 @@ MAKE_ENV+= FC_INC_DIR="${LOCALBASE}/include/fontconfig" \
XDG_DATA_DIRS=${STAGEDIR}${PREFIX}/share \
XDG_CONFIG_HOME=${WRKDIR}/xdg-config
+.include <bsd.port.pre.mk>
+
+QTGUI_WRKSRC!= cd ${PORTSDIR}/x11-toolkits/qt4-gui && ${MAKE} -V WRKSRC
+
post-patch:
@${FIND} ${WRKSRC}/resources/content_server -name "*.orig" -delete
+ @${REINPLACE_CMD} -e "/^qt_private_inc =/s|\[]|[ '${QTGUI_WRKSRC}/include/QtGui', '${QTGUI_WRKSRC}/include/QtCore' ]|" \
+ ${WRKSRC}/setup/build_environment.py
do-build:
@${MKDIR} ${WRKDIR}/calibre-config ${WRKDIR}/xdg-config
@@ -88,5 +95,6 @@ do-install:
${PYSETUP} install --prefix ${PREFIX} \
--staging-root ${STAGEDIR}${PREFIX})
@${RM} ${STAGEDIR}${PREFIX}/bin/calibre-uninstall
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/calibre/calibre/plugins/*
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>