aboutsummaryrefslogtreecommitdiff
path: root/deskutils/conduit
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-19 10:40:22 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-19 10:40:22 +0000
commit2a3357182d8cb640f374f8c60b71b6c99ec43843 (patch)
tree7a5f4c1c91d14d9fcab2b30589db732cde4a3725 /deskutils/conduit
parent92fdeef4740a0893f904a81b5150a5e3f5604b10 (diff)
downloadports-2a3357182d8cb640f374f8c60b71b6c99ec43843.tar.gz
ports-2a3357182d8cb640f374f8c60b71b6c99ec43843.zip
Convert almost all gnome@ ports to OptionsNG, trim header, use USES=pathfix
instead of gnomehack and pet portlint. Add conflicts with future gnome3 versions. Reviewed by: miwi, bapt
Notes
Notes: svn path=/head/; revision=314632
Diffstat (limited to 'deskutils/conduit')
-rw-r--r--deskutils/conduit/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/deskutils/conduit/Makefile b/deskutils/conduit/Makefile
index 77bb3e9a54f6..170d5e80c0f8 100644
--- a/deskutils/conduit/Makefile
+++ b/deskutils/conduit/Makefile
@@ -1,6 +1,7 @@
# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/deskutils/conduit/Makefile,v 1.7 2008/03/18 14:53:42 ahze Exp $
+
PORTNAME= conduit
PORTVERSION= 0.3.17
PORTREVISION= 6
@@ -32,17 +33,20 @@ INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_GNOME= pygnome2 gnomeprefix
-OPTIONS= NAUTILUS "Enable Nautilus Plugin" On \
- EOG "Enable Eye-Of-Gnome Plugin" On
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= NAUTILUS EOG
+OPTIONS_DEFAULT=NAUTILUS EOG
+NAUTILUS_DESC= Build Nautilus Plugin
+EOG_DESC= Build Eye-Of-Gnome Plugin
+
+.include <bsd.port.options.mk>
-.if defined(WITH_NAUTILUS)
+.if ${PORT_OPTIONS:MNAUTILUS}
USE_GNOME+= nautilus2
CONFIGURE_ARGS+= --enable-nautilus-extension
.endif
-.if defined(WITH_EOG)
+.if ${PORT_OPTIONS:MEOG}
BUILD_DEPENDS+= eog:${PORTSDIR}/graphics/eog
RUN_DEPENDS+= eog:${PORTSDIR}/graphics/eog
CONFIGURE_ARGS+= --enable-eog-plugin
@@ -55,4 +59,4 @@ post-patch:
-e 's|/usr/bin/python|${LOCALBASE}/bin/python|' \
-e 's|/usr/lib/firefox*|${LOCALBASE}/lib/firefox|'
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>