aboutsummaryrefslogtreecommitdiff
path: root/deskutils/copyq/Makefile
diff options
context:
space:
mode:
authorKris Moore <kmoore@FreeBSD.org>2016-07-21 18:47:55 +0000
committerKris Moore <kmoore@FreeBSD.org>2016-07-21 18:47:55 +0000
commit780c9ecaf3adb806021bb9ad41da4c4e326a1a2d (patch)
treef5928a90a25c5e16a2ee2033ec76a4388d9c4df9 /deskutils/copyq/Makefile
parent7e8f632366746ff8e1a682d98a5d17158558b919 (diff)
downloadports-780c9ecaf3adb806021bb9ad41da4c4e326a1a2d.tar.gz
ports-780c9ecaf3adb806021bb9ad41da4c4e326a1a2d.zip
Notes
Diffstat (limited to 'deskutils/copyq/Makefile')
-rw-r--r--deskutils/copyq/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/deskutils/copyq/Makefile b/deskutils/copyq/Makefile
new file mode 100644
index 000000000000..f27e3e5af058
--- /dev/null
+++ b/deskutils/copyq/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= copyq
+PORTVERSION= 2.7.1
+DISTVERSIONPREFIX= v
+CATEGORIES= deskutils
+
+MAINTAINER= kris@ixsystems.com
+COMMENT= Qt5 based clipboard manager
+
+LICENSE= GPLv3
+
+USE_XORG+= x11 xfixes xtst
+USE_QT5= core gui network svg multimedia imageformats \
+ buildtools_build x11extras concurrent widgets xml \
+ script
+USE_GL+= gl
+USES= qmake
+
+PLIST_FILES= bin/copyq
+
+USE_GITHUB= yes
+GH_ACCOUNT= hluk
+GH_PROJECT= CopyQ
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/copyq ${STAGEDIR}${PREFIX}/bin/copyq
+
+.include <bsd.port.mk>