aboutsummaryrefslogtreecommitdiff
path: root/deskutils/dailystrips/Makefile
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2003-12-21 01:51:36 +0000
committerPete Fritchman <petef@FreeBSD.org>2003-12-21 01:51:36 +0000
commitc5fc78084c3c807bfa74965a8ebd2df51a8304a1 (patch)
tree1034e183056994cf95af9c64fd5bcf455a947093 /deskutils/dailystrips/Makefile
parent5ed2fa798731802195687253eefa05d0a9afe04b (diff)
downloadports-c5fc78084c3c807bfa74965a8ebd2df51a8304a1.tar.gz
ports-c5fc78084c3c807bfa74965a8ebd2df51a8304a1.zip
Notes
Diffstat (limited to 'deskutils/dailystrips/Makefile')
-rw-r--r--deskutils/dailystrips/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/deskutils/dailystrips/Makefile b/deskutils/dailystrips/Makefile
index 4f477f08a962..06b909b0a71a 100644
--- a/deskutils/dailystrips/Makefile
+++ b/deskutils/dailystrips/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dailystrips
PORTVERSION= 1.0.28
+PORTREVISION= 1
CATEGORIES= deskutils www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -24,16 +25,19 @@ USE_REINPLACE= yes
post-patch:
@${REINPLACE_CMD} 's|^#!/usr/bin/perl|#!${PERL}|; \
s!/usr/share/dailystrips/strips.def!${DATADIR}/strips.def!' \
- ${WRKSRC}/dailystrips
+ ${WRKSRC}/dailystrips ${WRKSRC}/dailystrips-clean \
+ ${WRKSRC}/dailystrips-update
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/dailystrips ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/dailystrips-clean ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/dailystrips-update ${PREFIX}/bin
@${MKDIR} ${DATADIR}
${INSTALL_SCRIPT} ${WRKSRC}/strips.def ${DATADIR}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for file in README README.DEFS README.LOCAL
+.for file in README README.DEFS README.LOCAL README.dailystrips-clean \
+ README.dailystrips-update
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif