aboutsummaryrefslogtreecommitdiff
path: root/deskutils/deforaos-todo
diff options
context:
space:
mode:
authorOlivier Cochard <olivier@FreeBSD.org>2016-03-09 13:31:43 +0000
committerOlivier Cochard <olivier@FreeBSD.org>2016-03-09 13:31:43 +0000
commitae5da009000402ece052374593481ec5e12c3304 (patch)
tree6b65a918f2080fba5065b1624f3d0a633ca2743a /deskutils/deforaos-todo
parentecf1495a3e403a8015090f155706a16a91c2524c (diff)
downloadports-ae5da009000402ece052374593481ec5e12c3304.tar.gz
ports-ae5da009000402ece052374593481ec5e12c3304.zip
Notes
Diffstat (limited to 'deskutils/deforaos-todo')
-rw-r--r--deskutils/deforaos-todo/Makefile33
-rw-r--r--deskutils/deforaos-todo/distinfo4
-rw-r--r--deskutils/deforaos-todo/files/patch-doc_Makefile11
-rw-r--r--deskutils/deforaos-todo/pkg-plist7
4 files changed, 47 insertions, 8 deletions
diff --git a/deskutils/deforaos-todo/Makefile b/deskutils/deforaos-todo/Makefile
index ec4e969a3155..9e99c3a8d8d5 100644
--- a/deskutils/deforaos-todo/Makefile
+++ b/deskutils/deforaos-todo/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= todo
-PORTVERSION= 0.1.2
-PORTREVISION= 2
+PORTVERSION= 0.2.1
CATEGORIES= deskutils
-MASTER_SITES= http://www.defora.org/os/download/download/3506/
+MASTER_SITES= http://www.defora.org/os/download/download/4429/
PKGNAMEPREFIX= deforaos-
DISTNAME= Todo-${PORTVERSION}
@@ -16,10 +15,36 @@ LICENSE= GPLv3
LIB_DEPENDS= libSystem.so:${PORTSDIR}/devel/deforaos-libsystem \
libDesktop.so:${PORTSDIR}/x11/deforaos-libdesktop
+BUILD_DEPENDS= ${LOCALBASE}/include/Desktop/Mailer/plugin.h:${PORTSDIR}/mail/deforaos-mailer
-USES= desktop-file-utils gettext pkgconfig
+USES= desktop-file-utils pkgconfig
USE_GNOME= gtk20
INSTALLS_ICONS= yes
MAKE_ARGS+= PREFIX=${PREFIX}
+MAKE_ENV= MANDIR=${STAGEDIR}${MANPREFIX}/man
+
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
+NLS_USES= gettext
+DOCS_BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt \
+ ${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl:${PORTSDIR}/textproc/docbook-xsl
+
+post-patch-DOCS-off:
+ ${REINPLACE_CMD} 's|= data doc|= data|' \
+ ${WRKSRC}/Makefile
+
+post-patch-NLS-off:
+ ${REINPLACE_CMD} 's|po src tools|src tools|' \
+ ${WRKSRC}/Makefile
+
+post-patch:
+ ${REINPLACE_CMD} 's|-Wl,-pie||g' \
+ ${WRKSRC}/tools/Makefile \
+ ${WRKSRC}/src/Makefile
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/todo \
+ ${STAGEDIR}${PREFIX}/lib/Mailer/plugins/todo.so
+
.include <bsd.port.mk>
diff --git a/deskutils/deforaos-todo/distinfo b/deskutils/deforaos-todo/distinfo
index 32d63ba15d35..c6c3352373c4 100644
--- a/deskutils/deforaos-todo/distinfo
+++ b/deskutils/deforaos-todo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Todo-0.1.2.tar.gz) = febf0191e55b7b28447d4f2b9199a23b09ffa1ead10953f081f418edf84301f1
-SIZE (Todo-0.1.2.tar.gz) = 33195
+SHA256 (Todo-0.2.1.tar.gz) = 08bbe78cbce11944af962f728463bee3c1dc001e1ebefda19431fa5f258e2a8e
+SIZE (Todo-0.2.1.tar.gz) = 29369
diff --git a/deskutils/deforaos-todo/files/patch-doc_Makefile b/deskutils/deforaos-todo/files/patch-doc_Makefile
new file mode 100644
index 000000000000..477ae157fedf
--- /dev/null
+++ b/deskutils/deforaos-todo/files/patch-doc_Makefile
@@ -0,0 +1,11 @@
+--- doc/Makefile.orig 2016-03-05 17:04:57 UTC
++++ doc/Makefile
+@@ -30,8 +30,6 @@ distclean: clean
+
+ install: $(TARGETS)
+ ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -i -- "$(OBJDIR)todo.1"
+- ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -i -- "$(OBJDIR)todo.html"
+- ../tools/subst.sh -P "$(DESTDIR)$(PREFIX)" -i -- "$(OBJDIR)todo.xml"
+
+ uninstall:
+ ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -u -- "todo.1"
diff --git a/deskutils/deforaos-todo/pkg-plist b/deskutils/deforaos-todo/pkg-plist
index 3f1edf19f54a..fd467b50d802 100644
--- a/deskutils/deforaos-todo/pkg-plist
+++ b/deskutils/deforaos-todo/pkg-plist
@@ -1,6 +1,9 @@
bin/todo
-share/applications/todo.desktop
+%%PORTDOCS%%man/man1/todo.1.gz
+share/applications/deforaos-todo.desktop
share/icons/hicolor/16x16/apps/todo.png
share/icons/hicolor/24x24/apps/todo.png
share/icons/hicolor/48x48/apps/todo.png
-share/locale/fr/LC_MESSAGES/Todo.mo
+lib/Mailer/plugins/todo.so
+%%NLS%%share/locale/fr/LC_MESSAGES/Todo.mo
+%%NLS%%share/locale/es/LC_MESSAGES/Todo.mo