aboutsummaryrefslogtreecommitdiff
path: root/deskutils/doodle/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-06-26 15:17:56 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-06-26 15:17:56 +0000
commit89e567e0eb5901b66dc5da7e77f3eae153f5e054 (patch)
treeeb0fe511ba107f83ab46b9d3d64fbf9890d12c85 /deskutils/doodle/Makefile
parentd6ddc22771ffa9d13f41ed0ecc3fb1c8d0e10b87 (diff)
downloadports-89e567e0eb5901b66dc5da7e77f3eae153f5e054.tar.gz
ports-89e567e0eb5901b66dc5da7e77f3eae153f5e054.zip
Notes
Diffstat (limited to 'deskutils/doodle/Makefile')
-rw-r--r--deskutils/doodle/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/deskutils/doodle/Makefile b/deskutils/doodle/Makefile
new file mode 100644
index 000000000000..919c36875ac0
--- /dev/null
+++ b/deskutils/doodle/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: doodle
+# Date created: 26 June 2005
+# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
+# Jean-Yves Lefort <jylefort@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= doodle
+PORTVERSION= 0.6.2
+CATEGORIES= deskutils
+MASTER_SITES= http://gnunet.org/doodle/download/
+
+MAINTAINER= jylefort@FreeBSD.org
+COMMENT= Quickly search documents
+
+LIB_DEPENDS= extractor.1:${PORTSDIR}/textproc/libextractor
+
+USE_REINPLACE= yes
+USE_LIBTOOL_VER=15
+USE_GETTEXT= yes
+USE_FAM= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= doodle.1 doodled.1
+MAN3= libdoodle.3
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|,\$$PTHREAD_CPPFLAGS,|,${PTHREAD_CFLAGS},|; \
+ s|,\$$PTHREAD_LIBS,|,${PTHREAD_LIBS},|; \
+ s|,\$$PTHREAD_LDFLAGS,|,,|;' ${WRKSRC}/configure
+
+.include <bsd.port.mk>