aboutsummaryrefslogtreecommitdiff
path: root/deskutils/etoile-extendedworkspacekit/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-11-19 16:34:12 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-11-19 16:34:12 +0000
commitf39c5127321e8a96b02f4613f80b55e3f4a0b5bd (patch)
tree89ea3e2fce99f720fa0a2ccae86fc00661ab0aff /deskutils/etoile-extendedworkspacekit/Makefile
parent35015d38aa4a7208d8bfcd13c7ee1b5c487b3ea8 (diff)
Notes
Diffstat (limited to 'deskutils/etoile-extendedworkspacekit/Makefile')
-rw-r--r--deskutils/etoile-extendedworkspacekit/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/deskutils/etoile-extendedworkspacekit/Makefile b/deskutils/etoile-extendedworkspacekit/Makefile
new file mode 100644
index 000000000000..d76737ddd957
--- /dev/null
+++ b/deskutils/etoile-extendedworkspacekit/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: etoile-extendedworkspacekit
+# Date created: 18 Nov 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= extendedworkspacekit
+PORTVERSION= 0.1.${SNAPSHOT}
+CATEGORIES= deskutils
+MASTER_SITES= http://florida.ethz.ch/ports/distfiles/
+PKGNAMEPREFIX= etoile-
+DISTNAME= etoile_0+${SNAPSHOT}+dfsg.orig
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Etoile Project ExtendedWorkspaceKit framework
+
+SNAPSHOT= 20060917
+WRKSRC= ${WRKDIR}/etoile-0+${SNAPSHOT}+dfsg/Etoile/
+USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+MAKEFILE= GNUmakefile
+LDCONFIG_DIRS= ${LOCALLIBDIR}
+INSTALLS_SHLIB= yes
+NO_FILTER_SHLIBS= yes
+USE_GNUSTEP_SYSTEM_LIBS+= TrackerKit:${TRACKERKIT_PORT}
+USE_GNUSTEP_MAKE_DIRS+= Frameworks/ExtendedWorkspaceKit
+
+TRACKERKIT_PORT?= deskutils/etoile-trackerkit
+
+.include <bsd.port.mk>