aboutsummaryrefslogtreecommitdiff
path: root/deskutils/etoile-scriptservices
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2008-11-29 12:19:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2008-11-29 12:19:28 +0000
commit96850ec1a5293b5004598b59d0c935fcee2d9930 (patch)
treea2236fb3c72882a2b7b74a5363503008aaf93b55 /deskutils/etoile-scriptservices
parentf4c50564bee6dac760b551a2ef60097c03059a7c (diff)
downloadports-96850ec1a5293b5004598b59d0c935fcee2d9930.tar.gz
ports-96850ec1a5293b5004598b59d0c935fcee2d9930.zip
Notes
Diffstat (limited to 'deskutils/etoile-scriptservices')
-rw-r--r--deskutils/etoile-scriptservices/Makefile41
-rw-r--r--deskutils/etoile-scriptservices/distinfo3
-rw-r--r--deskutils/etoile-scriptservices/pkg-descr10
-rw-r--r--deskutils/etoile-scriptservices/pkg-plist14
4 files changed, 68 insertions, 0 deletions
diff --git a/deskutils/etoile-scriptservices/Makefile b/deskutils/etoile-scriptservices/Makefile
new file mode 100644
index 000000000000..7a0fc9528b4d
--- /dev/null
+++ b/deskutils/etoile-scriptservices/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: etoile-scriptservices
+# Date created: 26 Nov 2008
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= scriptservices
+PORTVERSION= 0.4.0
+CATEGORIES= deskutils gnustep
+MASTER_SITES= http://download.gna.org/etoile/
+PKGNAMEPREFIX= etoile-
+DISTNAME= etoile-${PORTVERSION}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Etoile Project ScriptServices
+
+USE_BZIP2= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+USE_GNUSTEP_LOCAL_LIBS+= EtoileFoundation:${FOUNDATION_PORT}
+USE_GNUSTEP_LOCAL_LIBS+= SmalltalkKit:${SMALLTALKKIT_PORT}
+
+WRKSRC= ${WRKDIR}/Etoile-${PORTVERSION}
+USE_GNUSTEP_MAKE_DIRS+= Services/Private/ScriptServices
+MORE_SRC= ${WRKSRC}/Services/Private/ScriptServices/Examples
+MORE_DEST= ${GNUSTEP_PREFIX}/Local/Applications/ScriptServices.app/Resources/Scripts/
+EXAMPLE= Current_Time_.sh Open_in_Wikipedia.sh \
+ Open_in_Wiktionary.sh today.sh
+
+FOUNDATION_PORT?= devel/etoile-foundation
+SMALLTALKKIT_PORT?= lang/etoile-smalltalkkit
+
+post-install:
+ cd ${MORE_SRC} && ${INSTALL_DATA} today.plist ${MORE_DEST}
+ cd ${MORE_SRC} && ${INSTALL_SCRIPT} ${EXAMPLE} ${MORE_DEST}
+
+.include <bsd.port.mk>
diff --git a/deskutils/etoile-scriptservices/distinfo b/deskutils/etoile-scriptservices/distinfo
new file mode 100644
index 000000000000..2c1e8a612c54
--- /dev/null
+++ b/deskutils/etoile-scriptservices/distinfo
@@ -0,0 +1,3 @@
+MD5 (etoile-0.4.0.tar.bz2) = 7c33baf8ec3a708d0d419b1e137452de
+SHA256 (etoile-0.4.0.tar.bz2) = 05b5f01932aaad2ae6251ae01a1ad5376d29c984ee83d9fb62688c8d4a20237a
+SIZE (etoile-0.4.0.tar.bz2) = 8225128
diff --git a/deskutils/etoile-scriptservices/pkg-descr b/deskutils/etoile-scriptservices/pkg-descr
new file mode 100644
index 000000000000..2c31b305cc04
--- /dev/null
+++ b/deskutils/etoile-scriptservices/pkg-descr
@@ -0,0 +1,10 @@
+ScriptServices is a gateway between GNUstep system services and Unix scripts.
+It turns Unix scripts into GNUstep system services.
+Scripts should be put under
+~/GNUstep/Library/ApplicaitonSupport/ScriptServices/
+Whenever new scripts are installed, you need to update services by doing
+`openapp ScriptServices --update`
+A default script using `bc` comes with ScriptServices.
+More scripts are in Examples directory.
+
+WWW: http://www.etoile-project.org/
diff --git a/deskutils/etoile-scriptservices/pkg-plist b/deskutils/etoile-scriptservices/pkg-plist
new file mode 100644
index 000000000000..eca04411bd02
--- /dev/null
+++ b/deskutils/etoile-scriptservices/pkg-plist
@@ -0,0 +1,14 @@
+Local/Applications/ScriptServices.app/Resources/Info-gnustep.plist
+Local/Applications/ScriptServices.app/Resources/ScriptServices.desktop
+Local/Applications/ScriptServices.app/Resources/Scripts/Calculate_.sh
+Local/Applications/ScriptServices.app/Resources/Scripts/Current_Time_.sh
+Local/Applications/ScriptServices.app/Resources/Scripts/Open_in_Wikipedia.sh
+Local/Applications/ScriptServices.app/Resources/Scripts/Open_in_Wiktionary.sh
+Local/Applications/ScriptServices.app/Resources/Scripts/today.plist
+Local/Applications/ScriptServices.app/Resources/Scripts/today.sh
+Local/Applications/ScriptServices.app/ScriptServices
+Local/Applications/ScriptServices.app/stamp.make
+Local/Tools/ScriptServices
+@dirrm Local/Applications/ScriptServices.app/Resources/Scripts
+@dirrm Local/Applications/ScriptServices.app/Resources
+@dirrm Local/Applications/ScriptServices.app