aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gdesklets/files
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-02-24 16:07:10 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-02-24 16:07:10 +0000
commit95d93851e690298b11fc931fc75da760d8979999 (patch)
treea42563112303558cb0973a3cd24aff0d45cab5cc /deskutils/gdesklets/files
parent795fa0e37e82f2b43d09f1edcdb5ca7634468d31 (diff)
downloadports-95d93851e690298b11fc931fc75da760d8979999.tar.gz
ports-95d93851e690298b11fc931fc75da760d8979999.zip
Notes
Diffstat (limited to 'deskutils/gdesklets/files')
-rw-r--r--deskutils/gdesklets/files/patch-configure4
-rw-r--r--deskutils/gdesklets/files/patch-data::Makefile.in7
-rw-r--r--deskutils/gdesklets/files/patch-display::TargetLabel.py8
-rw-r--r--deskutils/gdesklets/files/patch-libdesklets::Disk.py27
-rw-r--r--deskutils/gdesklets/files/patch-libdesklets::Network.py11
-rw-r--r--deskutils/gdesklets/files/patch-utils::i18n.py13
6 files changed, 27 insertions, 43 deletions
diff --git a/deskutils/gdesklets/files/patch-configure b/deskutils/gdesklets/files/patch-configure
index 479c5d3e2272..4f69b11cf95b 100644
--- a/deskutils/gdesklets/files/patch-configure
+++ b/deskutils/gdesklets/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig Tue Dec 30 13:22:59 2003
-+++ configure Tue Dec 30 13:23:27 2003
+--- configure.orig Mon Feb 23 10:03:28 2004
++++ configure Mon Feb 23 10:03:58 2004
@@ -18395,6 +18395,7 @@
# This can be used to rebuild libtool when needed
diff --git a/deskutils/gdesklets/files/patch-data::Makefile.in b/deskutils/gdesklets/files/patch-data::Makefile.in
index 4b5c1988a09d..4631224af96d 100644
--- a/deskutils/gdesklets/files/patch-data::Makefile.in
+++ b/deskutils/gdesklets/files/patch-data::Makefile.in
@@ -1,11 +1,12 @@
---- data/Makefile.in.orig Tue Dec 30 13:24:16 2003
-+++ data/Makefile.in Tue Dec 30 13:25:10 2003
-@@ -208,7 +208,7 @@
+--- data/Makefile.in.orig Mon Feb 23 09:58:01 2004
++++ data/Makefile.in Mon Feb 23 09:59:27 2004
+@@ -213,7 +213,8 @@
@USERINST_TRUE@mimedir = ~/.gnome/mime-info
mime_in_files = gdesklets.keys.in
mime_DATA = $(mime_in_files:.keys.in=.keys) gdesklets.mime
-@USERINST_FALSE@mimeicondir = $(datadir)/icons/gnome/48x48/mimetypes
+@USERINST_FALSE@mimeicondir = $(prefix)/share/icons/gnome/48x48/mimetypes
++
@USERINST_TRUE@mimeicondir = ~/.icons/gnome/48x48/mimetypes
mimeicon_DATA = x-gdesklets-display.png
diff --git a/deskutils/gdesklets/files/patch-display::TargetLabel.py b/deskutils/gdesklets/files/patch-display::TargetLabel.py
index 005b5aa7aa93..9c355009b2cc 100644
--- a/deskutils/gdesklets/files/patch-display::TargetLabel.py
+++ b/deskutils/gdesklets/files/patch-display::TargetLabel.py
@@ -1,13 +1,13 @@
---- display/TargetLabel.py.orig Tue Dec 30 13:26:48 2003
-+++ display/TargetLabel.py Tue Dec 30 13:27:20 2003
-@@ -90,7 +90,14 @@
+--- display/TargetLabel.py.orig Mon Feb 23 09:55:46 2004
++++ display/TargetLabel.py Mon Feb 23 09:56:50 2004
+@@ -103,7 +103,14 @@
# determine the locale
import commands
+import string
fail, CHARMAP = commands.getstatusoutput("locale charmap")
+if (fail or not CHARMAP):
-+ fail, CHARMAP = commands.getstatusoutput("echo $MM_CHARSET")
++ fail, CHARMAP = commands.getstatusoutput("echo $MM_CHARSET")
+ if (fail or not CHARMAP):
+ fail, CHARMAP = commands.getstatusoutput("echo $LANG")
+ CHARMAP = CHARMAP[string.find(CHARMAP, ".")+1:len(CHARMAP)]
diff --git a/deskutils/gdesklets/files/patch-libdesklets::Disk.py b/deskutils/gdesklets/files/patch-libdesklets::Disk.py
index ee68f1451d31..0b4a640d965a 100644
--- a/deskutils/gdesklets/files/patch-libdesklets::Disk.py
+++ b/deskutils/gdesklets/files/patch-libdesklets::Disk.py
@@ -1,16 +1,5 @@
-# Many thanks to Alexander Leidinger <netchild@FreeBSD.org> and
-# Franz Klammer <klammer@webonaut.com> for help and create
-# those patches.
-#
-# Note that, this is for now. It will be remove when the
-# libgtop is update to 2.6 or maybe I can ask gnome@freebsd.org
-# if they won't mind to add a patch in libgtop 2.4 to get this
-# patch remove.
-#
-# Joe has fixed it in the libgtop 2.5.x and isn't in ports yet.
-
---- libdesklets/Disk.py.orig Tue Dec 30 13:29:57 2003
-+++ libdesklets/Disk.py Tue Dec 30 13:31:01 2003
+--- libdesklets/Disk.py.orig Mon Feb 23 10:52:50 2004
++++ libdesklets/Disk.py Mon Feb 23 10:54:31 2004
@@ -1,6 +1,6 @@
import glibtop
import polling
@@ -19,8 +8,8 @@
class Disk:
-@@ -14,18 +14,22 @@
-
+@@ -21,14 +21,19 @@
+ #
def __poll_partitions(self):
- data = glibtop.get_mountlist(0)
@@ -42,11 +31,7 @@
+ "hfs", "befs", "bfs", "efs", "iso9660", "minix",
+ "sysv", "coda", "nfs", "udf", "ufs", "xiafs")):
+ partitions.append((fields[0], fields[1]))
- #end for
-
- return partitions
--
+
-
- def __poll_size(self, partition):
+ return partitions
+
diff --git a/deskutils/gdesklets/files/patch-libdesklets::Network.py b/deskutils/gdesklets/files/patch-libdesklets::Network.py
new file mode 100644
index 000000000000..1fd0d059ee8d
--- /dev/null
+++ b/deskutils/gdesklets/files/patch-libdesklets::Network.py
@@ -0,0 +1,11 @@
+--- libdesklets/Network.py.orig Mon Feb 23 11:01:31 2004
++++ libdesklets/Network.py Mon Feb 23 11:01:55 2004
+@@ -142,7 +142,7 @@
+
+ if ("FreeBSD" == platform or "NetBSD" == platform):
+ fd = os.popen("ifconfig -a | grep mtu", "r")
+- data = fs.readlines()
++ data = fd.readlines()
+ fd.close()
+
+ for lines in data:
diff --git a/deskutils/gdesklets/files/patch-utils::i18n.py b/deskutils/gdesklets/files/patch-utils::i18n.py
deleted file mode 100644
index f62cd5a201d3..000000000000
--- a/deskutils/gdesklets/files/patch-utils::i18n.py
+++ /dev/null
@@ -1,13 +0,0 @@
---- utils/i18n.py.orig Sun Jan 4 13:56:21 2004
-+++ utils/i18n.py Sun Jan 4 14:26:10 2004
-@@ -12,6 +12,9 @@
- translate = gettext.translation(domain, localedir).gettext
-
- except:
-- translate = dummy
-+ try:
-+ translate = gettext.translation("gdesklets", localedir).gettext
-+ except:
-+ translate = dummy
-
- return translate