aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gdesklets
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-10-24 23:37:25 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-10-24 23:37:25 +0000
commit4acc6fb2a411b291c9c210d82bafe7c62e71c77d (patch)
treebc16420eb52d65511ceb520c00171d219210a473 /deskutils/gdesklets
parent97dfcc1b41c5b4581b1d73128a866beec069c5bf (diff)
Notes
Diffstat (limited to 'deskutils/gdesklets')
-rw-r--r--deskutils/gdesklets/Makefile6
-rw-r--r--deskutils/gdesklets/files/patch-data::Makefile.in11
-rw-r--r--deskutils/gdesklets/files/patch-main::__init__.py11
-rw-r--r--deskutils/gdesklets/pkg-install2
-rw-r--r--deskutils/gdesklets/pkg-plist19
5 files changed, 14 insertions, 35 deletions
diff --git a/deskutils/gdesklets/Makefile b/deskutils/gdesklets/Makefile
index f15efdcdbc5f..7b2b3323e45d 100644
--- a/deskutils/gdesklets/Makefile
+++ b/deskutils/gdesklets/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gdesklets
PORTVERSION= 0.35.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils gnome
MASTER_SITES= http://www.gdesklets.org/downloads/ \
http://www.pycage.de/download/${PORTNAME}/ \
@@ -45,8 +45,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_C
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
post-install:
- @${MKDIR} ${PREFIX}/share/gnome/gdesklets/Displays
- @${MKDIR} ${PREFIX}/share/gnome/gdesklets/Sensors
+ @${MKDIR} ${PREFIX}/share/gdesklets/Displays
+ @${MKDIR} ${PREFIX}/share/gdesklets/Sensors
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/lib/gdesklets
@${CAT} ${PKGMESSAGE}
diff --git a/deskutils/gdesklets/files/patch-data::Makefile.in b/deskutils/gdesklets/files/patch-data::Makefile.in
deleted file mode 100644
index 467ca7297f20..000000000000
--- a/deskutils/gdesklets/files/patch-data::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- data/Makefile.in.orig Tue Nov 14 13:33:28 2006
-+++ data/Makefile.in Tue Nov 14 13:36:09 2006
-@@ -252,7 +252,7 @@
- sharedmimepackagedir = $(sharedmimedir)/packages
- sharedmimepackage_in_files = gdesklets.xml.in
- sharedmimepackage_DATA = $(sharedmimepackage_in_files:.xml.in=.xml)
--mimeicondir = $(datadir)/icons/gnome/48x48/mimetypes
-+mimeicondir = $(prefix)/share/icons/gnome/48x48/mimetypes
- mimeicon_DATA = gnome-mime-application-x-gdesklets-display.png
- pixmapdir = $(PIXMAPDIR)
- pixmap_DATA = gdesklets.png
diff --git a/deskutils/gdesklets/files/patch-main::__init__.py b/deskutils/gdesklets/files/patch-main::__init__.py
deleted file mode 100644
index f9f873aa9852..000000000000
--- a/deskutils/gdesklets/files/patch-main::__init__.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- main/__init__.py.orig Thu Oct 5 16:14:40 2006
-+++ main/__init__.py Tue Nov 14 13:38:57 2006
-@@ -7,7 +7,7 @@
- # gDesklets home paths
- HOME = os.path.abspath(os.path.join(os.path.dirname(__file__), os.pardir))
- USERHOME = os.path.join(os.path.expanduser("~"), ".gdesklets")
--OLDHOME = os.path.join(HOME, os.pardir, os.pardir, "share", "gdesklets")
-+OLDHOME = os.path.join(HOME, os.pardir, os.pardir, "share", "gnome", "gdesklets")
-
- # we need the DISPLAY variable
- try:
diff --git a/deskutils/gdesklets/pkg-install b/deskutils/gdesklets/pkg-install
index 366e159fd31e..8a8d0cb4a84f 100644
--- a/deskutils/gdesklets/pkg-install
+++ b/deskutils/gdesklets/pkg-install
@@ -1,5 +1,5 @@
#!/bin/sh
if [ "$2" = "POST-INSTALL" ]; then
- mkdir -p ${PKG_PREFIX}/share/gnome/gdesklets/Displays
+ mkdir -p ${PKG_PREFIX}/share/gdesklets/Displays
fi
diff --git a/deskutils/gdesklets/pkg-plist b/deskutils/gdesklets/pkg-plist
index 7abc70cff434..d77246dc62c9 100644
--- a/deskutils/gdesklets/pkg-plist
+++ b/deskutils/gdesklets/pkg-plist
@@ -553,10 +553,10 @@ lib/gdesklets/utils/x11.so
lib/gdesklets/utils/xdr.py
lib/gdesklets/utils/xdr.pyc
lib/gdesklets/utils/xdr.pyo
-share/gnome/applications/gdesklets.desktop
-share/gnome/pixmaps/gdesklets.png
-@exec mkdir -p %D/share/gnome/gdesklets/Displays
-@exec mkdir -p %D/share/gnome/gdesklets/Sensors
+share/applications/gdesklets.desktop
+share/pixmaps/gdesklets.png
+@exec mkdir -p %D/share/gdesklets/Displays
+@exec mkdir -p %D/share/gdesklets/Sensors
share/icons/gnome/48x48/mimetypes/gnome-mime-application-x-gdesklets-display.png
share/locale/ar/LC_MESSAGES/gdesklets.mo
share/locale/az/LC_MESSAGES/gdesklets.mo
@@ -603,9 +603,9 @@ share/locale/gl/LC_MESSAGES/gdesklets.mo
share/locale/zh_HK/LC_MESSAGES/gdesklets.mo
share/mime/application/x-gdesklets-display.xml
share/mime/packages/gdesklets.xml
-@dirrm share/gnome/gdesklets/Sensors
-@dirrm share/gnome/gdesklets/Displays
-@dirrm share/gnome/gdesklets
+@dirrm share/gdesklets/Sensors
+@dirrm share/gdesklets/Displays
+@dirrm share/gdesklets
@dirrm lib/gdesklets/utils
@dirrm lib/gdesklets/shell/plugins/gDeskletsClient
@dirrm lib/gdesklets/shell/plugins/ViewSwitch
@@ -654,8 +654,9 @@ share/mime/packages/gdesklets.xml
@dirrm lib/gdesklets
@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
-@dirrmtry share/locale/rw/LC_MESSAGES
-@dirrmtry share/locale/rw
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
@dirrmtry share/icons/gnome/48x48/mimetypes
+@dirrmtry share/applications