aboutsummaryrefslogtreecommitdiff
path: root/deskutils/genius
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-10-26 18:25:36 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-10-26 18:25:36 +0000
commit5254c0cbdfa9567644253037dd57d2987a184bda (patch)
tree8e5959fb8546a26fd9f71a45500ff0b4a0e93bf7 /deskutils/genius
parent3d29c218f2cae0240f529d5aedc474059121f090 (diff)
downloadports-5254c0cbdfa9567644253037dd57d2987a184bda.tar.gz
ports-5254c0cbdfa9567644253037dd57d2987a184bda.zip
Notes
Diffstat (limited to 'deskutils/genius')
-rw-r--r--deskutils/genius/Makefile10
-rw-r--r--deskutils/genius/distinfo2
-rw-r--r--deskutils/genius/files/patch-configure10
-rw-r--r--deskutils/genius/files/patch-ltmain.sh15
-rw-r--r--deskutils/genius/files/patch-src::Makefile.in11
-rw-r--r--deskutils/genius/files/patch-src::calc.c20
-rw-r--r--deskutils/genius/pkg-plist13
7 files changed, 36 insertions, 45 deletions
diff --git a/deskutils/genius/Makefile b/deskutils/genius/Makefile
index fc862b0997bf..0c3a9d4c1f5a 100644
--- a/deskutils/genius/Makefile
+++ b/deskutils/genius/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= genius
-PORTVERSION= 0.5.5
-PORTREVISION= 1
+PORTVERSION= 0.5.6
CATEGORIES= deskutils gnome
MASTER_SITES= http://ftp.5z.com/pub/genius/
@@ -18,13 +17,10 @@ LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
USE_PERL5_BUILD= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack libgnomeui vte
-GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GNOME= gnomehack gnomeprefix gnometarget gtksourceview libgnomeui vte
+USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-INSTALLS_SHLIB= yes
-LDCONFIG_DIRS+= %%PREFIX%%/lib/genius
.include <bsd.port.pre.mk>
diff --git a/deskutils/genius/distinfo b/deskutils/genius/distinfo
index 2e5931ea0180..4d7ea9886600 100644
--- a/deskutils/genius/distinfo
+++ b/deskutils/genius/distinfo
@@ -1 +1 @@
-MD5 (genius-0.5.5.tar.gz) = ac3227f0cf8041df0efc7c26894e6e33
+MD5 (genius-0.5.6.tar.gz) = c8132a1d1f38e263888eee71759c4be1
diff --git a/deskutils/genius/files/patch-configure b/deskutils/genius/files/patch-configure
new file mode 100644
index 000000000000..bb978f35de65
--- /dev/null
+++ b/deskutils/genius/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Fri Oct 17 02:09:41 2003
++++ configure Fri Oct 17 11:52:59 2003
+@@ -18425,6 +18425,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/deskutils/genius/files/patch-ltmain.sh b/deskutils/genius/files/patch-ltmain.sh
deleted file mode 100644
index d311d361a2c1..000000000000
--- a/deskutils/genius/files/patch-ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- ltmain.sh.orig Sat Apr 26 04:18:44 2003
-+++ ltmain.sh Wed Jun 4 01:37:42 2003
-@@ -4280,10 +4280,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/deskutils/genius/files/patch-src::Makefile.in b/deskutils/genius/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..8f8408040069
--- /dev/null
+++ b/deskutils/genius/files/patch-src::Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.bak Fri Oct 17 02:22:23 2003
++++ src/Makefile.in Fri Oct 17 12:11:07 2003
+@@ -213,7 +213,7 @@
+
+ DEFS = @DEFS@ -I. -I$(srcdir) -I..
+ LIBS = @LIBS@
+-libtestplugin_la_LDFLAGS =
++libtestplugin_la_LDFLAGS = -module -avoid-version
+ libtestplugin_la_LIBADD =
+ libtestplugin_la_OBJECTS = testplugin.lo
+ bin_PROGRAMS = gnome-genius$(EXEEXT) genius$(EXEEXT)
diff --git a/deskutils/genius/files/patch-src::calc.c b/deskutils/genius/files/patch-src::calc.c
deleted file mode 100644
index 4c62ece4375f..000000000000
--- a/deskutils/genius/files/patch-src::calc.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/calc.c.orig Tue Jun 3 01:11:20 2003
-+++ src/calc.c Wed Jun 4 13:38:50 2003
-@@ -30,6 +30,8 @@
- #include <signal.h>
- #ifdef HAVE_WORDEXP
- #include <wordexp.h>
-+#else
-+#include <glob.h>
- #endif
- #include <stdio.h>
- #include <string.h>
-@@ -2402,7 +2404,7 @@
- return NULL;
- }
- for (i = 0; i < gl.gl_pathc; i++) {
-- list = g_slist_prepend (list, g_strdup (gl.gl_pathc[i]));
-+ list = g_slist_prepend (list, g_strdup (gl.gl_pathv[i]));
- }
- globfree (&gl);
- #endif
diff --git a/deskutils/genius/pkg-plist b/deskutils/genius/pkg-plist
index c655895c73f7..303bf886b1e3 100644
--- a/deskutils/genius/pkg-plist
+++ b/deskutils/genius/pkg-plist
@@ -14,9 +14,7 @@ include/genius/mpzextra.h
include/genius/plug_api.h
include/genius/structs.h
include/genius/utype.h
-lib/genius/libtestplugin.a
lib/genius/libtestplugin.so
-lib/genius/libtestplugin.so.0
libexec/genius-readline-helper-fifo
share/gnome/applications/gnome-genius.desktop
share/gnome/genius/gel/calculus/differentiation.gel
@@ -43,21 +41,32 @@ share/gnome/genius/gel/number_theory/misc.gel
share/gnome/genius/gel/number_theory/modulus.gel
share/gnome/genius/gel/number_theory/primes.gel
share/gnome/genius/gel/number_theory/quadratic.gel
+share/gnome/genius/gel/sets/basic.gel
share/gnome/genius/gel/statistics/basic.gel
+share/gnome/genius/gtksourceview/genius.lang
share/gnome/genius/manual.txt
share/gnome/genius/plugins/test.plugin
+share/locale/az/LC_MESSAGES/genius.mo
+share/locale/ca/LC_MESSAGES/genius.mo
share/locale/cs/LC_MESSAGES/genius.mo
share/locale/de/LC_MESSAGES/genius.mo
share/locale/es/LC_MESSAGES/genius.mo
share/locale/fr/LC_MESSAGES/genius.mo
+share/locale/hi/LC_MESSAGES/genius.mo
share/locale/it/LC_MESSAGES/genius.mo
share/locale/ko/LC_MESSAGES/genius.mo
+share/locale/nl/LC_MESSAGES/genius.mo
share/locale/no/LC_MESSAGES/genius.mo
share/locale/pl/LC_MESSAGES/genius.mo
share/locale/pt/LC_MESSAGES/genius.mo
+share/locale/sr/LC_MESSAGES/genius.mo
+share/locale/sr@Latn/LC_MESSAGES/genius.mo
share/locale/sv/LC_MESSAGES/genius.mo
+share/locale/zh_CN/LC_MESSAGES/genius.mo
+@dirrm share/gnome/genius/gtksourceview
@dirrm share/gnome/genius/plugins
@dirrm share/gnome/genius/gel/statistics
+@dirrm share/gnome/genius/gel/sets
@dirrm share/gnome/genius/gel/number_theory
@dirrm share/gnome/genius/gel/misc
@dirrm share/gnome/genius/gel/linear_algebra