aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gnome-initial-setup/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-08-05 19:13:24 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-08-05 19:13:24 +0000
commitd129587b5d568b0ff5300386f1e1b706c349f38e (patch)
treee398c7b6ea5203fd3953999e6dd9d6c83c9ec931 /deskutils/gnome-initial-setup/Makefile
parentc13de12f75988e599e389d9c77ed92db8d927185 (diff)
Notes
Diffstat (limited to 'deskutils/gnome-initial-setup/Makefile')
-rw-r--r--deskutils/gnome-initial-setup/Makefile14
1 files changed, 4 insertions, 10 deletions
diff --git a/deskutils/gnome-initial-setup/Makefile b/deskutils/gnome-initial-setup/Makefile
index 1a143342b382..c79450e88078 100644
--- a/deskutils/gnome-initial-setup/Makefile
+++ b/deskutils/gnome-initial-setup/Makefile
@@ -1,10 +1,8 @@
# Created by: Gustau Perez <gustau.perez@gmail.com>
# $FreeBSD$
-# $MCom: ports/trunk/deskutils/gnome-initial-setup/Makefile 20032 2014-11-02 21:57:34Z kwm $
PORTNAME= gnome-initial-setup
-PORTVERSION= 3.12.1
-PORTREVISION= 1
+PORTVERSION= 3.16.3
CATEGORIES= deskutils gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -20,7 +18,8 @@ LIB_DEPENDS= libgoa-1.0.so:${PORTSDIR}/net/gnome-online-accounts \
libgweather-3.so:${PORTSDIR}/net/libgweather
RUN_DEPENDS= gdm>=3.0.0:${PORTSDIR}/x11/gdm
-USES= autoreconf:build gettext gmake libtool pathfix pkgconfig tar:xz
+USES= autoreconf compiler:c++11-lib gettext gmake libtool \
+ pathfix pkgconfig tar:xz
USE_GNOME= gnomedesktop3 gnomeprefix gtk30 intlhack
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -34,8 +33,7 @@ OPTIONS_DEFAULT=KERBEROS
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 900007
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-gnome-initial-setup_pages_account_um-utils.c \
- ${FILESDIR}/extra-patch-gnome-initial-setup_pages_password_um-utils.c
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-gnome-initial-setup_pages_account_um-utils.c
.endif
.if !${PORT_OPTIONS:MKERBEROS}
@@ -44,10 +42,6 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-gnome-initial-setup_gis-account-page.c
post-patch:
@${REINPLACE_CMD} -e 's|krb5/krb5.h|krb5.h|g' \
- ${WRKSRC}/gnome-initial-setup/pages/password/um-realm-manager.c \
${WRKSRC}/gnome-initial-setup/pages/account/um-realm-manager.c
-pre-configure:
- cd ${WRKSRC} && NOCONFIGURE=yes ${SH} ./autogen.sh
-
.include <bsd.port.mk>