aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gnome-maps
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /deskutils/gnome-maps
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
Notes
Diffstat (limited to 'deskutils/gnome-maps')
-rw-r--r--deskutils/gnome-maps/Makefile30
-rw-r--r--deskutils/gnome-maps/distinfo2
-rw-r--r--deskutils/gnome-maps/pkg-descr3
-rw-r--r--deskutils/gnome-maps/pkg-plist87
4 files changed, 122 insertions, 0 deletions
diff --git a/deskutils/gnome-maps/Makefile b/deskutils/gnome-maps/Makefile
new file mode 100644
index 000000000000..fc48e3f8324e
--- /dev/null
+++ b/deskutils/gnome-maps/Makefile
@@ -0,0 +1,30 @@
+# Created by: Gustau Perez <gustau.perez@gmail.com>
+# $FreeBSD$
+# $MCom: ports/trunk/deskutils/gnome-maps/Makefile 19980 2014-10-17 06:01:57Z gusi $
+
+PORTNAME= gnome-maps
+PORTVERSION= 3.14.1.2
+CATEGORIES= deskutils gnome
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome3
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Map application for GNOME 3
+
+BUILD_DEPENDS= geoclue>=0:${PORTSDIR}/net/geoclue \
+ itstool:${PORTSDIR}/textproc/itstool
+LIB_DEPENDS= libcanberra-gtk3.so:${PORTSDIR}/audio/libcanberra-gtk3 \
+ libgeocode-glib.so:${PORTSDIR}/net/geocode-glib \
+ libgjs.so:${PORTSDIR}/lang/gjs
+RUN_DEPENDS= geoclue>=0:${PORTSDIR}/net/geoclue
+
+USES= gettext gmake libtool pathfix pkgconfig tar:xz
+USE_GNOME= gnomedesktop3 gnomeprefix gtk30 intlhack
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
+GLIB_SCHEMAS= org.gnome.maps.gschema.xml
+
+.include <bsd.port.mk>
diff --git a/deskutils/gnome-maps/distinfo b/deskutils/gnome-maps/distinfo
new file mode 100644
index 000000000000..8e1c77b7bf6d
--- /dev/null
+++ b/deskutils/gnome-maps/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gnome3/gnome-maps-3.14.1.2.tar.xz) = 7b3acd6580ef5aad0f4ca7bbaeff8ab9fdccd9300e0af78bbc66d2dcbc88a773
+SIZE (gnome3/gnome-maps-3.14.1.2.tar.xz) = 786364
diff --git a/deskutils/gnome-maps/pkg-descr b/deskutils/gnome-maps/pkg-descr
new file mode 100644
index 000000000000..0906f6776948
--- /dev/null
+++ b/deskutils/gnome-maps/pkg-descr
@@ -0,0 +1,3 @@
+Maps is a map application for GNOME 3
+
+WWW: https://wiki.gnome.org/action/show/Apps/Maps
diff --git a/deskutils/gnome-maps/pkg-plist b/deskutils/gnome-maps/pkg-plist
new file mode 100644
index 000000000000..5bced1a1dabf
--- /dev/null
+++ b/deskutils/gnome-maps/pkg-plist
@@ -0,0 +1,87 @@
+bin/gnome-maps
+share/appdata/org.gnome.Maps.appdata.xml
+share/applications/org.gnome.Maps.desktop
+share/dbus-1/services/org.gnome.Maps.service
+%%DATADIR%%/icons/hicolor/16x16/apps/layers-button-symbolic.svg
+%%DATADIR%%/icons/hicolor/16x16/apps/maps-point-end-symbolic.svg
+%%DATADIR%%/icons/hicolor/16x16/apps/maps-point-end.svg
+%%DATADIR%%/icons/hicolor/16x16/apps/maps-point-start-symbolic.svg
+%%DATADIR%%/icons/hicolor/16x16/apps/maps-point-start.svg
+%%DATADIR%%/icons/hicolor/16x16/apps/route-bike-symbolic.svg
+%%DATADIR%%/icons/hicolor/16x16/apps/route-button-symbolic.svg
+%%DATADIR%%/icons/hicolor/16x16/apps/route-car-symbolic.svg
+%%DATADIR%%/icons/hicolor/16x16/apps/route-pedestrian-symbolic.svg
+%%DATADIR%%/icons/hicolor/16x16/apps/route-transit-symbolic.svg
+%%DATADIR%%/icons/hicolor/22x22/apps/user-location.png
+%%DATADIR%%/icons/hicolor/32x32/apps/maps-direction-continue-symbolic.svg
+%%DATADIR%%/icons/hicolor/32x32/apps/maps-direction-left-symbolic.svg
+%%DATADIR%%/icons/hicolor/32x32/apps/maps-direction-right-symbolic.svg
+%%DATADIR%%/icons/hicolor/32x32/apps/maps-direction-sharpleft-symbolic.svg
+%%DATADIR%%/icons/hicolor/32x32/apps/maps-direction-sharpright-symbolic.svg
+%%DATADIR%%/icons/hicolor/32x32/apps/maps-direction-slightleft-symbolic.svg
+%%DATADIR%%/icons/hicolor/32x32/apps/maps-direction-slightright-symbolic.svg
+%%DATADIR%%/icons/hicolor/32x32/apps/maps-pin.svg
+share/icons/HighContrast/16x16/apps/gnome-maps.png
+share/icons/HighContrast/22x22/apps/gnome-maps.png
+share/icons/HighContrast/24x24/apps/gnome-maps.png
+share/icons/HighContrast/256x256/apps/gnome-maps.png
+share/icons/HighContrast/32x32/apps/gnome-maps.png
+share/icons/HighContrast/48x48/apps/gnome-maps.png
+share/icons/hicolor/16x16/apps/gnome-maps.png
+share/icons/hicolor/22x22/apps/gnome-maps.png
+share/icons/hicolor/24x24/apps/gnome-maps.png
+share/icons/hicolor/256x256/apps/gnome-maps.png
+share/icons/hicolor/32x32/apps/gnome-maps.png
+share/icons/hicolor/48x48/apps/gnome-maps.png
+share/locale/af/LC_MESSAGES/gnome-maps.mo
+share/locale/an/LC_MESSAGES/gnome-maps.mo
+share/locale/ar/LC_MESSAGES/gnome-maps.mo
+share/locale/as/LC_MESSAGES/gnome-maps.mo
+share/locale/ca/LC_MESSAGES/gnome-maps.mo
+share/locale/ca@valencia/LC_MESSAGES/gnome-maps.mo
+share/locale/cs/LC_MESSAGES/gnome-maps.mo
+share/locale/da/LC_MESSAGES/gnome-maps.mo
+share/locale/de/LC_MESSAGES/gnome-maps.mo
+share/locale/el/LC_MESSAGES/gnome-maps.mo
+share/locale/en_GB/LC_MESSAGES/gnome-maps.mo
+share/locale/eo/LC_MESSAGES/gnome-maps.mo
+share/locale/es/LC_MESSAGES/gnome-maps.mo
+share/locale/et/LC_MESSAGES/gnome-maps.mo
+share/locale/eu/LC_MESSAGES/gnome-maps.mo
+share/locale/fa/LC_MESSAGES/gnome-maps.mo
+share/locale/fi/LC_MESSAGES/gnome-maps.mo
+share/locale/fr/LC_MESSAGES/gnome-maps.mo
+share/locale/fur/LC_MESSAGES/gnome-maps.mo
+share/locale/ga/LC_MESSAGES/gnome-maps.mo
+share/locale/gl/LC_MESSAGES/gnome-maps.mo
+share/locale/he/LC_MESSAGES/gnome-maps.mo
+share/locale/hu/LC_MESSAGES/gnome-maps.mo
+share/locale/id/LC_MESSAGES/gnome-maps.mo
+share/locale/it/LC_MESSAGES/gnome-maps.mo
+share/locale/ja/LC_MESSAGES/gnome-maps.mo
+share/locale/kn/LC_MESSAGES/gnome-maps.mo
+share/locale/ko/LC_MESSAGES/gnome-maps.mo
+share/locale/lt/LC_MESSAGES/gnome-maps.mo
+share/locale/lv/LC_MESSAGES/gnome-maps.mo
+share/locale/ml/LC_MESSAGES/gnome-maps.mo
+share/locale/nb/LC_MESSAGES/gnome-maps.mo
+share/locale/ne/LC_MESSAGES/gnome-maps.mo
+share/locale/nl/LC_MESSAGES/gnome-maps.mo
+share/locale/pa/LC_MESSAGES/gnome-maps.mo
+share/locale/pl/LC_MESSAGES/gnome-maps.mo
+share/locale/pt/LC_MESSAGES/gnome-maps.mo
+share/locale/pt_BR/LC_MESSAGES/gnome-maps.mo
+share/locale/ro/LC_MESSAGES/gnome-maps.mo
+share/locale/ru/LC_MESSAGES/gnome-maps.mo
+share/locale/sk/LC_MESSAGES/gnome-maps.mo
+share/locale/sl/LC_MESSAGES/gnome-maps.mo
+share/locale/sr/LC_MESSAGES/gnome-maps.mo
+share/locale/sr@latin/LC_MESSAGES/gnome-maps.mo
+share/locale/sv/LC_MESSAGES/gnome-maps.mo
+share/locale/te/LC_MESSAGES/gnome-maps.mo
+share/locale/tg/LC_MESSAGES/gnome-maps.mo
+share/locale/tr/LC_MESSAGES/gnome-maps.mo
+share/locale/uk/LC_MESSAGES/gnome-maps.mo
+share/locale/zh_CN/LC_MESSAGES/gnome-maps.mo
+share/locale/zh_HK/LC_MESSAGES/gnome-maps.mo
+share/locale/zh_TW/LC_MESSAGES/gnome-maps.mo