aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gnome-shell-extension-calculator
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /deskutils/gnome-shell-extension-calculator
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
Notes
Diffstat (limited to 'deskutils/gnome-shell-extension-calculator')
-rw-r--r--deskutils/gnome-shell-extension-calculator/Makefile36
-rw-r--r--deskutils/gnome-shell-extension-calculator/distinfo2
-rw-r--r--deskutils/gnome-shell-extension-calculator/pkg-descr3
-rw-r--r--deskutils/gnome-shell-extension-calculator/pkg-plist3
4 files changed, 44 insertions, 0 deletions
diff --git a/deskutils/gnome-shell-extension-calculator/Makefile b/deskutils/gnome-shell-extension-calculator/Makefile
new file mode 100644
index 000000000000..c091dcb0027e
--- /dev/null
+++ b/deskutils/gnome-shell-extension-calculator/Makefile
@@ -0,0 +1,36 @@
+# Created by: Gustau Perez i Querol <gustau.perez@gmail.com>
+# $FreeBSD$
+# $MCom: ports/trunk/deskutils/gnome-shell-extension-calculator/Makefile 19680 2014-05-23 14:40:39Z gusi $
+
+PORTNAME= gnome-shell-extension-calculator
+PORTVERSION= 0.0.0.20140520
+CATEGORIES= deskutils gnome
+DIST_SUBDIR= gnome3
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Simple calculator in the gnome-shell search overview
+
+BUILD_DEPENDS= gnome-shell>=0:${PORTSDIR}/x11/gnome-shell
+RUN_DEPENDS= gnome-shell>=0:${PORTSDIR}/x11/gnome-shell
+
+WRKSRC= ${WRKDIR}/eonpatapon-gnome-shell-extension-calc-e4f4ac5
+
+USES= gettext gmake pkgconfig tar:xz
+USE_GITHUB= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+GH_ACCOUNT= eonpatapon
+GH_TAGNAME= e4f4ac5007
+GH_COMMIT= e4f4ac5007
+GH_PROJECT= gnome-shell-extension-calc
+
+PKGMESSAGE= ../gnome-shell-extra-extensions/pkg-message.slaves
+
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/gnome-shell/extensions/
+ @(cd ${WRKSRC} && ${CP} -pPR calc\@patapon.info ${STAGEDIR}${PREFIX}/share/gnome-shell/extensions/)
+
+.include <bsd.port.mk>
diff --git a/deskutils/gnome-shell-extension-calculator/distinfo b/deskutils/gnome-shell-extension-calculator/distinfo
new file mode 100644
index 000000000000..a2e2a7bc5ec5
--- /dev/null
+++ b/deskutils/gnome-shell-extension-calculator/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gnome3/gnome-shell-extension-calculator-0.0.0.20140520.tar.xz) = 39c0cf9267befcdf92edc5c4113bc1af57375ccace0c1a03b6dfcfcc049928c9
+SIZE (gnome3/gnome-shell-extension-calculator-0.0.0.20140520.tar.xz) = 206289
diff --git a/deskutils/gnome-shell-extension-calculator/pkg-descr b/deskutils/gnome-shell-extension-calculator/pkg-descr
new file mode 100644
index 000000000000..6b0b3ecc1835
--- /dev/null
+++ b/deskutils/gnome-shell-extension-calculator/pkg-descr
@@ -0,0 +1,3 @@
+Simple calculator for the gnome-shell search overview
+
+WWW: https://github.com/eonpatapon/gnome-shell-extension-calc
diff --git a/deskutils/gnome-shell-extension-calculator/pkg-plist b/deskutils/gnome-shell-extension-calculator/pkg-plist
new file mode 100644
index 000000000000..6aff85edf3b0
--- /dev/null
+++ b/deskutils/gnome-shell-extension-calculator/pkg-plist
@@ -0,0 +1,3 @@
+share/gnome-shell/extensions/calc@patapon.info/COPYING
+share/gnome-shell/extensions/calc@patapon.info/extension.js
+share/gnome-shell/extensions/calc@patapon.info/metadata.json