aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gnome-shell-extension-trash
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /deskutils/gnome-shell-extension-trash
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
downloadports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.tar.gz
ports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.zip
Notes
Diffstat (limited to 'deskutils/gnome-shell-extension-trash')
-rw-r--r--deskutils/gnome-shell-extension-trash/Makefile44
-rw-r--r--deskutils/gnome-shell-extension-trash/distinfo2
-rw-r--r--deskutils/gnome-shell-extension-trash/pkg-descr7
-rw-r--r--deskutils/gnome-shell-extension-trash/pkg-plist9
4 files changed, 62 insertions, 0 deletions
diff --git a/deskutils/gnome-shell-extension-trash/Makefile b/deskutils/gnome-shell-extension-trash/Makefile
new file mode 100644
index 000000000000..98879d60d013
--- /dev/null
+++ b/deskutils/gnome-shell-extension-trash/Makefile
@@ -0,0 +1,44 @@
+# Created by: Gustau Perez i Querol <gustau.perez@gmail.com>
+# $FreeBSD$
+# $MCom: ports/trunk/deskutils/gnome-shell-extension-trash/Makefile 19881 2014-09-16 11:15:10Z gusi $
+
+PORTNAME= gnome-shell-extension-trash
+PORTVERSION= 0.0.0.20140916
+CATEGORIES= deskutils gnome
+DIST_SUBDIR= gnome3
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Gnome-shell trash indicator
+
+BUILD_DEPENDS= gnome-shell>=0:${PORTSDIR}/x11/gnome-shell \
+ gsettings-desktop-schemas>=3.12.0:${PORTSDIR}/devel/gsettings-desktop-schemas
+RUN_DEPENDS= gnome-shell>=0:${PORTSDIR}/x11/gnome-shell \
+ gsettings-desktop-schemas>=3.12.0:${PORTSDIR}/devel/gsettings-desktop-schemas
+
+WRKSRC= ${WRKDIR}/bertoldia-gnome-shell-trash-extension-f7f335b
+
+USES= gettext gmake pkgconfig tar:xz
+USE_GNOME= glib20
+USE_GITHUB= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+GH_ACCOUNT= bertoldia
+GH_TAGNAME= f7f335b
+GH_COMMIT= f7f335b
+GH_PROJECT= gnome-shell-trash-extension
+
+PKGMESSAGE= ../gnome-shell-extra-extensions/pkg-message.slaves
+
+NO_BUILD= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|3.10|3.10","3.12|g' \
+ ${WRKSRC}/metadata.json
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/gnome-shell/extensions/gnome-shell-trash-extension
+ @(cd ${WRKSRC} && ${CP} -pPR * \
+ ${STAGEDIR}${PREFIX}/share/gnome-shell/extensions/gnome-shell-trash-extension)
+
+.include <bsd.port.mk>
diff --git a/deskutils/gnome-shell-extension-trash/distinfo b/deskutils/gnome-shell-extension-trash/distinfo
new file mode 100644
index 000000000000..611c01f0efac
--- /dev/null
+++ b/deskutils/gnome-shell-extension-trash/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gnome3/gnome-shell-extension-trash-0.0.0.20140916.tar.xz) = 04d6bc104b381529ebe821eea532d2a148f7a107a8d6106fdfc5b14f4dde46e2
+SIZE (gnome3/gnome-shell-extension-trash-0.0.0.20140916.tar.xz) = 4583
diff --git a/deskutils/gnome-shell-extension-trash/pkg-descr b/deskutils/gnome-shell-extension-trash/pkg-descr
new file mode 100644
index 000000000000..9776cc14ec98
--- /dev/null
+++ b/deskutils/gnome-shell-extension-trash/pkg-descr
@@ -0,0 +1,7 @@
+A minimalist Trash management extension for the Gnome Shell.
+
+It allows you to empty and open the Trash folder. It hides
+completely when the Trash is empty, and lists the files
+in the trash bin in the panel menu.
+
+WWW: https://github.com/bertoldia/gnome-shell-trash-extension
diff --git a/deskutils/gnome-shell-extension-trash/pkg-plist b/deskutils/gnome-shell-extension-trash/pkg-plist
new file mode 100644
index 000000000000..0a89e81c773a
--- /dev/null
+++ b/deskutils/gnome-shell-extension-trash/pkg-plist
@@ -0,0 +1,9 @@
+share/gnome-shell/extensions/gnome-shell-trash-extension/README
+share/gnome-shell/extensions/gnome-shell-trash-extension/extension.js
+share/gnome-shell/extensions/gnome-shell-trash-extension/locale/de/LC_MESSAGES/gnome-shell-trash-extension.mo
+share/gnome-shell/extensions/gnome-shell-trash-extension/locale/fr/LC_MESSAGES/gnome-shell-trash-extension.mo
+share/gnome-shell/extensions/gnome-shell-trash-extension/metadata.json
+share/gnome-shell/extensions/gnome-shell-trash-extension/po/de.po
+share/gnome-shell/extensions/gnome-shell-trash-extension/po/fr.po
+share/gnome-shell/extensions/gnome-shell-trash-extension/po/messages.pot
+share/gnome-shell/extensions/gnome-shell-trash-extension/po/pt_BR.po