aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gnomepim/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2001-05-04 21:39:58 +0000
committerAde Lovett <ade@FreeBSD.org>2001-05-04 21:39:58 +0000
commit03af2187bd388708aa7234d923ec38192b6fc7a2 (patch)
tree7ce23e0d0c750d353ac0da5306ba035076e0adf0 /deskutils/gnomepim/Makefile
parentdd85694bb4fdd0d68574a5b609e8e026c8a16a4e (diff)
downloadports-03af2187bd388708aa7234d923ec38192b6fc7a2.tar.gz
ports-03af2187bd388708aa7234d923ec38192b6fc7a2.zip
Notes
Diffstat (limited to 'deskutils/gnomepim/Makefile')
-rw-r--r--deskutils/gnomepim/Makefile23
1 files changed, 4 insertions, 19 deletions
diff --git a/deskutils/gnomepim/Makefile b/deskutils/gnomepim/Makefile
index b688bc0ac521..bdcd06e47671 100644
--- a/deskutils/gnomepim/Makefile
+++ b/deskutils/gnomepim/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnomepim
-PORTVERSION= 1.2.0
+PORTVERSION= 1.4.0
CATEGORIES= deskutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/gnome-pim
@@ -14,28 +14,13 @@ DISTNAME= gnome-pim-${PORTVERSION}
MAINTAINER= ade@FreeBSD.org
-.if defined(WITH_GNOMEPILOT)
-LIB_DEPENDS+= gpilotd.0:${PORTSDIR}/palm/gnomepilot
-PILOTINC= "-I${LOCALBASE}/pilot/include"
-PILOTLIB= "-L${LOCALBASE}/pilot/lib"
-PLIST_SUB+= GNOMEPILOT:=""
-.else
-CONFIGURE_ARGS= --without-pisock --disable-pilotlinktest
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-nopilot
-PLIST_SUB+= GNOMEPILOT:="@comment "
-.endif
-
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= yes
USE_LIBTOOL= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PILOTINC}" \
- LIBS="-L${LOCALBASE}/lib ${PILOTLIB}"
-
-.if !defined(WITH_GNOMEPILOT)
-pre-extract:
- @${ECHO} "You can add gnomepilot support by defining WITH_GNOMEPILOT"
-.endif
+CONFIGURE_ARGS= --without-pisock --disable-pilotlinktest
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \