aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gnomepim
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2001-05-04 21:39:58 +0000
committerAde Lovett <ade@FreeBSD.org>2001-05-04 21:39:58 +0000
commit03af2187bd388708aa7234d923ec38192b6fc7a2 (patch)
tree7ce23e0d0c750d353ac0da5306ba035076e0adf0 /deskutils/gnomepim
parentdd85694bb4fdd0d68574a5b609e8e026c8a16a4e (diff)
downloadports-03af2187bd388708aa7234d923ec38192b6fc7a2.tar.gz
ports-03af2187bd388708aa7234d923ec38192b6fc7a2.zip
Notes
Diffstat (limited to 'deskutils/gnomepim')
-rw-r--r--deskutils/gnomepim/Makefile23
-rw-r--r--deskutils/gnomepim/distinfo2
-rw-r--r--deskutils/gnomepim/files/extra-patch-nopilot26
-rw-r--r--deskutils/gnomepim/files/patch-ab8
-rw-r--r--deskutils/gnomepim/files/patch-ae28
-rw-r--r--deskutils/gnomepim/pkg-plist24
6 files changed, 41 insertions, 70 deletions
diff --git a/deskutils/gnomepim/Makefile b/deskutils/gnomepim/Makefile
index b688bc0ac521..bdcd06e47671 100644
--- a/deskutils/gnomepim/Makefile
+++ b/deskutils/gnomepim/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnomepim
-PORTVERSION= 1.2.0
+PORTVERSION= 1.4.0
CATEGORIES= deskutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/gnome-pim
@@ -14,28 +14,13 @@ DISTNAME= gnome-pim-${PORTVERSION}
MAINTAINER= ade@FreeBSD.org
-.if defined(WITH_GNOMEPILOT)
-LIB_DEPENDS+= gpilotd.0:${PORTSDIR}/palm/gnomepilot
-PILOTINC= "-I${LOCALBASE}/pilot/include"
-PILOTLIB= "-L${LOCALBASE}/pilot/lib"
-PLIST_SUB+= GNOMEPILOT:=""
-.else
-CONFIGURE_ARGS= --without-pisock --disable-pilotlinktest
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-nopilot
-PLIST_SUB+= GNOMEPILOT:="@comment "
-.endif
-
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= yes
USE_LIBTOOL= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PILOTINC}" \
- LIBS="-L${LOCALBASE}/lib ${PILOTLIB}"
-
-.if !defined(WITH_GNOMEPILOT)
-pre-extract:
- @${ECHO} "You can add gnomepilot support by defining WITH_GNOMEPILOT"
-.endif
+CONFIGURE_ARGS= --without-pisock --disable-pilotlinktest
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
diff --git a/deskutils/gnomepim/distinfo b/deskutils/gnomepim/distinfo
index 277f4e65d5f2..6daa3d5c1631 100644
--- a/deskutils/gnomepim/distinfo
+++ b/deskutils/gnomepim/distinfo
@@ -1 +1 @@
-MD5 (gnome-pim-1.2.0.tar.gz) = d0af4da54851fa996b59d4f738ff2920
+MD5 (gnome-pim-1.4.0.tar.gz) = 177daf8b1e15be906fb41dca94a00e76
diff --git a/deskutils/gnomepim/files/extra-patch-nopilot b/deskutils/gnomepim/files/extra-patch-nopilot
index 546fad85c5a5..e69de29bb2d1 100644
--- a/deskutils/gnomepim/files/extra-patch-nopilot
+++ b/deskutils/gnomepim/files/extra-patch-nopilot
@@ -1,26 +0,0 @@
---- configure.orig Fri Jun 2 12:19:04 2000
-+++ configure Fri Jun 2 12:19:38 2000
-@@ -3629,23 +3629,7 @@
-
- echo $ac_n "checking for gnome-pilot environment""... $ac_c" 1>&6
- echo "configure:3632: checking for gnome-pilot environment" >&5
--if eval "test \"`echo '$''{'gnome_cv_pilot_found'+set}'`\" = set"; then
-- echo $ac_n "(cached) $ac_c" 1>&6
--else
--
-- if test "x$GNOME_CONFIG" = "xno"; then
- gnome_cv_pilot_found=no
-- else
-- # gnome-config doesn't return a useful error status,
-- # so we check if it outputs anything to stderr
-- if test "x`$GNOME_CONFIG gpilot 2>&1 > /dev/null`" = "x"; then
-- gnome_cv_pilot_found=yes
-- else
-- gnome_cv_pilot_found=no
-- fi
-- fi
--
--fi
-
- echo "$ac_t""$gnome_cv_pilot_found" 1>&6
-
diff --git a/deskutils/gnomepim/files/patch-ab b/deskutils/gnomepim/files/patch-ab
index a64463dc909a..9471fee3c802 100644
--- a/deskutils/gnomepim/files/patch-ab
+++ b/deskutils/gnomepim/files/patch-ab
@@ -1,11 +1,11 @@
---- gncal/Makefile.in.orig Sat May 20 20:52:50 2000
-+++ gncal/Makefile.in Wed Aug 2 10:27:30 2000
-@@ -143,3 +143,3 @@
+--- gncal/Makefile.in.orig Tue Feb 27 16:56:32 2001
++++ gncal/Makefile.in Tue Feb 27 16:56:49 2001
+@@ -139,3 +139,3 @@
-help_base = $(datadir)/help/cal
+help_base = $(datadir)/help/gnomecal
-@@ -174,3 +174,3 @@
+@@ -170,3 +170,3 @@
-libcalendar_conduit_la_LDFLAGS = -rpath $(libdir)
+libcalendar_conduit_la_LDFLAGS = -rpath $(libdir) -avoid-version
diff --git a/deskutils/gnomepim/files/patch-ae b/deskutils/gnomepim/files/patch-ae
new file mode 100644
index 000000000000..d717eba3f5d7
--- /dev/null
+++ b/deskutils/gnomepim/files/patch-ae
@@ -0,0 +1,28 @@
+--- configure.orig Mon Feb 26 00:15:55 2001
++++ configure Tue Feb 27 16:58:50 2001
+@@ -3632,23 +3632,5 @@
+
+- echo $ac_n "checking for gnome-pilot environment""... $ac_c" 1>&6
+-echo "configure:3635: checking for gnome-pilot environment" >&5
+-if eval "test \"`echo '$''{'gnome_cv_pilot_found'+set}'`\" = set"; then
+- echo $ac_n "(cached) $ac_c" 1>&6
+-else
+-
+- if test "x$GNOME_CONFIG" = "xno"; then
++ echo "ignoring gnome-pilot environment""... $ac_c" 1>&6
++echo "configure:3635: ignoring gnome-pilot environment" >&5
+ gnome_cv_pilot_found=no
+- else
+- # gnome-config doesn't return a useful error status,
+- # so we check if it outputs anything to stderr
+- if test "x`$GNOME_CONFIG gpilot 2>&1 > /dev/null`" = "x"; then
+- gnome_cv_pilot_found=yes
+- else
+- gnome_cv_pilot_found=no
+- fi
+- fi
+-
+-fi
+-
+-echo "$ac_t""$gnome_cv_pilot_found" 1>&6
+
diff --git a/deskutils/gnomepim/pkg-plist b/deskutils/gnomepim/pkg-plist
index ad35d9235e36..13b989f665b7 100644
--- a/deskutils/gnomepim/pkg-plist
+++ b/deskutils/gnomepim/pkg-plist
@@ -1,40 +1,21 @@
-%%GNOMEPILOT:%%bin/address-conduit-capplet
-%%GNOMEPILOT:%%bin/calendar-conduit-control-applet
-%%GNOMEPILOT:%%bin/calendar-pilot-sync
bin/gnomecal
bin/gnomecard
etc/CORBA/servers/gnomecal.gnorba
etc/CORBA/servers/gnomecard.gnorba
-%%GNOMEPILOT:%%lib/gnome-pilot/conduits/libaddress_conduit.so
-%%GNOMEPILOT:%%lib/gnome-pilot/conduits/libcalendar_conduit.so
share/gnome/apps/Applications/gncal.desktop
share/gnome/apps/Applications/gnomecard.desktop
-%%GNOMEPILOT:%%share/gnome/apps/Settings/Peripherals/Conduits/address-conduit-capplet.desktop
-%%GNOMEPILOT:%%share/gnome/apps/Settings/Peripherals/Conduits/calendar-conduit-control-applet.desktop
-%%GNOMEPILOT:%%share/gnome/control-center/Peripherals/Conduits/address-conduit-capplet.desktop
-%%GNOMEPILOT:%%share/gnome/control-center/Peripherals/Conduits/calendar-conduit-control-applet.desktop
-%%GNOMEPILOT:%%share/gnome/gnome-pilot/conduits/gnomecal.conduit
-%%GNOMEPILOT:%%share/gnome/gnome-pilot/conduits/gnomecard.conduit
-share/gnome/help/gnomecal/C/calappoint.html
-share/gnome/help/gnomecal/C/calsetup.html
-share/gnome/help/gnomecal/C/caluse.html
-share/gnome/help/gnomecal/C/cmdline.html
-share/gnome/help/gnomecal/C/docbook.css
-share/gnome/help/gnomecal/C/gcal.html
-share/gnome/help/gnomecal/C/gnomecal.html
share/gnome/help/gnomecal/C/images/cal-props.gif
share/gnome/help/gnomecal/C/images/calday.gif
share/gnome/help/gnomecal/C/images/calmonth.gif
share/gnome/help/gnomecal/C/images/calweek.gif
share/gnome/help/gnomecal/C/images/calyear.gif
-share/gnome/help/gnomecal/C/ln20.html
-share/gnome/help/gnomecal/C/tech.html.html
share/gnome/help/gnomecal/C/topic.dat
share/gnome/idl/GnomeCal.idl
share/gnome/idl/gnome-pim.idl
share/gnome/mime-info/gnome-pim.keys
share/gnome/pixmaps/gnome-calendar-conduit.png
share/gnome/pixmaps/gnome-gnomecard.png
+share/locale/az/LC_MESSAGES/gnome-pim.mo
share/locale/ca/LC_MESSAGES/gnome-pim.mo
share/locale/cs/LC_MESSAGES/gnome-pim.mo
share/locale/cy/LC_MESSAGES/gnome-pim.mo
@@ -62,7 +43,10 @@ share/locale/pl/LC_MESSAGES/gnome-pim.mo
share/locale/pt/LC_MESSAGES/gnome-pim.mo
share/locale/pt_BR/LC_MESSAGES/gnome-pim.mo
share/locale/ru/LC_MESSAGES/gnome-pim.mo
+share/locale/sk/LC_MESSAGES/gnome-pim.mo
+share/locale/sl/LC_MESSAGES/gnome-pim.mo
share/locale/sv/LC_MESSAGES/gnome-pim.mo
+share/locale/tr/LC_MESSAGES/gnome-pim.mo
share/locale/uk/LC_MESSAGES/gnome-pim.mo
share/locale/wa/LC_MESSAGES/gnome-pim.mo
share/locale/zh_CN.GB2312/LC_MESSAGES/gnome-pim.mo