aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gnotime/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 05:45:41 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 05:45:41 +0000
commite130c95d6b664d138f50f64cb07373b50ecccfae (patch)
treeda44957ef80a4f3f4bc85d8055ee9816aebca7e7 /deskutils/gnotime/Makefile
parentb0e6fb00cb878e4aec86223fb04eef64a7865954 (diff)
downloadports-e130c95d6b664d138f50f64cb07373b50ecccfae.tar.gz
ports-e130c95d6b664d138f50f64cb07373b50ecccfae.zip
Notes
Diffstat (limited to 'deskutils/gnotime/Makefile')
-rw-r--r--deskutils/gnotime/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/deskutils/gnotime/Makefile b/deskutils/gnotime/Makefile
index 4701b04c661d..04dfee8646f3 100644
--- a/deskutils/gnotime/Makefile
+++ b/deskutils/gnotime/Makefile
@@ -3,10 +3,12 @@
# Whom: Martin Klaffenboeck <martin.klaffenboeck@gmx.at>
#
# $FreeBSD$
+# $MCom: ports/deskutils/gnotime/Makefile,v 1.15 2005/07/01 17:57:13 marcus Exp $
#
PORTNAME= gnotime
-PORTVERSION= 2.2.2
+PORTVERSION= 2.2.1
+PORTREVISION= 1
CATEGORIES= deskutils gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gttr
@@ -16,17 +18,22 @@ COMMENT= GnoTime is a time tracker for gnome2
LIB_DEPENDS= guile.15:${PORTSDIR}/lang/guile
-USE_GNOME= gnomehack gnomeprefix intlhack gtkhtml3 libgnomeui
+USE_GNOME= gnomehack gnomeprefix gtkhtml3 libgnomeui
USE_X_PREFIX= yes
USE_GMAKE= yes
INSTALLS_OMF= yes
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib"
MAN1= gnotime.1
GCONF_SCHEMAS= gnotime.schemas
+# until a new version comes out...
+post-patch:
+ @${REINPLACE_CMD} -e "s|gtkhtml-3.1|gtkhtml-3.8|g" \
+ ${WRKSRC}/configure
+
.include <bsd.port.mk>