aboutsummaryrefslogtreecommitdiff
path: root/deskutils/growl-for-linux/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-09-04 14:55:44 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-09-04 14:55:44 +0000
commitcf9419befc3bcd557c4fd248d338a70259763e04 (patch)
tree0b2669941771b6fa3b870b6cae919181d49e4e3b /deskutils/growl-for-linux/Makefile
parent6a14a411860776d3d47e3a9824dd0235b8218ad2 (diff)
downloadports-cf9419befc3bcd557c4fd248d338a70259763e04.tar.gz
ports-cf9419befc3bcd557c4fd248d338a70259763e04.zip
Notes
Diffstat (limited to 'deskutils/growl-for-linux/Makefile')
-rw-r--r--deskutils/growl-for-linux/Makefile41
1 files changed, 19 insertions, 22 deletions
diff --git a/deskutils/growl-for-linux/Makefile b/deskutils/growl-for-linux/Makefile
index b180eebac665..e1c9555cbbfb 100644
--- a/deskutils/growl-for-linux/Makefile
+++ b/deskutils/growl-for-linux/Makefile
@@ -2,7 +2,7 @@
PORTNAME= growl-for-linux
PORTVERSION= 0.6.9
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= deskutils
MAINTAINER= nivit@FreeBSD.org
@@ -20,32 +20,29 @@ GH_COMMIT= ac7c8cd
GH_TAGNAME= ${GH_COMMIT}
GNU_CONFIGURE= yes
-
-OPTIONS_DEFINE= LIBNOTIFY
-OPTIONS_DEFAULT= LIBNOTIFY
-LIBNOTIFY_DESC= Use notify-osd for libnotify display plugin
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MLIBNOTIFY}
-LIB_DEPENDS+= libnotify.so:${PORTSDIR}/devel/libnotify
-RUN_DEPENDS+= notify-osd>=0.9.29_3:${PORTSDIR}/deskutils/notify-osd
-.endif
-
-PLIST_SUB= DESKTOPDIR=${DESKTOPDIR:S,^${PREFIX}/,,}
-
-USE_AUTOTOOLS= autoconf:env automake:env libtoolize:env
+CONFIGURE_ARGS= OPENSSL_CFLAGS="-I${OPENSSLINC}" OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto"
+USES= compiler:nestedfct libtool pkgconfig
+USE_AUTOTOOLS= libtoolize aclocal autoconf automake
+AUTOMAKE_ARGS= -a -c -f
USE_GITHUB= yes
-USE_GCC= any
USE_GNOME= gtk20
-USE_LDCONFIG= yes
USE_OPENSSL= yes
USE_SQLITE= 3
-USES= libtool pkgconfig
-WITH_OPENSSL_PORT= yes
+PLIST_SUB= DESKTOPDIR=${DESKTOPDIR:S,^${PREFIX}/,,}
+
+OPTIONS_DEFINE= LIBNOTIFY
+OPTIONS_DEFAULT=LIBNOTIFY
+
+LIBNOTIFY_DESC= Use notify-osd for libnotify display plugin
+LIBNOTIFY_LIB_DEPENDS= libnotify.so:${PORTSDIR}/devel/libnotify
+LIBNOTIFY_RUN_DEPENDS= notify-osd>=0.9.29_3:${PORTSDIR}/deskutils/notify-osd
+
+post-patch:
+ @${REINPLACE_CMD} '/^gol_LDADD =/s/$$/ -lgmodule-2.0/' \
+ ${WRKSRC}/Makefile.am
-pre-configure:
- @(cd ${CONFIGURE_WRKSRC} ; ${SETENV} ${CONFIGURE_ENV} ${SH} autogen.sh)
+post-install:
+ ${RM} ${STAGEDIR}${PREFIX}/lib/libgolplug.a
.include <bsd.port.mk>