aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gucharmap/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2017-05-31 13:04:19 +0000
committerKoop Mast <kwm@FreeBSD.org>2017-05-31 13:04:19 +0000
commit307b07e97338dd53bb6f09cfb3f416679cd16416 (patch)
tree48397b36a37d6f5bd9da5969b1d9651d7ccdcfd9 /deskutils/gucharmap/Makefile
parentc23c05ae64e204554e9cfdb37dc66712c4e461a1 (diff)
Notes
Diffstat (limited to 'deskutils/gucharmap/Makefile')
-rw-r--r--deskutils/gucharmap/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/deskutils/gucharmap/Makefile b/deskutils/gucharmap/Makefile
index 89b4c8c5af76..dd2992a245f6 100644
--- a/deskutils/gucharmap/Makefile
+++ b/deskutils/gucharmap/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gucharmap
-PORTVERSION= 3.18.2
+PORTVERSION= 9.0.4
CATEGORIES= deskutils gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -13,20 +13,25 @@ COMMENT= Unicode/ISO10646 character map and font viewer
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= itstool:textproc/itstool
+BUILD_DEPENDS= itstool:textproc/itstool \
+ unicode-ucd>=0:misc/unicode-ucd
PORTSCOUT= limitw:1,even
-USES= desktop-file-utils gettext gmake gnome libtool pathfix \
- pkgconfig tar:xz
-USE_GNOME= gnomeprefix gtk30 intlhack introspection:build
+USES= gmake gnome libtool localbase pathfix pkgconfig tar:xz
+USE_GNOME= cairo gdkpixbuf2 gtk30 introspection:build
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-unicode-data=${LOCALBASE}/share/unicode-ucd/
USE_LDCONFIG= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
GLIB_SCHEMAS= org.gnome.Charmap.enums.xml \
org.gnome.Charmap.gschema.xml
+OPTIONS_SUB= yes
+OPTIONS_DEFINE= NLS
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+
.include <bsd.port.mk>