aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gxneur
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-12-14 13:29:06 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-12-14 13:29:06 +0000
commit22717a14de78fdf9a48285bc6aaf9742f1718d7f (patch)
tree463c69386d2326bc6cefe8f263b1b8ca19dd4035 /deskutils/gxneur
parent5e74f768cad4c5922ac34ecbb423e2dd7fb46426 (diff)
downloadports-22717a14de78fdf9a48285bc6aaf9742f1718d7f.tar.gz
ports-22717a14de78fdf9a48285bc6aaf9742f1718d7f.zip
Notes
Diffstat (limited to 'deskutils/gxneur')
-rw-r--r--deskutils/gxneur/Makefile35
-rw-r--r--deskutils/gxneur/distinfo3
-rw-r--r--deskutils/gxneur/pkg-descr12
-rw-r--r--deskutils/gxneur/pkg-plist19
4 files changed, 69 insertions, 0 deletions
diff --git a/deskutils/gxneur/Makefile b/deskutils/gxneur/Makefile
new file mode 100644
index 000000000000..e39cb6a2a16c
--- /dev/null
+++ b/deskutils/gxneur/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: gxneur
+# Date created: 07 December 2008
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gxneur
+PORTVERSION= 0.9.2
+CATEGORIES= deskutils
+MASTER_SITES= http://dists.xneur.ru/release-${PORTVERSION}/tgz/
+
+MAINTAINER= ports@logvinov.com
+COMMENT= GTK frontend for XNeur keyboard layout switcher
+
+BUILD_DEPENDS= xneur:${PORTSDIR}/russian/xneur
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gtk20 libglade2
+
+MAN1= ${PORTNAME}.1
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/deskutils/gxneur/distinfo b/deskutils/gxneur/distinfo
new file mode 100644
index 000000000000..8ea0946b3026
--- /dev/null
+++ b/deskutils/gxneur/distinfo
@@ -0,0 +1,3 @@
+MD5 (gxneur-0.9.2.tar.bz2) = 793f8627fbd9ae7e1d3772e50714c6d7
+SHA256 (gxneur-0.9.2.tar.bz2) = c22e36182a37f213166c5e0c3b8eb7af70e781d7f3aea05fbc9c6bb4b6c850f5
+SIZE (gxneur-0.9.2.tar.bz2) = 308167
diff --git a/deskutils/gxneur/pkg-descr b/deskutils/gxneur/pkg-descr
new file mode 100644
index 000000000000..96eff3600cc4
--- /dev/null
+++ b/deskutils/gxneur/pkg-descr
@@ -0,0 +1,12 @@
+GTK frontend for XNeur keyboard layout switcher.
+
+In-place converter of text typed in with a wrong keyboard layout. When users
+work in multilingual environment (e.g. Russian+English), they sometimes type
+in text with wrong keyboard layout. In auto mode XNeur can automatically
+detect language of a word user typed, switch keyboard layout and convert the
+word from one keyboard layout into another. In manual mode user has ability
+to convert last typed word or some selected text using hot keys. The idea of
+this utility is similar to Punto Switcher for Windows. For now XNeur support
+English, Russian, Ukrainian, Belarusian, French and Romanian.
+
+WWW: http://www.xneur.ru/
diff --git a/deskutils/gxneur/pkg-plist b/deskutils/gxneur/pkg-plist
new file mode 100644
index 000000000000..fbc2c6fa328a
--- /dev/null
+++ b/deskutils/gxneur/pkg-plist
@@ -0,0 +1,19 @@
+bin/gxneur
+%%DATADIR%%/pixmaps/Russian.png
+%%DATADIR%%/pixmaps/Ukrainian.png
+%%DATADIR%%/pixmaps/English.png
+%%DATADIR%%/pixmaps/Belarusian.png
+%%DATADIR%%/pixmaps/French.png
+%%DATADIR%%/pixmaps/Romanian.png
+%%DATADIR%%/pixmaps/Kazakh.png
+%%DATADIR%%/pixmaps/German.png
+%%DATADIR%%/pixmaps/gxneur.png
+%%DATADIR%%/glade/config.glade
+%%DATADIR%%/glade/about.glade
+%%DATADIR%%/glade/list.glade
+%%DATADIR%%/glade/abbr_add.glade
+%%DATADIR%%/glade/choose_file.glade
+%%NLS%%share/locale/ru/LC_MESSAGES/gxneur.mo
+@dirrmtry %%DATADIR%%/pixmaps
+@dirrmtry %%DATADIR%%/glade
+@dirrmtry %%DATADIR%%