aboutsummaryrefslogtreecommitdiff
path: root/deskutils/hamster-applet/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-03-31 22:07:21 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-03-31 22:07:21 +0000
commit8f7a63f9929227fbac7f7d79ec074a2f6f5f45aa (patch)
treef9075ae7916eeb34a1c8330e90debf6f278fea01 /deskutils/hamster-applet/Makefile
parent3beb6fb6e6f165f0514d787df7fd971e5541d061 (diff)
downloadports-8f7a63f9929227fbac7f7d79ec074a2f6f5f45aa.tar.gz
ports-8f7a63f9929227fbac7f7d79ec074a2f6f5f45aa.zip
Notes
Diffstat (limited to 'deskutils/hamster-applet/Makefile')
-rw-r--r--deskutils/hamster-applet/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/deskutils/hamster-applet/Makefile b/deskutils/hamster-applet/Makefile
index 3cf41a905b96..fdf69d50bb55 100644
--- a/deskutils/hamster-applet/Makefile
+++ b/deskutils/hamster-applet/Makefile
@@ -30,7 +30,6 @@ LDFLAGS+= -L${LOCALBASE}/lib
GCONF_SCHEMAS= hamster-applet.schemas
-NO_STAGE= yes
.include <bsd.port.pre.mk>
# WAF needs that
@@ -43,11 +42,10 @@ do-build:
@cd ${WRKSRC} && ./waf build
do-install:
- @cd ${WRKSRC} && dbus-launch ./waf install
-# -O -Qold
- @${PYTHON_CMD} -Qold ${PYTHON_LIBDIR}/compileall.py -q \
- ${PYTHON_SITELIBDIR:S|${LOCALBASE}|${PREFIX}|}/hamster
- @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py -q \
- ${PYTHON_SITELIBDIR:S|${LOCALBASE}|${PREFIX}|}/hamster
+ @cd ${WRKSRC} && DESTDIR=${STAGEDIR} dbus-launch ./waf install
+ (cd ${STAGEDIR}${PREFIX} && ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py \
+ -d ${PYTHONPREFIX_SITELIBDIR} -f ${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;})
+ (cd ${STAGEDIR}${PREFIX} && ${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py \
+ -d ${PYTHONPREFIX_SITELIBDIR} -f ${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;})
.include <bsd.port.post.mk>