aboutsummaryrefslogtreecommitdiff
path: root/deskutils/horde-kronolith
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-04-08 23:42:31 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-04-08 23:42:31 +0000
commit1e0d8c9112e8493a5f7edfd1134a422c3e3efac3 (patch)
tree8195bcc94557ed871bb3862c71b9314dc2c43bd8 /deskutils/horde-kronolith
parent3e50ab625e240bab15b5babee4112f1f654cae5d (diff)
downloadports-1e0d8c9112e8493a5f7edfd1134a422c3e3efac3.tar.gz
ports-1e0d8c9112e8493a5f7edfd1134a422c3e3efac3.zip
Notes
Diffstat (limited to 'deskutils/horde-kronolith')
-rw-r--r--deskutils/horde-kronolith/Makefile62
-rw-r--r--deskutils/horde-kronolith/files/pkg-deinstall.in24
-rw-r--r--deskutils/horde-kronolith/files/pkg-install.in23
-rw-r--r--deskutils/horde-kronolith/files/pkg-message.in8
-rw-r--r--deskutils/horde-kronolith/pkg-plist611
5 files changed, 314 insertions, 414 deletions
diff --git a/deskutils/horde-kronolith/Makefile b/deskutils/horde-kronolith/Makefile
index d23e7549c9f1..c6b6b98907f8 100644
--- a/deskutils/horde-kronolith/Makefile
+++ b/deskutils/horde-kronolith/Makefile
@@ -7,69 +7,15 @@
PORTNAME= kronolith
PORTVERSION= 2.1.4
-DISTVERSIONPREFIX= h3-
PORTREVISION= 1
CATEGORIES= deskutils www
-MASTER_SITES= HORDE
MAINTAINER= beech@alaskaparadise.com
COMMENT= Kronolith is the Horde calendar application
-RUN_DEPENDS= ${LOCALBASE}/${LHORDEDIR}/rpc.php:${PORTSDIR}/www/horde-base
-
-NO_BUILD= yes
-USE_PHP= yes # modules set by Horde, but needed to get PHP_VER
+USE_HORDE= base
USE_GETTEXT= yes
+PORTDOCS= README CHANGES CREDITS INSTALL RELEASE_NOTES TODO UPGRADING
-REINPLACE_ARGS= -i ""
-PORTDOCS= README CHANGES CREDITS INSTALL \
- RELEASE_NOTES TODO UPGRADING
-CONFFILE= keywords.php menu.php prefs.php
-SUB_DIRS= config js lib locale po scripts templates themes
-
-LHORDEDIR?= www/horde
-LKRONOLITHDIR?= ${LHORDEDIR}/kronolith
-
-PKGMESSAGE= ${WRKDIR}/pkg-message
-PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-install pkg-deinstall
-SUB_LIST= KRONOLITHDIR=${KRONOLITHDIR}
-PLIST_SUB= KRONOLITHDIR=${LKRONOLITHDIR}
-
-KRONOLITHDIR= ${PREFIX}/${LKRONOLITHDIR}
-CONFDIR= ${KRONOLITHDIR}/config
-
-.include <bsd.port.pre.mk>
-
-post-extract:
- @${MV} ${WRKSRC}/README ${WRKSRC}/docs/
-
-pre-configure:
- @(cd ${WRKSRC}/scripts && \
- ${FIND} . -name "*.php" -exec \
- ${REINPLACE_CMD} -e "s:/usr/local/bin/php: ${LOCALBASE}/bin/php:;s:/usr/bin/php: ${LOCALBASE}/bin/php:" {} \; )
-
-do-install:
- @${INSTALL} -d ${KRONOLITHDIR}/
- @${CP} -Rp ${SUB_DIRS:S|^|${WRKSRC}/|} ${KRONOLITHDIR}/
- @${CP} -p ${WRKSRC}/*.php ${KRONOLITHDIR}/
- @${INSTALL_DATA} ${WRKSRC}/config/conf.xml ${CONFDIR}/
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${KRONOLITHDIR}/
- @${CHMOD} -R o-rwx ${KRONOLITHDIR}/
- ${ECHO_CMD} @exec ${CHOWN} -R ${WWWOWN}:${WWWGRP}\
- %D/${KRONOLITHDIR:S|^${PREFIX}/||}/ >> ${TMPPLIST}
- ${ECHO_CMD} @exec ${CHMOD} -R o-rwx\
- %D/${KRONOLITHDIR:S|^${PREFIX}/||}/ >> ${TMPPLIST}
-.if !defined(NOPORTDOCS)
- @${INSTALL} -d ${DOCSDIR}/
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/docs/|} ${DOCSDIR}/
- @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
-.endif
-
-post-install:
- @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
- @${ECHO_MSG}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_MSG}
-
-.include <bsd.port.post.mk>
+.include "${.CURDIR}/../../www/horde-base/bsd.horde.mk"
+.include <bsd.port.mk>
diff --git a/deskutils/horde-kronolith/files/pkg-deinstall.in b/deskutils/horde-kronolith/files/pkg-deinstall.in
deleted file mode 100644
index 97d0a7cca145..000000000000
--- a/deskutils/horde-kronolith/files/pkg-deinstall.in
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-# Backup Kronolith config files, if needed.
-
-if [ x$2 != xDEINSTALL ]; then
- exit
-fi
-
-if [ -z "${PACKAGE_BUILDING}" ]; then
- for cf in `ls %%KRONOLITHDIR%%/config/*php`; do
- diff -bBqw $cf $cf.dist >/dev/null 2>&1
- case $? in
- 0) # original config file, delete it
- rm -f $cf
- ;;
- 1) # config file has been updated, leave it alone
- ;;
- *) # not found?
- ;;
- esac
- done
-fi
diff --git a/deskutils/horde-kronolith/files/pkg-install.in b/deskutils/horde-kronolith/files/pkg-install.in
deleted file mode 100644
index 84722b6dc70a..000000000000
--- a/deskutils/horde-kronolith/files/pkg-install.in
+++ /dev/null
@@ -1,23 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-PATH=/usr/sbin:/usr/bin:/bin ; export PATH
-
-case $2 in
- PRE-INSTALL)
- ;;
-
- POST-INSTALL)
- if [ -z "${PACKAGE_BUILDING}" ]; then
- # Copy over sample config files unless they already exist
-
- for cf in `ls %%KRONOLITHDIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
- if [ ! -f $cf ]; then
- cp -p $cf.dist $cf
- fi
- done
- fi
- ;;
-esac
diff --git a/deskutils/horde-kronolith/files/pkg-message.in b/deskutils/horde-kronolith/files/pkg-message.in
index 8d1569fe4107..dba8deffa2d6 100644
--- a/deskutils/horde-kronolith/files/pkg-message.in
+++ b/deskutils/horde-kronolith/files/pkg-message.in
@@ -1,16 +1,16 @@
**************************************************************************
-Kronolith has been installed in %%KRONOLITHDIR%% with your
+Kronolith has been installed in %%HORDIR%% with your
blank configuration files.
-Horde must be configured; if not, see `pkg_info -D -x horde'.
+Horde must be configured; if not, see `pkg_info -Dx horde-base'.
Then you have to create some tables from the SQL scripts in
-%%KRONOLITHDIR%%/scripts/sql.
+%%HORDIR%%/scripts/sql.
WARNING! Please note that the MCAL back-end has been deprecated!
********
To migrate from MCAL to SQL, you can use the provided script
- %%KRONOLITHDIR%%/scripts/migrate_to_sql_driver.php
+ %%HORDIR%%/scripts/migrate_to_sql_driver.php
Finally, you must login to Horde as a Horde Administrator to finish the
configuration.
diff --git a/deskutils/horde-kronolith/pkg-plist b/deskutils/horde-kronolith/pkg-plist
index 3ee56c7dd0b1..bb727dffffef 100644
--- a/deskutils/horde-kronolith/pkg-plist
+++ b/deskutils/horde-kronolith/pkg-plist
@@ -1,305 +1,306 @@
-%%KRONOLITHDIR%%/addevent.php
-%%KRONOLITHDIR%%/addeventaction.php
-%%KRONOLITHDIR%%/attend.php
-%%KRONOLITHDIR%%/attendees.php
-%%KRONOLITHDIR%%/calendar_search.php
-%%KRONOLITHDIR%%/calendars.php
-%%KRONOLITHDIR%%/config/.htaccess
-%%KRONOLITHDIR%%/config/conf.xml
-%%KRONOLITHDIR%%/config/keywords.php.dist
-%%KRONOLITHDIR%%/config/menu.php.dist
-%%KRONOLITHDIR%%/config/prefs.php.dist
-%%KRONOLITHDIR%%/contacts.php
-%%KRONOLITHDIR%%/data.php
-%%KRONOLITHDIR%%/day.php
-%%KRONOLITHDIR%%/delevent.php
-%%KRONOLITHDIR%%/deleventaction.php
-%%KRONOLITHDIR%%/editevent.php
-%%KRONOLITHDIR%%/editeventaction.php
-%%KRONOLITHDIR%%/fb.php
-%%KRONOLITHDIR%%/ics.php
-%%KRONOLITHDIR%%/index.php
-%%KRONOLITHDIR%%/js/fixUnstyledOptions.js
-%%KRONOLITHDIR%%/js/stripe.js
-%%KRONOLITHDIR%%/lib/Block/month.php
-%%KRONOLITHDIR%%/lib/Block/monthlist.php
-%%KRONOLITHDIR%%/lib/Block/prevmonthlist.php
-%%KRONOLITHDIR%%/lib/Block/summary.php
-%%KRONOLITHDIR%%/lib/Block/tree_alarms.php
-%%KRONOLITHDIR%%/lib/Block/tree_menu.php
-%%KRONOLITHDIR%%/lib/Day.php
-%%KRONOLITHDIR%%/lib/DayView.php
-%%KRONOLITHDIR%%/lib/Driver.php
-%%KRONOLITHDIR%%/lib/Driver/ical.php
-%%KRONOLITHDIR%%/lib/Driver/kolab.php
-%%KRONOLITHDIR%%/lib/Driver/sql.php
-%%KRONOLITHDIR%%/lib/FBView.php
-%%KRONOLITHDIR%%/lib/FBView/day.php
-%%KRONOLITHDIR%%/lib/FBView/week.php
-%%KRONOLITHDIR%%/lib/FBView/workweek.php
-%%KRONOLITHDIR%%/lib/Kronolith.php
-%%KRONOLITHDIR%%/lib/Scheduler/kronolith.php
-%%KRONOLITHDIR%%/lib/Storage.php
-%%KRONOLITHDIR%%/lib/Storage/kolab.php
-%%KRONOLITHDIR%%/lib/Storage/sql.php
-%%KRONOLITHDIR%%/lib/WeekView.php
-%%KRONOLITHDIR%%/lib/api.php
-%%KRONOLITHDIR%%/lib/base.php
-%%KRONOLITHDIR%%/lib/prefs.php
-%%KRONOLITHDIR%%/lib/version.php
-%%KRONOLITHDIR%%/locale/ar_SY/LC_MESSAGES/kronolith.mo
-%%KRONOLITHDIR%%/locale/bg_BG/LC_MESSAGES/kronolith.mo
-%%KRONOLITHDIR%%/locale/cs_CZ/LC_MESSAGES/kronolith.mo
-%%KRONOLITHDIR%%/locale/da_DK/LC_MESSAGES/kronolith.mo
-%%KRONOLITHDIR%%/locale/de_DE/LC_MESSAGES/kronolith.mo
-%%KRONOLITHDIR%%/locale/de_DE/help.xml
-%%KRONOLITHDIR%%/locale/el_GR/LC_MESSAGES/kronolith.mo
-%%KRONOLITHDIR%%/locale/en_US/help.xml
-%%KRONOLITHDIR%%/locale/es_ES/LC_MESSAGES/kronolith.mo
-%%KRONOLITHDIR%%/locale/es_ES/help.xml
-%%KRONOLITHDIR%%/locale/fi_FI/LC_MESSAGES/kronolith.mo
-%%KRONOLITHDIR%%/locale/fi_FI/help.xml
-%%KRONOLITHDIR%%/locale/fr_FR/LC_MESSAGES/kronolith.mo
-%%KRONOLITHDIR%%/locale/hu_HU/LC_MESSAGES/kronolith.mo
-%%KRONOLITHDIR%%/locale/hu_HU/help.xml
-%%KRONOLITHDIR%%/locale/it_IT/LC_MESSAGES/kronolith.mo
-%%KRONOLITHDIR%%/locale/ja_JP/LC_MESSAGES/kronolith.mo
-%%KRONOLITHDIR%%/locale/ko_KR/LC_MESSAGES/kronolith.mo
-%%KRONOLITHDIR%%/locale/lt_LT/LC_MESSAGES/kronolith.mo
-%%KRONOLITHDIR%%/locale/lv_LV/LC_MESSAGES/kronolith.mo
-%%KRONOLITHDIR%%/locale/nb_NO/LC_MESSAGES/kronolith.mo
-%%KRONOLITHDIR%%/locale/nl_NL/LC_MESSAGES/kronolith.mo
-%%KRONOLITHDIR%%/locale/nn_NO/LC_MESSAGES/kronolith.mo
-%%KRONOLITHDIR%%/locale/pl_PL/LC_MESSAGES/kronolith.mo
-%%KRONOLITHDIR%%/locale/pt_BR/LC_MESSAGES/kronolith.mo
-%%KRONOLITHDIR%%/locale/pt_BR/help.xml
-%%KRONOLITHDIR%%/locale/pt_PT/LC_MESSAGES/kronolith.mo
-%%KRONOLITHDIR%%/locale/ro_RO/LC_MESSAGES/kronolith.mo
-%%KRONOLITHDIR%%/locale/ru_RU/LC_MESSAGES/kronolith.mo
-%%KRONOLITHDIR%%/locale/sk_SK/LC_MESSAGES/kronolith.mo
-%%KRONOLITHDIR%%/locale/sl_SI/LC_MESSAGES/kronolith.mo
-%%KRONOLITHDIR%%/locale/sv_SE/LC_MESSAGES/kronolith.mo
-%%KRONOLITHDIR%%/locale/tr_TR/help.xml
-%%KRONOLITHDIR%%/locale/zh_CN/LC_MESSAGES/kronolith.mo
-%%KRONOLITHDIR%%/locale/zh_TW/LC_MESSAGES/kronolith.mo
-%%KRONOLITHDIR%%/month.php
-%%KRONOLITHDIR%%/po/README
-%%KRONOLITHDIR%%/po/ar_SY.po
-%%KRONOLITHDIR%%/po/bg_BG.po
-%%KRONOLITHDIR%%/po/cs_CZ.po
-%%KRONOLITHDIR%%/po/da_DK.po
-%%KRONOLITHDIR%%/po/de_DE.po
-%%KRONOLITHDIR%%/po/el_GR.po
-%%KRONOLITHDIR%%/po/es_ES.po
-%%KRONOLITHDIR%%/po/fi_FI.po
-%%KRONOLITHDIR%%/po/fr_FR.po
-%%KRONOLITHDIR%%/po/hu_HU.po
-%%KRONOLITHDIR%%/po/it_IT.po
-%%KRONOLITHDIR%%/po/ja_JP.po
-%%KRONOLITHDIR%%/po/ko_KR.po
-%%KRONOLITHDIR%%/po/kronolith.pot
-%%KRONOLITHDIR%%/po/lt_LT.po
-%%KRONOLITHDIR%%/po/lv_LV.po
-%%KRONOLITHDIR%%/po/nb_NO.po
-%%KRONOLITHDIR%%/po/nl_NL.po
-%%KRONOLITHDIR%%/po/nn_NO.po
-%%KRONOLITHDIR%%/po/pl_PL.po
-%%KRONOLITHDIR%%/po/pt_BR.po
-%%KRONOLITHDIR%%/po/pt_PT.po
-%%KRONOLITHDIR%%/po/ro_RO.po
-%%KRONOLITHDIR%%/po/ru_RU.po
-%%KRONOLITHDIR%%/po/sk_SK.po
-%%KRONOLITHDIR%%/po/sl_SI.po
-%%KRONOLITHDIR%%/po/sv_SE.po
-%%KRONOLITHDIR%%/po/zh_CN.po
-%%KRONOLITHDIR%%/po/zh_TW.po
-%%KRONOLITHDIR%%/scripts/.htaccess
-%%KRONOLITHDIR%%/scripts/import_icals.php
-%%KRONOLITHDIR%%/scripts/migrate_to_sql_driver.php
-%%KRONOLITHDIR%%/scripts/reminders.php
-%%KRONOLITHDIR%%/scripts/sql/kronolith.mssql.sql
-%%KRONOLITHDIR%%/scripts/sql/kronolith.mysql.sql
-%%KRONOLITHDIR%%/scripts/sql/kronolith.oci8.sql
-%%KRONOLITHDIR%%/scripts/sql/kronolith.pgsql.sql
-%%KRONOLITHDIR%%/scripts/sql/kronolith.sql
-%%KRONOLITHDIR%%/scripts/sql/kronolith.xml
-%%KRONOLITHDIR%%/scripts/upgrades/1.1_to_2.0.mysql.sql
-%%KRONOLITHDIR%%/scripts/upgrades/1.1_to_2.0.pgsql.sql
-%%KRONOLITHDIR%%/scripts/upgrades/1.1_to_2.0.oci8.sql
-%%KRONOLITHDIR%%/scripts/upgrades/2004-05-19_convert_categories_to_strings.php
-%%KRONOLITHDIR%%/scripts/upgrades/2004-12-21_add_event_uid.pgsql.sql
-%%KRONOLITHDIR%%/scripts/upgrades/2004-12-21_add_event_uid.sql
-%%KRONOLITHDIR%%/scripts/upgrades/2006-08-20_fix_recur_int_fields.mysql.sql
-%%KRONOLITHDIR%%/search.php
-%%KRONOLITHDIR%%/templates/attendees/attendees.inc
-%%KRONOLITHDIR%%/templates/calendars/calendars.inc
-%%KRONOLITHDIR%%/templates/calendars/search.inc
-%%KRONOLITHDIR%%/templates/category_legend.inc
-%%KRONOLITHDIR%%/templates/common-header.inc
-%%KRONOLITHDIR%%/templates/contacts/contacts.inc
-%%KRONOLITHDIR%%/templates/data/export.inc
-%%KRONOLITHDIR%%/templates/data/import.inc
-%%KRONOLITHDIR%%/templates/day/all_day.inc
-%%KRONOLITHDIR%%/templates/day/head.inc
-%%KRONOLITHDIR%%/templates/day/head_side_by_side.inc
-%%KRONOLITHDIR%%/templates/day/rows.html
-%%KRONOLITHDIR%%/templates/delete/delete.inc
-%%KRONOLITHDIR%%/templates/delete/one.inc
-%%KRONOLITHDIR%%/templates/edit/edit.inc
-%%KRONOLITHDIR%%/templates/edit/edit_timespan.inc
-%%KRONOLITHDIR%%/templates/edit/javascript.inc
-%%KRONOLITHDIR%%/templates/fbview/busyblock.tpl
-%%KRONOLITHDIR%%/templates/fbview/emptyblock.tpl
-%%KRONOLITHDIR%%/templates/fbview/header.tpl
-%%KRONOLITHDIR%%/templates/fbview/legend.tpl
-%%KRONOLITHDIR%%/templates/fbview/meetingblock.tpl
-%%KRONOLITHDIR%%/templates/fbview/row.tpl
-%%KRONOLITHDIR%%/templates/fbview/section.tpl
-%%KRONOLITHDIR%%/templates/fbview/unknownblock.tpl
-%%KRONOLITHDIR%%/templates/javascript/goto.js
-%%KRONOLITHDIR%%/templates/javascript/open_attendees_win.js
-%%KRONOLITHDIR%%/templates/javascript/open_calendar_search.js
-%%KRONOLITHDIR%%/templates/menu.inc
-%%KRONOLITHDIR%%/templates/month/head.inc
-%%KRONOLITHDIR%%/templates/month/head_side_by_side.inc
-%%KRONOLITHDIR%%/templates/prefs/fb_cals_select.inc
-%%KRONOLITHDIR%%/templates/prefs/remote_cal_management.inc
-%%KRONOLITHDIR%%/templates/prefs/search_abook_select.inc
-%%KRONOLITHDIR%%/templates/prefs/shareselect.inc
-%%KRONOLITHDIR%%/templates/search/empty.inc
-%%KRONOLITHDIR%%/templates/search/event_footers.inc
-%%KRONOLITHDIR%%/templates/search/event_headers.inc
-%%KRONOLITHDIR%%/templates/search/event_summaries.inc
-%%KRONOLITHDIR%%/templates/search/header.inc
-%%KRONOLITHDIR%%/templates/search/search.inc
-%%KRONOLITHDIR%%/templates/search/search_advanced.inc
-%%KRONOLITHDIR%%/templates/view/view.inc
-%%KRONOLITHDIR%%/templates/week/head.inc
-%%KRONOLITHDIR%%/templates/week/head_side_by_side.inc
-%%KRONOLITHDIR%%/templates/year/head.inc
-%%KRONOLITHDIR%%/themes/bluewhite/screen.css
-%%KRONOLITHDIR%%/themes/burntorange/screen.css
-%%KRONOLITHDIR%%/themes/categoryCSS.php
-%%KRONOLITHDIR%%/themes/graphics/addressbook_browse.png
-%%KRONOLITHDIR%%/themes/graphics/alarm.png
-%%KRONOLITHDIR%%/themes/graphics/alarm_small.png
-%%KRONOLITHDIR%%/themes/graphics/attendees.png
-%%KRONOLITHDIR%%/themes/graphics/calendars.png
-%%KRONOLITHDIR%%/themes/graphics/dayview.png
-%%KRONOLITHDIR%%/themes/graphics/expand.png
-%%KRONOLITHDIR%%/themes/graphics/favicon.ico
-%%KRONOLITHDIR%%/themes/graphics/goto.png
-%%KRONOLITHDIR%%/themes/graphics/kronolith.png
-%%KRONOLITHDIR%%/themes/graphics/monthview.png
-%%KRONOLITHDIR%%/themes/graphics/new.png
-%%KRONOLITHDIR%%/themes/graphics/new_big.png
-%%KRONOLITHDIR%%/themes/graphics/new_small.png
-%%KRONOLITHDIR%%/themes/graphics/recur.png
-%%KRONOLITHDIR%%/themes/graphics/today.png
-%%KRONOLITHDIR%%/themes/graphics/unknown-background.png
-%%KRONOLITHDIR%%/themes/graphics/weekview.png
-%%KRONOLITHDIR%%/themes/graphics/workweekview.png
-%%KRONOLITHDIR%%/themes/graphics/yearview.png
-%%KRONOLITHDIR%%/themes/mozilla/screen.css
-%%KRONOLITHDIR%%/themes/print/screen.css
-%%KRONOLITHDIR%%/themes/screen.css
-%%KRONOLITHDIR%%/themes/simplex/screen.css
-%%KRONOLITHDIR%%/viewevent.php
-%%KRONOLITHDIR%%/week.php
-%%KRONOLITHDIR%%/workweek.php
-%%KRONOLITHDIR%%/year.php
-@dirrm %%KRONOLITHDIR%%/themes/simplex
-@dirrm %%KRONOLITHDIR%%/themes/print
-@dirrm %%KRONOLITHDIR%%/themes/mozilla
-@dirrm %%KRONOLITHDIR%%/themes/graphics
-@dirrm %%KRONOLITHDIR%%/themes/burntorange
-@dirrm %%KRONOLITHDIR%%/themes/bluewhite
-@dirrm %%KRONOLITHDIR%%/themes
-@dirrm %%KRONOLITHDIR%%/templates/year
-@dirrm %%KRONOLITHDIR%%/templates/week
-@dirrm %%KRONOLITHDIR%%/templates/view
-@dirrm %%KRONOLITHDIR%%/templates/search
-@dirrm %%KRONOLITHDIR%%/templates/prefs
-@dirrm %%KRONOLITHDIR%%/templates/month
-@dirrm %%KRONOLITHDIR%%/templates/javascript
-@dirrm %%KRONOLITHDIR%%/templates/fbview
-@dirrm %%KRONOLITHDIR%%/templates/edit
-@dirrm %%KRONOLITHDIR%%/templates/delete
-@dirrm %%KRONOLITHDIR%%/templates/day
-@dirrm %%KRONOLITHDIR%%/templates/data
-@dirrm %%KRONOLITHDIR%%/templates/contacts
-@dirrm %%KRONOLITHDIR%%/templates/calendars
-@dirrm %%KRONOLITHDIR%%/templates/attendees
-@dirrm %%KRONOLITHDIR%%/templates
-@dirrm %%KRONOLITHDIR%%/scripts/upgrades
-@dirrm %%KRONOLITHDIR%%/scripts/sql
-@dirrm %%KRONOLITHDIR%%/scripts
-@dirrm %%KRONOLITHDIR%%/po
-@dirrm %%KRONOLITHDIR%%/locale/zh_TW/LC_MESSAGES
-@dirrm %%KRONOLITHDIR%%/locale/zh_TW
-@dirrm %%KRONOLITHDIR%%/locale/zh_CN/LC_MESSAGES
-@dirrm %%KRONOLITHDIR%%/locale/zh_CN
-@dirrm %%KRONOLITHDIR%%/locale/sv_SE/LC_MESSAGES
-@dirrm %%KRONOLITHDIR%%/locale/tr_TR
-@dirrm %%KRONOLITHDIR%%/locale/sv_SE
-@dirrm %%KRONOLITHDIR%%/locale/sl_SI/LC_MESSAGES
-@dirrm %%KRONOLITHDIR%%/locale/sl_SI
-@dirrm %%KRONOLITHDIR%%/locale/sk_SK/LC_MESSAGES
-@dirrm %%KRONOLITHDIR%%/locale/sk_SK
-@dirrm %%KRONOLITHDIR%%/locale/ru_RU/LC_MESSAGES
-@dirrm %%KRONOLITHDIR%%/locale/ru_RU
-@dirrm %%KRONOLITHDIR%%/locale/ro_RO/LC_MESSAGES
-@dirrm %%KRONOLITHDIR%%/locale/ro_RO
-@dirrm %%KRONOLITHDIR%%/locale/pt_PT/LC_MESSAGES
-@dirrm %%KRONOLITHDIR%%/locale/pt_PT
-@dirrm %%KRONOLITHDIR%%/locale/pt_BR/LC_MESSAGES
-@dirrm %%KRONOLITHDIR%%/locale/pt_BR
-@dirrm %%KRONOLITHDIR%%/locale/pl_PL/LC_MESSAGES
-@dirrm %%KRONOLITHDIR%%/locale/pl_PL
-@dirrm %%KRONOLITHDIR%%/locale/nn_NO/LC_MESSAGES
-@dirrm %%KRONOLITHDIR%%/locale/nn_NO
-@dirrm %%KRONOLITHDIR%%/locale/nl_NL/LC_MESSAGES
-@dirrm %%KRONOLITHDIR%%/locale/nl_NL
-@dirrm %%KRONOLITHDIR%%/locale/nb_NO/LC_MESSAGES
-@dirrm %%KRONOLITHDIR%%/locale/nb_NO
-@dirrm %%KRONOLITHDIR%%/locale/lv_LV/LC_MESSAGES
-@dirrm %%KRONOLITHDIR%%/locale/lv_LV
-@dirrm %%KRONOLITHDIR%%/locale/lt_LT/LC_MESSAGES
-@dirrm %%KRONOLITHDIR%%/locale/lt_LT
-@dirrm %%KRONOLITHDIR%%/locale/ko_KR/LC_MESSAGES
-@dirrm %%KRONOLITHDIR%%/locale/ko_KR
-@dirrm %%KRONOLITHDIR%%/locale/ja_JP/LC_MESSAGES
-@dirrm %%KRONOLITHDIR%%/locale/ja_JP
-@dirrm %%KRONOLITHDIR%%/locale/it_IT/LC_MESSAGES
-@dirrm %%KRONOLITHDIR%%/locale/it_IT
-@dirrm %%KRONOLITHDIR%%/locale/hu_HU/LC_MESSAGES
-@dirrm %%KRONOLITHDIR%%/locale/hu_HU
-@dirrm %%KRONOLITHDIR%%/locale/fr_FR/LC_MESSAGES
-@dirrm %%KRONOLITHDIR%%/locale/fr_FR
-@dirrm %%KRONOLITHDIR%%/locale/fi_FI/LC_MESSAGES
-@dirrm %%KRONOLITHDIR%%/locale/fi_FI
-@dirrm %%KRONOLITHDIR%%/locale/es_ES/LC_MESSAGES
-@dirrm %%KRONOLITHDIR%%/locale/es_ES
-@dirrm %%KRONOLITHDIR%%/locale/en_US
-@dirrm %%KRONOLITHDIR%%/locale/el_GR/LC_MESSAGES
-@dirrm %%KRONOLITHDIR%%/locale/el_GR
-@dirrm %%KRONOLITHDIR%%/locale/de_DE/LC_MESSAGES
-@dirrm %%KRONOLITHDIR%%/locale/de_DE
-@dirrm %%KRONOLITHDIR%%/locale/da_DK/LC_MESSAGES
-@dirrm %%KRONOLITHDIR%%/locale/da_DK
-@dirrm %%KRONOLITHDIR%%/locale/cs_CZ/LC_MESSAGES
-@dirrm %%KRONOLITHDIR%%/locale/cs_CZ
-@dirrm %%KRONOLITHDIR%%/locale/bg_BG/LC_MESSAGES
-@dirrm %%KRONOLITHDIR%%/locale/bg_BG
-@dirrm %%KRONOLITHDIR%%/locale/ar_SY/LC_MESSAGES
-@dirrm %%KRONOLITHDIR%%/locale/ar_SY
-@dirrm %%KRONOLITHDIR%%/locale
-@dirrm %%KRONOLITHDIR%%/lib/Storage
-@dirrm %%KRONOLITHDIR%%/lib/Scheduler
-@dirrm %%KRONOLITHDIR%%/lib/FBView
-@dirrm %%KRONOLITHDIR%%/lib/Driver
-@dirrm %%KRONOLITHDIR%%/lib/Block
-@dirrm %%KRONOLITHDIR%%/lib
-@dirrm %%KRONOLITHDIR%%/js
-@dirrmtry %%KRONOLITHDIR%%/config
-@dirrmtry %%KRONOLITHDIR%%
+%%HORDIR%%/addevent.php
+%%HORDIR%%/addeventaction.php
+%%HORDIR%%/attend.php
+%%HORDIR%%/attendees.php
+%%HORDIR%%/calendar_search.php
+%%HORDIR%%/calendars.php
+%%HORDIR%%/config/.htaccess
+%%HORDIR%%/config/conf.xml
+%%HORDIR%%/config/keywords.php.dist
+%%HORDIR%%/config/menu.php.dist
+%%HORDIR%%/config/prefs.php.dist
+%%HORDIR%%/contacts.php
+%%HORDIR%%/data.php
+%%HORDIR%%/day.php
+%%HORDIR%%/delevent.php
+%%HORDIR%%/deleventaction.php
+%%HORDIR%%/editevent.php
+%%HORDIR%%/editeventaction.php
+%%HORDIR%%/fb.php
+%%HORDIR%%/ics.php
+%%HORDIR%%/index.php
+%%HORDIR%%/js/fixUnstyledOptions.js
+%%HORDIR%%/js/stripe.js
+%%HORDIR%%/lib/Block/month.php
+%%HORDIR%%/lib/Block/monthlist.php
+%%HORDIR%%/lib/Block/prevmonthlist.php
+%%HORDIR%%/lib/Block/summary.php
+%%HORDIR%%/lib/Block/tree_alarms.php
+%%HORDIR%%/lib/Block/tree_menu.php
+%%HORDIR%%/lib/Day.php
+%%HORDIR%%/lib/DayView.php
+%%HORDIR%%/lib/Driver/ical.php
+%%HORDIR%%/lib/Driver/kolab.php
+%%HORDIR%%/lib/Driver/sql.php
+%%HORDIR%%/lib/Driver.php
+%%HORDIR%%/lib/FBView/day.php
+%%HORDIR%%/lib/FBView/week.php
+%%HORDIR%%/lib/FBView/workweek.php
+%%HORDIR%%/lib/FBView.php
+%%HORDIR%%/lib/Kronolith.php
+%%HORDIR%%/lib/Scheduler/kronolith.php
+%%HORDIR%%/lib/Storage/kolab.php
+%%HORDIR%%/lib/Storage/sql.php
+%%HORDIR%%/lib/Storage.php
+%%HORDIR%%/lib/WeekView.php
+%%HORDIR%%/lib/api.php
+%%HORDIR%%/lib/base.php
+%%HORDIR%%/lib/prefs.php
+%%HORDIR%%/lib/version.php
+%%HORDIR%%/locale/ar_SY/LC_MESSAGES/kronolith.mo
+%%HORDIR%%/locale/bg_BG/LC_MESSAGES/kronolith.mo
+%%HORDIR%%/locale/cs_CZ/LC_MESSAGES/kronolith.mo
+%%HORDIR%%/locale/da_DK/LC_MESSAGES/kronolith.mo
+%%HORDIR%%/locale/de_DE/LC_MESSAGES/kronolith.mo
+%%HORDIR%%/locale/de_DE/help.xml
+%%HORDIR%%/locale/el_GR/LC_MESSAGES/kronolith.mo
+%%HORDIR%%/locale/en_US/help.xml
+%%HORDIR%%/locale/es_ES/LC_MESSAGES/kronolith.mo
+%%HORDIR%%/locale/es_ES/help.xml
+%%HORDIR%%/locale/fi_FI/LC_MESSAGES/kronolith.mo
+%%HORDIR%%/locale/fi_FI/help.xml
+%%HORDIR%%/locale/fr_FR/LC_MESSAGES/kronolith.mo
+%%HORDIR%%/locale/hu_HU/LC_MESSAGES/kronolith.mo
+%%HORDIR%%/locale/hu_HU/help.xml
+%%HORDIR%%/locale/it_IT/LC_MESSAGES/kronolith.mo
+%%HORDIR%%/locale/ja_JP/LC_MESSAGES/kronolith.mo
+%%HORDIR%%/locale/ko_KR/LC_MESSAGES/kronolith.mo
+%%HORDIR%%/locale/lt_LT/LC_MESSAGES/kronolith.mo
+%%HORDIR%%/locale/lv_LV/LC_MESSAGES/kronolith.mo
+%%HORDIR%%/locale/nb_NO/LC_MESSAGES/kronolith.mo
+%%HORDIR%%/locale/nl_NL/LC_MESSAGES/kronolith.mo
+%%HORDIR%%/locale/nn_NO/LC_MESSAGES/kronolith.mo
+%%HORDIR%%/locale/pl_PL/LC_MESSAGES/kronolith.mo
+%%HORDIR%%/locale/pt_BR/LC_MESSAGES/kronolith.mo
+%%HORDIR%%/locale/pt_BR/help.xml
+%%HORDIR%%/locale/pt_PT/LC_MESSAGES/kronolith.mo
+%%HORDIR%%/locale/ro_RO/LC_MESSAGES/kronolith.mo
+%%HORDIR%%/locale/ru_RU/LC_MESSAGES/kronolith.mo
+%%HORDIR%%/locale/sk_SK/LC_MESSAGES/kronolith.mo
+%%HORDIR%%/locale/sl_SI/LC_MESSAGES/kronolith.mo
+%%HORDIR%%/locale/sv_SE/LC_MESSAGES/kronolith.mo
+%%HORDIR%%/locale/tr_TR/help.xml
+%%HORDIR%%/locale/zh_CN/LC_MESSAGES/kronolith.mo
+%%HORDIR%%/locale/zh_TW/LC_MESSAGES/kronolith.mo
+%%HORDIR%%/month.php
+%%HORDIR%%/po/README
+%%HORDIR%%/po/ar_SY.po
+%%HORDIR%%/po/bg_BG.po
+%%HORDIR%%/po/cs_CZ.po
+%%HORDIR%%/po/da_DK.po
+%%HORDIR%%/po/de_DE.po
+%%HORDIR%%/po/el_GR.po
+%%HORDIR%%/po/es_ES.po
+%%HORDIR%%/po/fi_FI.po
+%%HORDIR%%/po/fr_FR.po
+%%HORDIR%%/po/hu_HU.po
+%%HORDIR%%/po/it_IT.po
+%%HORDIR%%/po/ja_JP.po
+%%HORDIR%%/po/ko_KR.po
+%%HORDIR%%/po/kronolith.pot
+%%HORDIR%%/po/lt_LT.po
+%%HORDIR%%/po/lv_LV.po
+%%HORDIR%%/po/nb_NO.po
+%%HORDIR%%/po/nl_NL.po
+%%HORDIR%%/po/nn_NO.po
+%%HORDIR%%/po/pl_PL.po
+%%HORDIR%%/po/pt_BR.po
+%%HORDIR%%/po/pt_PT.po
+%%HORDIR%%/po/ro_RO.po
+%%HORDIR%%/po/ru_RU.po
+%%HORDIR%%/po/sk_SK.po
+%%HORDIR%%/po/sl_SI.po
+%%HORDIR%%/po/sv_SE.po
+%%HORDIR%%/po/zh_CN.po
+%%HORDIR%%/po/zh_TW.po
+%%HORDIR%%/scripts/.htaccess
+%%HORDIR%%/scripts/import_icals.php
+%%HORDIR%%/scripts/migrate_to_sql_driver.php
+%%HORDIR%%/scripts/reminders.php
+%%HORDIR%%/scripts/sql/kronolith.mssql.sql
+%%HORDIR%%/scripts/sql/kronolith.mysql.sql
+%%HORDIR%%/scripts/sql/kronolith.oci8.sql
+%%HORDIR%%/scripts/sql/kronolith.pgsql.sql
+%%HORDIR%%/scripts/sql/kronolith.sql
+%%HORDIR%%/scripts/sql/kronolith.xml
+%%HORDIR%%/scripts/upgrades/1.1_to_2.0.mysql.sql
+%%HORDIR%%/scripts/upgrades/1.1_to_2.0.oci8.sql
+%%HORDIR%%/scripts/upgrades/1.1_to_2.0.pgsql.sql
+%%HORDIR%%/scripts/upgrades/2004-05-19_convert_categories_to_strings.php
+%%HORDIR%%/scripts/upgrades/2004-12-21_add_event_uid.pgsql.sql
+%%HORDIR%%/scripts/upgrades/2004-12-21_add_event_uid.sql
+%%HORDIR%%/scripts/upgrades/2006-08-20_fix_recur_int_fields.mysql.sql
+%%HORDIR%%/search.php
+%%HORDIR%%/templates/attendees/attendees.inc
+%%HORDIR%%/templates/calendars/calendars.inc
+%%HORDIR%%/templates/calendars/search.inc
+%%HORDIR%%/templates/category_legend.inc
+%%HORDIR%%/templates/common-header.inc
+%%HORDIR%%/templates/contacts/contacts.inc
+%%HORDIR%%/templates/data/export.inc
+%%HORDIR%%/templates/data/import.inc
+%%HORDIR%%/templates/day/all_day.inc
+%%HORDIR%%/templates/day/head.inc
+%%HORDIR%%/templates/day/head_side_by_side.inc
+%%HORDIR%%/templates/day/rows.html
+%%HORDIR%%/templates/delete/delete.inc
+%%HORDIR%%/templates/delete/one.inc
+%%HORDIR%%/templates/edit/edit.inc
+%%HORDIR%%/templates/edit/edit_timespan.inc
+%%HORDIR%%/templates/edit/javascript.inc
+%%HORDIR%%/templates/fbview/busyblock.tpl
+%%HORDIR%%/templates/fbview/emptyblock.tpl
+%%HORDIR%%/templates/fbview/header.tpl
+%%HORDIR%%/templates/fbview/legend.tpl
+%%HORDIR%%/templates/fbview/meetingblock.tpl
+%%HORDIR%%/templates/fbview/row.tpl
+%%HORDIR%%/templates/fbview/section.tpl
+%%HORDIR%%/templates/fbview/unknownblock.tpl
+%%HORDIR%%/templates/javascript/goto.js
+%%HORDIR%%/templates/javascript/open_attendees_win.js
+%%HORDIR%%/templates/javascript/open_calendar_search.js
+%%HORDIR%%/templates/menu.inc
+%%HORDIR%%/templates/month/head.inc
+%%HORDIR%%/templates/month/head_side_by_side.inc
+%%HORDIR%%/templates/prefs/fb_cals_select.inc
+%%HORDIR%%/templates/prefs/remote_cal_management.inc
+%%HORDIR%%/templates/prefs/search_abook_select.inc
+%%HORDIR%%/templates/prefs/shareselect.inc
+%%HORDIR%%/templates/search/empty.inc
+%%HORDIR%%/templates/search/event_footers.inc
+%%HORDIR%%/templates/search/event_headers.inc
+%%HORDIR%%/templates/search/event_summaries.inc
+%%HORDIR%%/templates/search/header.inc
+%%HORDIR%%/templates/search/search.inc
+%%HORDIR%%/templates/search/search_advanced.inc
+%%HORDIR%%/templates/view/view.inc
+%%HORDIR%%/templates/week/head.inc
+%%HORDIR%%/templates/week/head_side_by_side.inc
+%%HORDIR%%/templates/year/head.inc
+%%HORDIR%%/themes/bluewhite/screen.css
+%%HORDIR%%/themes/burntorange/screen.css
+%%HORDIR%%/themes/categoryCSS.php
+%%HORDIR%%/themes/graphics/addressbook_browse.png
+%%HORDIR%%/themes/graphics/alarm.png
+%%HORDIR%%/themes/graphics/alarm_small.png
+%%HORDIR%%/themes/graphics/attendees.png
+%%HORDIR%%/themes/graphics/calendars.png
+%%HORDIR%%/themes/graphics/dayview.png
+%%HORDIR%%/themes/graphics/expand.png
+%%HORDIR%%/themes/graphics/favicon.ico
+%%HORDIR%%/themes/graphics/goto.png
+%%HORDIR%%/themes/graphics/kronolith.png
+%%HORDIR%%/themes/graphics/monthview.png
+%%HORDIR%%/themes/graphics/new.png
+%%HORDIR%%/themes/graphics/new_big.png
+%%HORDIR%%/themes/graphics/new_small.png
+%%HORDIR%%/themes/graphics/recur.png
+%%HORDIR%%/themes/graphics/today.png
+%%HORDIR%%/themes/graphics/unknown-background.png
+%%HORDIR%%/themes/graphics/weekview.png
+%%HORDIR%%/themes/graphics/workweekview.png
+%%HORDIR%%/themes/graphics/yearview.png
+%%HORDIR%%/themes/mozilla/screen.css
+%%HORDIR%%/themes/print/screen.css
+%%HORDIR%%/themes/screen.css
+%%HORDIR%%/themes/simplex/screen.css
+%%HORDIR%%/viewevent.php
+%%HORDIR%%/week.php
+%%HORDIR%%/workweek.php
+%%HORDIR%%/year.php
+@dirrmtry %%HORDIR%%/config
+@dirrm %%HORDIR%%/js
+@dirrm %%HORDIR%%/lib/Block
+@dirrm %%HORDIR%%/lib/Driver
+@dirrm %%HORDIR%%/lib/FBView
+@dirrm %%HORDIR%%/lib/Scheduler
+@dirrm %%HORDIR%%/lib/Storage
+@dirrm %%HORDIR%%/lib
+@dirrm %%HORDIR%%/locale/ar_SY/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/ar_SY
+@dirrm %%HORDIR%%/locale/bg_BG/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/bg_BG
+@dirrm %%HORDIR%%/locale/cs_CZ/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/cs_CZ
+@dirrm %%HORDIR%%/locale/da_DK/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/da_DK
+@dirrm %%HORDIR%%/locale/de_DE/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/de_DE
+@dirrm %%HORDIR%%/locale/el_GR/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/el_GR
+@dirrm %%HORDIR%%/locale/en_US
+@dirrm %%HORDIR%%/locale/es_ES/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/es_ES
+@dirrm %%HORDIR%%/locale/fi_FI/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/fi_FI
+@dirrm %%HORDIR%%/locale/fr_FR/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/fr_FR
+@dirrm %%HORDIR%%/locale/hu_HU/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/hu_HU
+@dirrm %%HORDIR%%/locale/it_IT/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/it_IT
+@dirrm %%HORDIR%%/locale/ja_JP/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/ja_JP
+@dirrm %%HORDIR%%/locale/ko_KR/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/ko_KR
+@dirrm %%HORDIR%%/locale/lt_LT/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/lt_LT
+@dirrm %%HORDIR%%/locale/lv_LV/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/lv_LV
+@dirrm %%HORDIR%%/locale/nb_NO/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/nb_NO
+@dirrm %%HORDIR%%/locale/nl_NL/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/nl_NL
+@dirrm %%HORDIR%%/locale/nn_NO/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/nn_NO
+@dirrm %%HORDIR%%/locale/pl_PL/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/pl_PL
+@dirrm %%HORDIR%%/locale/pt_BR/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/pt_BR
+@dirrm %%HORDIR%%/locale/pt_PT/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/pt_PT
+@dirrm %%HORDIR%%/locale/ro_RO/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/ro_RO
+@dirrm %%HORDIR%%/locale/ru_RU/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/ru_RU
+@dirrm %%HORDIR%%/locale/sk_SK/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/sk_SK
+@dirrm %%HORDIR%%/locale/sl_SI/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/sl_SI
+@dirrm %%HORDIR%%/locale/sv_SE/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/sv_SE
+@dirrm %%HORDIR%%/locale/tr_TR
+@dirrm %%HORDIR%%/locale/zh_CN/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/zh_CN
+@dirrm %%HORDIR%%/locale/zh_TW/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/zh_TW
+@dirrm %%HORDIR%%/locale
+@dirrm %%HORDIR%%/po
+@dirrm %%HORDIR%%/scripts/sql
+@dirrm %%HORDIR%%/scripts/upgrades
+@dirrm %%HORDIR%%/scripts
+@dirrm %%HORDIR%%/templates/attendees
+@dirrm %%HORDIR%%/templates/calendars
+@dirrm %%HORDIR%%/templates/contacts
+@dirrm %%HORDIR%%/templates/data
+@dirrm %%HORDIR%%/templates/day
+@dirrm %%HORDIR%%/templates/delete
+@dirrm %%HORDIR%%/templates/edit
+@dirrm %%HORDIR%%/templates/fbview
+@dirrm %%HORDIR%%/templates/javascript
+@dirrm %%HORDIR%%/templates/month
+@dirrm %%HORDIR%%/templates/prefs
+@dirrm %%HORDIR%%/templates/search
+@dirrm %%HORDIR%%/templates/view
+@dirrm %%HORDIR%%/templates/week
+@dirrm %%HORDIR%%/templates/year
+@dirrm %%HORDIR%%/templates
+@dirrm %%HORDIR%%/themes/bluewhite
+@dirrm %%HORDIR%%/themes/burntorange
+@dirrm %%HORDIR%%/themes/graphics
+@dirrm %%HORDIR%%/themes/mozilla
+@dirrm %%HORDIR%%/themes/print
+@dirrm %%HORDIR%%/themes/simplex
+@dirrm %%HORDIR%%/themes
+@dirrmtry %%HORDIR%%
+@dirrmtry %%HORBAS%%