aboutsummaryrefslogtreecommitdiff
path: root/deskutils/ical/Makefile
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-01-12 18:05:12 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-01-12 18:05:12 +0000
commit5843946ac4b694035b04ca9af0cb8df85eb7cac2 (patch)
treeb8e63f0a05601d45876592f6bf4089537ec372a5 /deskutils/ical/Makefile
parent37d288db3aff5ee82e0cdfb5a55044e5dfa211d3 (diff)
Notes
Diffstat (limited to 'deskutils/ical/Makefile')
-rw-r--r--deskutils/ical/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/deskutils/ical/Makefile b/deskutils/ical/Makefile
index 9c08823271b8..c31a353ec161 100644
--- a/deskutils/ical/Makefile
+++ b/deskutils/ical/Makefile
@@ -2,18 +2,19 @@
# $FreeBSD$
PORTNAME= ical
-PORTVERSION= 2.2
-PORTREVISION= 5
+PORTVERSION= 2.3.1
CATEGORIES= deskutils tk
MASTER_SITES= http://opal.com/jr/ical/
-PATCH_SITES= http://www.isi.edu/~johnh/SOFTWARE/ICAL/
+PATCH_SITES= http://www.isi.edu/~johnh/SOFTWARE/ICAL/ \
+ http://opal.com/jr/ical/
PATCHFILES= ical-2.3.1-upvar.patch
MAINTAINER= fbsd@opal.com
COMMENT= Calendar application
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT.GNU
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
@@ -27,12 +28,18 @@ CONFIGURE_ARGS= --with-tclconfig=${TCL_LIBDIR} \
--with-tkconfig=${TK_LIBDIR} \
--with-tkhdir=${TK_INCLUDEDIR}
MAKE_ENV= STAGEDIR=${STAGEDIR}
+SUB_FILES= pkg-message
+SUB_LIST+= VERSION=${VERSION}
+
+USER_TCL= ${HOME}/.tk/${PORTNAME}/user.tcl
+VERSION= ${PORTVERSION:C/([0-9]+\.[0-9]+)(\.[0-9]+)*/\1/}
+DIST_VER= ${DISTNAME:S/${PORTVERSION}/${VERSION}/}
post-patch:
@${REINPLACE_CMD} -e 's,tcl->result,Tcl_GetStringResult(tcl),' \
${WRKSRC}/ical.C
post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${DISTNAME}
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${DIST_VER}
.include <bsd.port.mk>