aboutsummaryrefslogtreecommitdiff
path: root/deskutils/kdepim-runtime-kde4/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-02-10 10:29:51 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-02-10 10:29:51 +0000
commit737c1cc56dbc42d63372805d3642ba9b3d119a96 (patch)
tree0b032f3e2684e6f49384c70cbee1ccfb5359893d /deskutils/kdepim-runtime-kde4/Makefile
parent5e9ae3b9f544b762bebe53addbf6c4095bbafcf3 (diff)
Notes
Diffstat (limited to 'deskutils/kdepim-runtime-kde4/Makefile')
-rw-r--r--deskutils/kdepim-runtime-kde4/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/deskutils/kdepim-runtime-kde4/Makefile b/deskutils/kdepim-runtime-kde4/Makefile
new file mode 100644
index 000000000000..ae72e8d46af0
--- /dev/null
+++ b/deskutils/kdepim-runtime-kde4/Makefile
@@ -0,0 +1,42 @@
+# Created by: miwi
+# $FreeBSD$
+
+PORTNAME= kdepim-runtime
+PORTVERSION= ${KDE4_KDEPIM_VERSION}
+PORTREVISION= 9
+CATEGORIES= deskutils kde
+MASTER_SITES= KDE/${KDE4_APPLICATIONS_BRANCH}/applications/${KDE4_APPLICATIONS_VERSION}/src
+DIST_SUBDIR= KDE/${PORTVERSION}
+PKGNAMESUFFIX= -kde4
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE PIM tools and services
+
+LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
+ libkgapi2.so:devel/libkgapi \
+ libkolab.so:devel/libkolab \
+ libkolabxml.so:textproc/libkolabxml \
+ libkfbapi.so:net/libkfbapi \
+ libqjson.so:devel/qjson
+
+CONFLICTS_INSTALL= kdepim-runtime44-4.*
+
+USES= cmake:outsource kde:4 shared-mime-info tar:xz
+USE_GNOME= libxml2 libxslt:build
+USE_KDE= kdelibs pimlibs \
+ akonadi automoc4
+USE_QT4= corelib dbus declarative designer_build gui network qtestlib \
+ script xml xmlpatterns \
+ qmake_build moc_build rcc_build uic_build
+USE_LDCONFIG= yes
+MAKE_ENV= XDG_CONFIG_HOME=/dev/null
+CMAKE_ARGS= -DKDEPIM_MOBILE_UI:BOOL=OFF
+
+post-patch:
+# Prevent updating MIME during build.
+ ${REINPLACE_CMD} -e '/^update_xdg_mimetypes/ d' \
+ ${PATCH_WRKSRC}/CMakeLists.txt \
+ ${PATCH_WRKSRC}/accountwizard/CMakeLists.txt \
+ ${PATCH_WRKSRC}/resources/facebook/serializer/CMakeLists.txt
+
+.include <bsd.port.mk>