aboutsummaryrefslogtreecommitdiff
path: root/deskutils/kdepim3/Makefile
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-03-09 19:41:12 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-03-09 19:41:12 +0000
commitf64c6af4f4d0803346188ad60d5055ea8b8d63dc (patch)
treea4ccebaea6c27a0834589e8629dbcdc5ee328c8b /deskutils/kdepim3/Makefile
parente96188d0c88794161a4508f2a16698da04fbba36 (diff)
downloadports-f64c6af4f4d0803346188ad60d5055ea8b8d63dc.tar.gz
ports-f64c6af4f4d0803346188ad60d5055ea8b8d63dc.zip
Notes
Diffstat (limited to 'deskutils/kdepim3/Makefile')
-rw-r--r--deskutils/kdepim3/Makefile44
1 files changed, 35 insertions, 9 deletions
diff --git a/deskutils/kdepim3/Makefile b/deskutils/kdepim3/Makefile
index 755b6d1ad517..5ad99ec867b3 100644
--- a/deskutils/kdepim3/Makefile
+++ b/deskutils/kdepim3/Makefile
@@ -7,16 +7,15 @@
PORTNAME= kdepim
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
CATEGORIES= deskutils mail news kde
MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
+MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Personal Information Management tools for KDE
-CONFLICTS= kdenetwork-3.1*
+CONFLICTS= kdenetwork-3.1.*
USE_KDELIBS_VER=3
PREFIX= ${KDE_PREFIX}
@@ -31,27 +30,54 @@ INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
KDE_BUILD_PLIST=yes
-.if exists(${LOCALBASE}/bin/pilot-link)
+OPTIONS= KPILOT "Build KPilot, hotsync software for KDE" off \
+ GNOKII "KAdressbook import/export for Nokia phones" off
+
+.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/pilot-xfer)
+. if !defined(WITH_KPILOT)
+KPILOT_OVERRIDE=yes
WITH_KPILOT= yes
+. endif
.endif
.if exists(${LOCALBASE}/bin/gnokii)
+. if !defined(WITH_GNOKII)
+GNOKII_OVERRIDE=yes
WITH_GNOKII= yes
+. endif
.endif
-.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.pre.mk>
-
.if defined(WITH_GNOKII)
-LIB_DEPENDS+= gnokii.1:${PORTSDIR}/comms/gnokii
+LIB_DEPENDS+= gnokii:${PORTSDIR}/comms/gnokii
.endif # defined ($(WITH_GNOKII))
.if defined(WITH_KPILOT)
-LIB_DEPENDS= mal:${PORTSDIR}/palm/libmal \
+LIB_DEPENDS+= mal:${PORTSDIR}/palm/libmal \
pisock:${PORTSDIR}/palm/pilot-link
PLIST_APPEND+= plist.kpilot
.endif # defined ($(WITH_KPILOT))
+pre-everything::
+.if defined(KPILOT_OVERRIDE)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "*******************************************************"
+ @${ECHO_MSG} "* pilot-link is installed but WITH_KPILOT is not set! *"
+ @${ECHO_MSG} "* WITH_KPILOT has been enabled automatically. *"
+ @${ECHO_MSG} "*******************************************************"
+ @${ECHO_MSG}
+.endif
+.if defined(GNOKII_OVERRIDE)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "*******************************************************"
+ @${ECHO_MSG} "* gnokii is installed but WITH_GNOKII is not set! *"
+ @${ECHO_MSG} "* WITH_GNOKII has been enabled automatically. *"
+ @${ECHO_MSG} "*******************************************************"
+ @${ECHO_MSG}
+.endif
+
pre-configure:
${REINPLACE_CMD} -e 's|-ldl||' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's|-lgnokii|-lgnokii -liconv -lintl|' ${WRKSRC}/configure