aboutsummaryrefslogtreecommitdiff
path: root/deskutils/kdepim3
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-01 16:59:20 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-01 16:59:20 +0000
commitebdc8740cb89f824afce83e20c29f487f5fffdb1 (patch)
tree1e21bd11cd298963c7da7054dbb6e9a6e6d1eb1d /deskutils/kdepim3
parentcb564fb324f294b0ac8ecd9ce88e4d9d4bd0608f (diff)
Notes
Diffstat (limited to 'deskutils/kdepim3')
-rw-r--r--deskutils/kdepim3/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/deskutils/kdepim3/Makefile b/deskutils/kdepim3/Makefile
index 097f437842af..7dda5939af21 100644
--- a/deskutils/kdepim3/Makefile
+++ b/deskutils/kdepim3/Makefile
@@ -37,13 +37,14 @@ CONFIGURE_ARGS= --with-gpg=${LOCALBASE}/bin/gpg \
--with-gpgsm=${LOCALBASE}/bin/gpgsm \
--with-ssl-dir=${OPENSSLBASE}
-OPTIONS= GNOKII "KAdressbook import/export for Nokia phones" off \
- KITCHENSYNC "PIM synchronization utility" off
+OPTIONS_DEFINE= GNOKII KITCHENSYNC
+GNOKII_DESC= KAdressbook import/export for Nokia phones
+KITCHENSYNC_DESC= PIM synchronization utility
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_KITCHENSYNC)
+.if ${PORT_OPTIONS:MKITCHENSYNC}
LIB_DEPENDS+= opensync.0:${PORTSDIR}/devel/libopensync022
PLIST_SUB+= KITCHENSYNC=""
.else
@@ -52,15 +53,15 @@ DO_NOT_COMPILE+=kitchensync
.endif
.if exists(${LOCALBASE}/bin/gnokii)
-. if !defined(WITH_GNOKII)
+. if empty(PORT_OPTIONS:MGNOKII)
GNOKII_OVERRIDE=yes
-WITH_GNOKII= yes
+PORT_OPTIONS+= GNOKII
. endif
.endif
-.if defined(WITH_GNOKII)
+.if ${PORT_OPTIONS:MGNOKII)
LIB_DEPENDS+= gnokii:${PORTSDIR}/comms/gnokii
-.endif # defined ($(WITH_GNOKII))
+.endif
.if defined(DO_NOT_COMPILE)
CONFIGURE_ENV+= DO_NOT_COMPILE="${DO_NOT_COMPILE}"
@@ -76,4 +77,4 @@ pre-everything::
@${ECHO_MSG}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>