aboutsummaryrefslogtreecommitdiff
path: root/deskutils/kdepim4
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-05-10 19:43:14 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-05-10 19:43:14 +0000
commit90e380e1cbd656e275c9638cb1b043378d6ecca7 (patch)
tree5c7300991656b5e02bd8042ba30767f043c9814c /deskutils/kdepim4
parentceea69bb4b397171f4247dcb81598e0e666267b9 (diff)
Notes
Diffstat (limited to 'deskutils/kdepim4')
-rw-r--r--deskutils/kdepim4/Makefile1
-rw-r--r--deskutils/kdepim4/distinfo4
-rw-r--r--deskutils/kdepim4/files/patch-grantleetheme__grantleethememanager.cpp25
-rw-r--r--deskutils/kdepim4/files/patch-kleopatra__CMakeLists.txt10
4 files changed, 27 insertions, 13 deletions
diff --git a/deskutils/kdepim4/Makefile b/deskutils/kdepim4/Makefile
index 21bc56bfc522..3c8344545045 100644
--- a/deskutils/kdepim4/Makefile
+++ b/deskutils/kdepim4/Makefile
@@ -3,7 +3,6 @@
PORTNAME= kdepim
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 1
CATEGORIES= deskutils kde
MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
diff --git a/deskutils/kdepim4/distinfo b/deskutils/kdepim4/distinfo
index f3ec03bf6cee..b22080fd32e1 100644
--- a/deskutils/kdepim4/distinfo
+++ b/deskutils/kdepim4/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/4.12.4/kdepim-4.12.4.tar.xz) = ff786d59f2914bef03470a8ee60f98cb059a73de06630837166d0a73ccf39a02
-SIZE (KDE/4.12.4/kdepim-4.12.4.tar.xz) = 14257840
+SHA256 (KDE/4.12.5/kdepim-4.12.5.tar.xz) = 5e26dc33b5d36eb305a24a834b153515990ea8a501498b63ee10103df94c6ff0
+SIZE (KDE/4.12.5/kdepim-4.12.5.tar.xz) = 14259060
diff --git a/deskutils/kdepim4/files/patch-grantleetheme__grantleethememanager.cpp b/deskutils/kdepim4/files/patch-grantleetheme__grantleethememanager.cpp
new file mode 100644
index 000000000000..55716c1d3ac9
--- /dev/null
+++ b/deskutils/kdepim4/files/patch-grantleetheme__grantleethememanager.cpp
@@ -0,0 +1,25 @@
+commit 8c64e00460a173141d69624cb36fca19801405b4
+Author: Raphael Kubo da Costa <rakuco@FreeBSD.org>
+Date: Sun May 4 23:33:29 2014 +0300
+
+ Stop needlessly calling KDirWatch::stopScan().
+
+ Not only should the call be unnecessary, but it also causes an infinite
+ loop when KDirWatch is set to use QFileSystemWatcher: the
+ KDirWatch::stopScan()/addDir()/startScan() combination makes the slot
+ where they're called end up being infinitely triggered.
+
+ Discussed with dfaure.
+
+ REVIEW: 117993
+
+--- grantleetheme/grantleethememanager.cpp
++++ grantleetheme/grantleethememanager.cpp
+@@ -95,7 +95,6 @@ public:
+ void updateThemesPath()
+ {
+ if ( !themesDirectories.isEmpty() ) {
+- watch->stopScan();
+ Q_FOREACH (const QString &directory, themesDirectories) {
+ watch->removeDir( directory );
+ }
diff --git a/deskutils/kdepim4/files/patch-kleopatra__CMakeLists.txt b/deskutils/kdepim4/files/patch-kleopatra__CMakeLists.txt
deleted file mode 100644
index 2a1de2975b97..000000000000
--- a/deskutils/kdepim4/files/patch-kleopatra__CMakeLists.txt
+++ /dev/null
@@ -1,10 +0,0 @@
---- kleopatra/CMakeLists.txt.orig 2013-01-23 22:57:35.000000000 +0100
-+++ kleopatra/CMakeLists.txt 2013-03-01 16:49:52.000000000 +0100
-@@ -361,6 +361,7 @@
- endif()
-
- add_definitions(-DKDE_DEFAULT_DEBUG_AREA=5151)
-+add_definitions(-DBOOST_TT_HAS_OPERATOR_HPP_INCLUDED)
-
- kde4_add_app_icon(_kleopatra_mainwindow_SRCS "hi*-app-kleopatra.png")
-