aboutsummaryrefslogtreecommitdiff
path: root/deskutils/kdepim4
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-04-06 20:47:58 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-04-06 20:47:58 +0000
commit7da47077fe6f02bc3335ac9ccca94ac8ffc33fcf (patch)
tree7938ea75ba24e1d16c323cf869fc7ce4a80dae49 /deskutils/kdepim4
parentc58bd6e866297bac05c1482b0a0c7f23c6600fe9 (diff)
Notes
Diffstat (limited to 'deskutils/kdepim4')
-rw-r--r--deskutils/kdepim4/Makefile1
-rw-r--r--deskutils/kdepim4/files/patch-kaddressbook__main.cpp16
-rw-r--r--deskutils/kdepim4/files/patch-kmail__kmmainwidget.cpp23
-rw-r--r--deskutils/kdepim4/files/patch-kmail__main.cpp17
-rw-r--r--deskutils/kdepim4/files/patch-kmail__popaccount.cpp21
-rw-r--r--deskutils/kdepim4/files/patch-kontact__src__main.cpp14
6 files changed, 92 insertions, 0 deletions
diff --git a/deskutils/kdepim4/Makefile b/deskutils/kdepim4/Makefile
index ce22ee241e3a..1902c8862328 100644
--- a/deskutils/kdepim4/Makefile
+++ b/deskutils/kdepim4/Makefile
@@ -6,6 +6,7 @@
PORTNAME= kdepim
PORTVERSION= ${KDEPIM4_VERSION}
+PORTREVISION= 1
CATEGORIES= deskutils kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDEPIM4_BRANCH}/kdepim-${PORTVERSION}/src
diff --git a/deskutils/kdepim4/files/patch-kaddressbook__main.cpp b/deskutils/kdepim4/files/patch-kaddressbook__main.cpp
new file mode 100644
index 000000000000..9e9e0d8ffd10
--- /dev/null
+++ b/deskutils/kdepim4/files/patch-kaddressbook__main.cpp
@@ -0,0 +1,16 @@
+--- kaddressbook/main.cpp
++++ kaddressbook/main.cpp
+@@ -49,11 +49,13 @@ int main( int argc, char **argv )
+ MainWindow *window = new MainWindow;
+ window->show();
+
++#if !KDE_IS_VERSION(4,6,0)
+ if ( !Akonadi::Control::start( window ) ) {
+ //TODO: add message box after string freeze
+ kWarning() << "Unable to start Akonadi server, exit application";
+ return 1;
+ }
++#endif
+
+ return app.exec();
+ }
diff --git a/deskutils/kdepim4/files/patch-kmail__kmmainwidget.cpp b/deskutils/kdepim4/files/patch-kmail__kmmainwidget.cpp
new file mode 100644
index 000000000000..05c026f8bda5
--- /dev/null
+++ b/deskutils/kdepim4/files/patch-kmail__kmmainwidget.cpp
@@ -0,0 +1,23 @@
+--- kmail/kmmainwidget.cpp
++++ kmail/kmmainwidget.cpp
+@@ -165,6 +165,9 @@ using KMail::TemplateParser;
+
+ #include <errno.h> // ugh
+
++#include <akonadi/control.h>
++#include <akonadi/servermanager.h>
++
+ #include "kmmainwidget.moc"
+
+ K_GLOBAL_STATIC( KMMainWidget::PtrList, theMainWidgetList )
+@@ -186,6 +189,10 @@ KMMainWidget::KMMainWidget( QWidget *parent, KXMLGUIClient *aGUIClient,
+ mVacationIndicatorActive( false ),
+ mGoToFirstUnreadMessageInSelectedFolder( false )
+ {
++#if KDE_IS_VERSION(4,6,0)
++ Akonadi::Control::widgetNeedsAkonadi(this);
++ Akonadi::ServerManager::start();
++#endif
+ // must be the first line of the constructor:
+ mStartupDone = false;
+ mWasEverShown = false;
diff --git a/deskutils/kdepim4/files/patch-kmail__main.cpp b/deskutils/kdepim4/files/patch-kmail__main.cpp
new file mode 100644
index 000000000000..bbdfc3e86f7d
--- /dev/null
+++ b/deskutils/kdepim4/files/patch-kmail__main.cpp
@@ -0,0 +1,17 @@
+--- kmail/main.cpp
++++ kmail/main.cpp
+@@ -145,12 +145,14 @@ int main(int argc, char *argv[])
+ app.setEventLoopReached();
+ app.delayedInstanceCreation();
+
++#if !KDE_IS_VERSION(4,6,0)
+ // Start Akonadi
+ if ( !Akonadi::Control::start( kmkernel->getKMMainWidget() ) ) {
+ //TODO: add message box after string freeze
+ kWarning() << "Unable to start Akonadi server, exit application";
+ return 1;
+ }
++#endif
+
+ // Go!
+ int ret = qApp->exec();
diff --git a/deskutils/kdepim4/files/patch-kmail__popaccount.cpp b/deskutils/kdepim4/files/patch-kmail__popaccount.cpp
new file mode 100644
index 000000000000..8c8c83e8ecf4
--- /dev/null
+++ b/deskutils/kdepim4/files/patch-kmail__popaccount.cpp
@@ -0,0 +1,21 @@
+--- kmail/popaccount.cpp
++++ kmail/popaccount.cpp
+@@ -959,11 +959,13 @@ void PopAccount::slotData( KIO::Job* job, const QByteArray &data)
+ .subs( numBytesToRead/1024 ).subs( mLogin ).subs( mHost )
+ .toString();
+ }
+- mMailCheckProgressItem->setStatus( msg );
+- mMailCheckProgressItem->setProgress(
+- (numBytesToRead <= 100) ? 50 // We never know what the server tells us
+- // This way of dividing is required for > 21MB of mail
+- : (numBytesRead / (numBytesToRead / 100)) );
++ if( mMailCheckProgressItem ) {
++ mMailCheckProgressItem->setStatus( msg );
++ mMailCheckProgressItem->setProgress(
++ (numBytesToRead <= 100) ? 50 // We never know what the server tells us
++ // This way of dividing is required for > 21MB of mail
++ : (numBytesRead / (numBytesToRead / 100)) );
++ }
+ }
+ return;
+ }
diff --git a/deskutils/kdepim4/files/patch-kontact__src__main.cpp b/deskutils/kdepim4/files/patch-kontact__src__main.cpp
new file mode 100644
index 000000000000..1e6ce7237350
--- /dev/null
+++ b/deskutils/kdepim4/files/patch-kontact__src__main.cpp
@@ -0,0 +1,14 @@
+--- kontact/src/main.cpp
++++ kontact/src/main.cpp
+@@ -199,9 +199,11 @@ int main( int argc, char **argv )
+
+ KontactApp app;
+
++#if !KDE_IS_VERSION(4,6,0)
+ // KDE 4.4: do akonadi startup before creating any window, since creating
+ // the window loads kmail. In 4.5 we'll do this startup async instead.
+ Akonadi::Control::start( 0 );
++#endif
+
+ // Qt doesn't treat the system tray as a window, and therefore Qt would quit
+ // the event loop when an error message is clicked away while Kontact is in the