aboutsummaryrefslogtreecommitdiff
path: root/deskutils/kdepim
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-12-04 03:47:18 +0000
committerWill Andrews <will@FreeBSD.org>2001-12-04 03:47:18 +0000
commit1d206a3483e848f4589962473bdf169313ea740f (patch)
tree269caee3e56d61cd6318b44d85c3ff64b32d57b6 /deskutils/kdepim
parentfb2c030e15fb4b426c06fee701c06b7f44c272ab (diff)
downloadports-1d206a3483e848f4589962473bdf169313ea740f.tar.gz
ports-1d206a3483e848f4589962473bdf169313ea740f.zip
Notes
Diffstat (limited to 'deskutils/kdepim')
-rw-r--r--deskutils/kdepim/Makefile34
-rw-r--r--deskutils/kdepim/distinfo2
-rw-r--r--deskutils/kdepim/pkg-plist39
3 files changed, 70 insertions, 5 deletions
diff --git a/deskutils/kdepim/Makefile b/deskutils/kdepim/Makefile
index 0e10fb385d36..787e1269838d 100644
--- a/deskutils/kdepim/Makefile
+++ b/deskutils/kdepim/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= kdepim
-PORTVERSION= 2.2.1
+PORTVERSION= 2.2.2
CATEGORIES= deskutils kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -14,14 +14,44 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
+BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
+ automake14:${PORTSDIR}/devel/automake14 \
+ objprelink:${PORTSDIR}/devel/objprelink
+LIB_DEPENDS= pisock:${PORTSDIR}/palm/pilot-link
+
USE_KDELIBS_VER=2
USE_BISON= yes
USE_BZIP2= yes
INSTALLS_SHLIB= yes
-USE_AUTOCONF= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-objprelink \
+ --with-extra-includes=${LOCALBASE}/pilot/include \
+ --with-extra-libs=${LOCALBASE}/pilot/lib
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
+CONFIGURE_ARGS+=--enable-final
+.endif
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
+CONFIGURE_ARGS+=--disable-debug
+.endif
+QTCPPFLAGS= -I${LOCALBASE}/pilot/include -L${LOCALBASE}/pilot/lib
+QTLDFLAGS= ${QTCPPFLAGS}
+CONFIGURE_ENV+= LIBS="${QTLDFLAGS}"
+MAKE_ENV= ${CONFIGURE_ENV}
USE_GMAKE= yes
pre-configure:
+ ${MKDIR} ${WRKSRC}/auto-bin
+.for AC in autoconf autoheader
+ ${LN} -sf ${LOCALBASE}/bin/${AC}213 ${WRKSRC}/auto-bin/${AC}
+.endfor
+.for AM in automake aclocal
+ ${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
+.endfor
+ cd ${WRKSRC} && env PATH=$$PATH:${WRKSRC}/auto-bin \
+ ${GMAKE} -f Makefile.cvs
+ find ${WRKSRC}/kpilot \( -name Makefile.in -o -name Makefile.am \) | \
+ xargs ${PERL} -pi -e \
+ "s@LDFLAGS =@LDFLAGS=-L${LOCALBASE}/pilot/lib@g"
find ${WRKSRC}/libical -name Makefile.in | xargs ${PERL} -pi -e \
"s|INSTALL = \@INSTALL\@|INSTALL=${INSTALL} ${COPY} -o ${BINOWN} -g ${BINGRP}|g"
diff --git a/deskutils/kdepim/distinfo b/deskutils/kdepim/distinfo
index 291838009c90..37134e643f7d 100644
--- a/deskutils/kdepim/distinfo
+++ b/deskutils/kdepim/distinfo
@@ -1 +1 @@
-MD5 (KDE/kdepim-2.2.1.tar.bz2) = 2b72725439279241b75c8048a79ca955
+MD5 (KDE/kdepim-2.2.2.tar.bz2) = 55daf69b90108509895814b96fc8b671
diff --git a/deskutils/kdepim/pkg-plist b/deskutils/kdepim/pkg-plist
index c9d488388eb2..6189673215b2 100644
--- a/deskutils/kdepim/pkg-plist
+++ b/deskutils/kdepim/pkg-plist
@@ -1,8 +1,18 @@
+bin/abbrowser_conduit
bin/alarmd
+bin/conduitExpense
+bin/conduitKNotes
bin/ical2vcal
bin/kandy
bin/kandy_client
bin/korganizer
+bin/kpilot
+bin/kpilotDaemon
+bin/null_conduit
+bin/pilotListener
+bin/popmail_conduit
+bin/todoconduit
+bin/vcalconduit
include/kgantt/KGantt.h
include/kgantt/KGanttBarConfig.h
include/kgantt/KGanttItem.h
@@ -74,6 +84,8 @@ lib/libvcard.so
lib/libvcard.so.0
share/applnk/Applications/korganizer.desktop
share/applnk/Utilities/kandy.desktop
+share/applnk/Utilities/kpilot.desktop
+share/applnk/Utilities/kpilotdaemon.desktop
share/apps/kandy/default.kandy
share/apps/kandy/kandymobileui.rc
share/apps/kandy/kandyui.rc
@@ -189,6 +201,11 @@ share/apps/korganizer/sounds/lightmag.wav
share/apps/korganizer/sounds/onscreen.wav
share/apps/korganizer/sounds/spinout.wav
share/apps/korganizer/tips
+share/apps/kpilot/icons/hicolor/16x16/actions/backup.png
+share/apps/kpilot/icons/hicolor/16x16/actions/fastsync.png
+share/apps/kpilot/icons/hicolor/16x16/actions/hotsync.png
+share/apps/kpilot/icons/hicolor/16x16/actions/restore.png
+share/apps/kpilot/kpilotui.rc
share/autostart/alarmd.desktop
share/config/korganizerrc
share/doc/HTML/en/kandy/common
@@ -251,17 +268,34 @@ share/doc/HTML/en/kpilot/toolbar_backup.png
share/doc/HTML/en/kpilot/toolbar_hotsync.png
share/icons/hicolor/16x16/apps/kandy.png
share/icons/hicolor/16x16/apps/korganizer.png
+share/icons/hicolor/16x16/apps/kpilot.png
share/icons/hicolor/32x32/apps/kandy.png
share/icons/hicolor/32x32/apps/korganizer.png
+share/icons/hicolor/32x32/apps/kpilot.png
share/icons/hicolor/48x48/apps/korganizer.png
+share/icons/locolor/16x16/apps/kpilot.xpm
+share/services/abbrowser_conduit.desktop
+share/services/expense-conduit.desktop
+share/services/knotes-conduit.desktop
+share/services/null-conduit.desktop
+share/services/popmail-conduit.desktop
+share/services/todo-conduit.desktop
+share/services/vcal-conduit.desktop
+share/servicetypes/kpilotconduit.desktop
+@dirrm share/icons/locolor/16x16/apps
+@dirrm share/icons/locolor/16x16
+@dirrm share/icons/locolor
@dirrm share/icons/hicolor/48x48/apps
@dirrm share/icons/hicolor/32x32/apps
-@dirrm share/icons/hicolor/16x16/apps
@dirrm share/doc/HTML/en/kpilot
@dirrm share/doc/HTML/en/korganizer
@dirrm share/doc/HTML/en/kandy
-@dirrm share/config
@dirrm share/autostart
+@dirrm share/apps/kpilot/icons/hicolor/16x16/actions
+@dirrm share/apps/kpilot/icons/hicolor/16x16
+@dirrm share/apps/kpilot/icons/hicolor
+@dirrm share/apps/kpilot/icons
+@dirrm share/apps/kpilot
@dirrm share/apps/korganizer/sounds
@dirrm share/apps/korganizer/icons/hicolor/32x32/actions
@dirrm share/apps/korganizer/icons/hicolor/32x32
@@ -286,5 +320,6 @@ share/icons/hicolor/48x48/apps/korganizer.png
@dirrm share/apps/kandy
@dirrm share/applnk/Utilities
@dirrm share/applnk/Applications
+@dirrm share/applnk
@dirrm include/rmm
@dirrm include/kgantt