aboutsummaryrefslogtreecommitdiff
path: root/deskutils/kompose/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2004-09-01 22:04:50 +0000
committerWill Andrews <will@FreeBSD.org>2004-09-01 22:04:50 +0000
commit1d31bc5cbf97fe44c939702e4261afcd8e005c2b (patch)
treedb80b4c913e9a6e4a5fd1d4bfa4f1938c52e3652 /deskutils/kompose/Makefile
parentd956ad3a7b4ea6cfe3168bef612953ca2758f609 (diff)
Notes
Diffstat (limited to 'deskutils/kompose/Makefile')
-rw-r--r--deskutils/kompose/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/deskutils/kompose/Makefile b/deskutils/kompose/Makefile
new file mode 100644
index 000000000000..6dda58fe27af
--- /dev/null
+++ b/deskutils/kompose/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: kompose
+# Date created: 31 Aug 2004
+# Whom: Lauri Watts <lauri@kde.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kompose
+PORTVERSION= 0.4.2
+CATEGORIES= deskutils kde
+MASTER_SITES= http://download.berlios.de/kompose/
+
+MAINTAINER= lauri@kde.org
+COMMENT= Full-screen task manager similar to Exposé(tm)
+
+LIB_DEPENDS= Imlib2:${PORTSDIR}/graphics/imlib2
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_KDELIBS_VER= 3
+GNU_CONFIGURE= yes
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2 ||g' ${WRKSRC}/configure
+
+.include <bsd.port.mk>