aboutsummaryrefslogtreecommitdiff
path: root/deskutils/labyrinth
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-12-19 14:19:54 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-12-19 14:19:54 +0000
commitc3e2a5ad4a15b1b1e9005fe3ef947362f8ca6efd (patch)
treec61c38661a10fe4f03b4a827b58d48b89cabff07 /deskutils/labyrinth
parent97a9a3b5051755670afa96a97b64225cd5624778 (diff)
downloadports-c3e2a5ad4a15b1b1e9005fe3ef947362f8ca6efd.tar.gz
ports-c3e2a5ad4a15b1b1e9005fe3ef947362f8ca6efd.zip
Notes
Diffstat (limited to 'deskutils/labyrinth')
-rw-r--r--deskutils/labyrinth/Makefile26
-rw-r--r--deskutils/labyrinth/distinfo3
-rw-r--r--deskutils/labyrinth/files/patch-data_Makefile.in15
-rw-r--r--deskutils/labyrinth/files/patch-src_labyrinth.py23
-rw-r--r--deskutils/labyrinth/pkg-descr6
-rw-r--r--deskutils/labyrinth/pkg-plist75
6 files changed, 148 insertions, 0 deletions
diff --git a/deskutils/labyrinth/Makefile b/deskutils/labyrinth/Makefile
new file mode 100644
index 000000000000..a2f2467456c7
--- /dev/null
+++ b/deskutils/labyrinth/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: labyrinth
+# Date created: 2008-09-28
+# Whom: Romain Tartiere <romain@blogreen.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= labyrinth
+PORTVERSION= 0.4.1
+CATEGORIES= deskutils python
+MASTER_SITES= GOOGLE_CODE
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= romain@blogreen.org
+COMMENT= Mind-mapping tool for GNOME
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-0.4.0
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ENV= GMSGFMT=msgfmt
+USE_GNOME= pygnome2 gnomedesktop gnomehack
+USE_PYTHON= yes
+USE_GETTEXT= yes
+INSTALLS_ICONS= yes
+
+.include <bsd.port.mk>
diff --git a/deskutils/labyrinth/distinfo b/deskutils/labyrinth/distinfo
new file mode 100644
index 000000000000..7888580a2679
--- /dev/null
+++ b/deskutils/labyrinth/distinfo
@@ -0,0 +1,3 @@
+MD5 (labyrinth_0.4.1.tar.gz) = 74a9f9ae7710ef99ab2597c9d4eb24b1
+SHA256 (labyrinth_0.4.1.tar.gz) = 3fafcbd622074eaa80710d7eb76849d5e9b1e36742f48110e2425eb760e2d53c
+SIZE (labyrinth_0.4.1.tar.gz) = 553527
diff --git a/deskutils/labyrinth/files/patch-data_Makefile.in b/deskutils/labyrinth/files/patch-data_Makefile.in
new file mode 100644
index 000000000000..eef192e3d638
--- /dev/null
+++ b/deskutils/labyrinth/files/patch-data_Makefile.in
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- data/Makefile.in.orig
++++ data/Makefile.in
+@@ -437,8 +437,7 @@
+ @INTLTOOL_DESKTOP_RULE@
+
+ install-icons:
+-# This sucks
+- for size in 16x16 22x22 24x24 scalable; do mkdir --parents $(DESTDIR)/$(datadir)/icons/hicolor/$$size/apps; done
++ for size in 16x16 22x22 24x24 scalable; do install -d $(DESTDIR)/$(datadir)/icons/hicolor/$$size/apps; done
+ install -m 644 $(srcdir)/labyrinth-16.png $(DESTDIR)/$(datadir)/icons/hicolor/16x16/apps/labyrinth.png
+ install -m 644 $(srcdir)/labyrinth-22.png $(DESTDIR)/$(datadir)/icons/hicolor/22x22/apps/labyrinth.png
+ install -m 644 $(srcdir)/labyrinth-24.png $(DESTDIR)/$(datadir)/icons/hicolor/24x24/apps/labyrinth.png
diff --git a/deskutils/labyrinth/files/patch-src_labyrinth.py b/deskutils/labyrinth/files/patch-src_labyrinth.py
new file mode 100644
index 000000000000..a4c9d273a40e
--- /dev/null
+++ b/deskutils/labyrinth/files/patch-src_labyrinth.py
@@ -0,0 +1,23 @@
+
+$FreeBSD$
+
+--- src/labyrinth.py.orig
++++ src/labyrinth.py
+@@ -56,11 +56,12 @@
+ if hasattr(gettext, 'bind_textdomain_codeset'):
+ gettext.bind_textdomain_codeset('labyrinth','UTF-8')
+ gettext.textdomain('labyrinth')
+-if not os.name == 'nt':
+- locale.bindtextdomain('labyrinth', localedir)
+- if hasattr(locale, 'bind_textdomain_codeset'):
+- locale.bind_textdomain_codeset('labyrinth','UTF-8')
+- locale.textdomain('labyrinth')
++if hasattr(locale, 'bindtextdomain'):
++ if not os.name == 'nt':
++ locale.bindtextdomain('labyrinth', localedir)
++ if hasattr(locale, 'bind_textdomain_codeset'):
++ locale.bind_textdomain_codeset('labyrinth','UTF-8')
++ locale.textdomain('labyrinth')
+
+ gtk.glade.bindtextdomain('labyrinth')
+ gtk.glade.textdomain('labyrinth')
diff --git a/deskutils/labyrinth/pkg-descr b/deskutils/labyrinth/pkg-descr
new file mode 100644
index 000000000000..ab2c4a6faf84
--- /dev/null
+++ b/deskutils/labyrinth/pkg-descr
@@ -0,0 +1,6 @@
+Labyrinth is a lightweight mind-mapping tool for the GNOME desktop. It is
+written in Python and uses cairo for its rendering. It is intended to be as
+light and intuitive as possible, but still provide a wide range of powerful
+features.
+
+WWW: http://code.google.com/p/labyrinth/
diff --git a/deskutils/labyrinth/pkg-plist b/deskutils/labyrinth/pkg-plist
new file mode 100644
index 000000000000..41b48175d792
--- /dev/null
+++ b/deskutils/labyrinth/pkg-plist
@@ -0,0 +1,75 @@
+@comment $FreeBSD$
+bin/labyrinth
+%%PYTHON_SITELIBDIR%%/labyrinth/BaseThought.py
+%%PYTHON_SITELIBDIR%%/labyrinth/BaseThought.pyc
+%%PYTHON_SITELIBDIR%%/labyrinth/BaseThought.pyo
+%%PYTHON_SITELIBDIR%%/labyrinth/Browser.py
+%%PYTHON_SITELIBDIR%%/labyrinth/Browser.pyc
+%%PYTHON_SITELIBDIR%%/labyrinth/Browser.pyo
+%%PYTHON_SITELIBDIR%%/labyrinth/DrawingThought.py
+%%PYTHON_SITELIBDIR%%/labyrinth/DrawingThought.pyc
+%%PYTHON_SITELIBDIR%%/labyrinth/DrawingThought.pyo
+%%PYTHON_SITELIBDIR%%/labyrinth/ImageThought.py
+%%PYTHON_SITELIBDIR%%/labyrinth/ImageThought.pyc
+%%PYTHON_SITELIBDIR%%/labyrinth/ImageThought.pyo
+%%PYTHON_SITELIBDIR%%/labyrinth/Links.py
+%%PYTHON_SITELIBDIR%%/labyrinth/Links.pyc
+%%PYTHON_SITELIBDIR%%/labyrinth/Links.pyo
+%%PYTHON_SITELIBDIR%%/labyrinth/MMapArea.py
+%%PYTHON_SITELIBDIR%%/labyrinth/MMapArea.pyc
+%%PYTHON_SITELIBDIR%%/labyrinth/MMapArea.pyo
+%%PYTHON_SITELIBDIR%%/labyrinth/MainWindow.py
+%%PYTHON_SITELIBDIR%%/labyrinth/MainWindow.pyc
+%%PYTHON_SITELIBDIR%%/labyrinth/MainWindow.pyo
+%%PYTHON_SITELIBDIR%%/labyrinth/MapList.py
+%%PYTHON_SITELIBDIR%%/labyrinth/MapList.pyc
+%%PYTHON_SITELIBDIR%%/labyrinth/MapList.pyo
+%%PYTHON_SITELIBDIR%%/labyrinth/PeriodicSaveThread.py
+%%PYTHON_SITELIBDIR%%/labyrinth/PeriodicSaveThread.pyc
+%%PYTHON_SITELIBDIR%%/labyrinth/PeriodicSaveThread.pyo
+%%PYTHON_SITELIBDIR%%/labyrinth/TextBufferMarkup.py
+%%PYTHON_SITELIBDIR%%/labyrinth/TextBufferMarkup.pyc
+%%PYTHON_SITELIBDIR%%/labyrinth/TextBufferMarkup.pyo
+%%PYTHON_SITELIBDIR%%/labyrinth/TextThought.py
+%%PYTHON_SITELIBDIR%%/labyrinth/TextThought.pyc
+%%PYTHON_SITELIBDIR%%/labyrinth/TextThought.pyo
+%%PYTHON_SITELIBDIR%%/labyrinth/TrayIcon.py
+%%PYTHON_SITELIBDIR%%/labyrinth/TrayIcon.pyc
+%%PYTHON_SITELIBDIR%%/labyrinth/TrayIcon.pyo
+%%PYTHON_SITELIBDIR%%/labyrinth/UndoManager.py
+%%PYTHON_SITELIBDIR%%/labyrinth/UndoManager.pyc
+%%PYTHON_SITELIBDIR%%/labyrinth/UndoManager.pyo
+%%PYTHON_SITELIBDIR%%/labyrinth/__init__.py
+%%PYTHON_SITELIBDIR%%/labyrinth/__init__.pyc
+%%PYTHON_SITELIBDIR%%/labyrinth/__init__.pyo
+%%PYTHON_SITELIBDIR%%/labyrinth/defs.py
+%%PYTHON_SITELIBDIR%%/labyrinth/defs.pyc
+%%PYTHON_SITELIBDIR%%/labyrinth/defs.pyo
+%%PYTHON_SITELIBDIR%%/labyrinth/prefs.py
+%%PYTHON_SITELIBDIR%%/labyrinth/prefs.pyc
+%%PYTHON_SITELIBDIR%%/labyrinth/prefs.pyo
+%%PYTHON_SITELIBDIR%%/labyrinth/utils.py
+%%PYTHON_SITELIBDIR%%/labyrinth/utils.pyc
+%%PYTHON_SITELIBDIR%%/labyrinth/utils.pyo
+share/applications/labyrinth.desktop
+share/icons/hicolor/16x16/apps/labyrinth.png
+share/icons/hicolor/22x22/apps/labyrinth.png
+share/icons/hicolor/24x24/apps/labyrinth.png
+share/icons/hicolor/scalable/apps/labyrinth.svg
+%%DATADIR%%/labyrinth-ui.xml
+%%DATADIR%%/labyrinth.glade
+share/locale/ca/LC_MESSAGES/labyrinth.mo
+share/locale/cs/LC_MESSAGES/labyrinth.mo
+share/locale/de/LC_MESSAGES/labyrinth.mo
+share/locale/eu/LC_MESSAGES/labyrinth.mo
+share/locale/fa/LC_MESSAGES/labyrinth.mo
+share/locale/fr/LC_MESSAGES/labyrinth.mo
+share/locale/it/LC_MESSAGES/labyrinth.mo
+share/locale/nl/LC_MESSAGES/labyrinth.mo
+share/locale/pl/LC_MESSAGES/labyrinth.mo
+share/locale/pt_BR/LC_MESSAGES/labyrinth.mo
+share/locale/pt_PT/LC_MESSAGES/labyrinth.mo
+share/locale/ru/LC_MESSAGES/labyrinth.mo
+share/locale/sv/LC_MESSAGES/labyrinth.mo
+@dirrm %%DATADIR%%
+@dirrm %%PYTHON_SITELIBDIR%%/labyrinth