aboutsummaryrefslogtreecommitdiff
path: root/deskutils/libopensync-plugin-synce-legacy
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-01-16 14:06:07 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-01-16 14:06:07 +0000
commit3f30251c579501b8559943f4a44414c9f75a6251 (patch)
treee7ff5f352a237229ef6fc0f6950274ac49982b89 /deskutils/libopensync-plugin-synce-legacy
parentd8502386526d42bfe7a67029bd9553ffb1565d17 (diff)
downloadports-3f30251c579501b8559943f4a44414c9f75a6251.tar.gz
ports-3f30251c579501b8559943f4a44414c9f75a6251.zip
Notes
Diffstat (limited to 'deskutils/libopensync-plugin-synce-legacy')
-rw-r--r--deskutils/libopensync-plugin-synce-legacy/Makefile29
-rw-r--r--deskutils/libopensync-plugin-synce-legacy/distinfo3
-rw-r--r--deskutils/libopensync-plugin-synce-legacy/files/patch-src_synce_file.c66
-rw-r--r--deskutils/libopensync-plugin-synce-legacy/pkg-descr4
-rw-r--r--deskutils/libopensync-plugin-synce-legacy/pkg-plist7
5 files changed, 109 insertions, 0 deletions
diff --git a/deskutils/libopensync-plugin-synce-legacy/Makefile b/deskutils/libopensync-plugin-synce-legacy/Makefile
new file mode 100644
index 000000000000..4c6241324720
--- /dev/null
+++ b/deskutils/libopensync-plugin-synce-legacy/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: libopensync-plugin-synce-legacy
+# Date created: 19 June 2008
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libopensync-plugin-synce
+PORTVERSION= 0.22
+CATEGORIES= deskutils palm
+MASTER_SITES= http://www.opensync.org/download/releases/${PORTVERSION}/
+PKGNAMESUFFIX= -legacy
+
+MAINTAINER= ports@logvinov.com
+COMMENT= SynCE legacy plugin for the OpenSync framework
+
+LIB_DEPENDS= opensync.0:${PORTSDIR}/devel/libopensync022 \
+ rra.0:${PORTSDIR}/palm/synce-librra
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GNOME= glib20 libxml2
+
+CFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CONFIGURE_ENV= CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+
+.include <bsd.port.mk>
diff --git a/deskutils/libopensync-plugin-synce-legacy/distinfo b/deskutils/libopensync-plugin-synce-legacy/distinfo
new file mode 100644
index 000000000000..3eb4af3ca7e2
--- /dev/null
+++ b/deskutils/libopensync-plugin-synce-legacy/distinfo
@@ -0,0 +1,3 @@
+MD5 (libopensync-plugin-synce-0.22.tar.bz2) = f325b7dd9f273c46e77fb7b337325880
+SHA256 (libopensync-plugin-synce-0.22.tar.bz2) = 72166c8c6e2a45f38fa260a3eb4920b3f55b3cb4cd04c29d6889b9411e369b57
+SIZE (libopensync-plugin-synce-0.22.tar.bz2) = 240364
diff --git a/deskutils/libopensync-plugin-synce-legacy/files/patch-src_synce_file.c b/deskutils/libopensync-plugin-synce-legacy/files/patch-src_synce_file.c
new file mode 100644
index 000000000000..5ca648bbef2d
--- /dev/null
+++ b/deskutils/libopensync-plugin-synce-legacy/files/patch-src_synce_file.c
@@ -0,0 +1,66 @@
+--- src/synce_file.c.orig 2007-03-27 22:14:24.000000000 +1000
++++ src/synce_file.c 2008-12-27 23:47:34.000000000 +0900
+@@ -114,7 +114,7 @@
+ size = CeGetFileSize(h, NULL);
+ CeCloseHandle(h);
+ } else size = 0;
+- hash = g_strdup_printf("%ld-%u", ff->last_mod, size);
++ hash = g_strdup_printf("%ld-%u", (long)ff->last_mod, size);
+ osync_change_set_hash(change, hash);
+ fprintf(stderr, "%s(%s) hash %s\n", __func__, path, hash);
+ g_free(hash);
+@@ -220,7 +220,8 @@
+ fileFormat *ff;
+ WCHAR *wfn;
+ DWORD wr, e, opt;
+- char *p, *s, *fn, *lfn, *str;
++ char *p, *fn, *lfn, *str;
++ const char *s;
+ OSyncChangeType ct;
+
+ osync_debug("SYNCE-SYNC", 4, "start: %s", __func__);
+@@ -495,7 +496,7 @@
+ if (r == 0) {
+ /* Error */
+ DWORD e = CeGetLastError();
+- char *s = synce_strerror(e);
++ const char *s = synce_strerror(e);
+ osync_context_report_error(ctx, 1, "Error from CeReadFile (%d:%s)",
+ e, s);
+ CeCloseHandle(h);
+@@ -672,7 +673,7 @@
+ &cnt, &find_data) == 0) {
+ /* FIX ME what does failure mean here ? */
+ e = CeGetLastError();
+- s = synce_strerror(e);
++ s = (char*)synce_strerror(e);
+ fprintf(stderr,
+ "CeFindAllFiles(%s) : %s",
+ lfn, s);
+@@ -686,7 +687,7 @@
+ fprintf(stderr, "Yow create(%s)\n", lfn);
+ if (CeCreateDirectory(w, NULL) == 0) {
+ e = CeGetLastError();
+- s = synce_strerror(e);
++ s = (char*)synce_strerror(e);
+ fprintf(stderr,
+ "CeCreateDirectory(%s) : %s",
+ lfn, s);
+@@ -707,7 +708,7 @@
+ CREATE_NEW, FILE_ATTRIBUTE_NORMAL, 0);
+ if (h == 0) {
+ e = CeGetLastError();
+- s = synce_strerror(e);
++ s = (char*)synce_strerror(e);
+ fprintf(stderr, "CeCreateFile(%s) : %s", lfn, s);
+ free(lfn);
+ return FALSE;
+@@ -719,7 +720,7 @@
+ DWORD wr;
+ if (CeWriteFile(h, "Yow", 3, &wr, NULL) == 0) {
+ e = CeGetLastError();
+- s = synce_strerror(e);
++ s = (char*)synce_strerror(e);
+ fprintf(stderr, "CeWriteFile(%s) : %s", lfn, s);
+ free(lfn);
+ return FALSE;
diff --git a/deskutils/libopensync-plugin-synce-legacy/pkg-descr b/deskutils/libopensync-plugin-synce-legacy/pkg-descr
new file mode 100644
index 000000000000..08081862948a
--- /dev/null
+++ b/deskutils/libopensync-plugin-synce-legacy/pkg-descr
@@ -0,0 +1,4 @@
+This plugin allows applications using OpenSync to synchronise to and from
+Windows Mobile 2003 based devices.
+
+WWW: http://www.opensync.org/
diff --git a/deskutils/libopensync-plugin-synce-legacy/pkg-plist b/deskutils/libopensync-plugin-synce-legacy/pkg-plist
new file mode 100644
index 000000000000..79c29d73aaa9
--- /dev/null
+++ b/deskutils/libopensync-plugin-synce-legacy/pkg-plist
@@ -0,0 +1,7 @@
+lib/opensync/plugins/synce_plugin.so
+lib/opensync/plugins/synce_plugin.la
+share/opensync/defaults/synce-plugin
+@dirrmtry lib/opensync/plugins
+@dirrmtry lib/opensync
+@dirrmtry share/opensync/defaults
+@dirrmtry share/opensync